summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-02-22 19:10:05 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:25 +0100
commitae08ee70a430789e08827bbb00958ae1bb7aabb3 (patch)
tree29097305affbc6518c95f7f0478b26b0d284e36f /meta-gnome
parent0acb0d7292edbb1e64b2d1ff04de439706ae4aa5 (diff)
downloadmeta-openembedded-ae08ee70a430789e08827bbb00958ae1bb7aabb3.tar.gz
gnumeric: fix gobject introspection support
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnumeric/gnumeric/0001-configure.in-drop-introspection-macros-replace-them-.patch84
-rw-r--r--meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb5
2 files changed, 87 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/gnumeric/gnumeric/0001-configure.in-drop-introspection-macros-replace-them-.patch b/meta-gnome/recipes-gnome/gnumeric/gnumeric/0001-configure.in-drop-introspection-macros-replace-them-.patch
new file mode 100644
index 000000000..914d2ccf9
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnumeric/gnumeric/0001-configure.in-drop-introspection-macros-replace-them-.patch
@@ -0,0 +1,84 @@
1From de5f0a535d6ea1932d2c7de53bd33510c8682ee7 Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex.kanavin@gmail.com>
3Date: Mon, 22 Feb 2016 16:34:03 +0200
4Subject: [PATCH] configure.in: drop introspection macros, replace them with a
5 standard one
6
7Upstream-Status: Pending
8Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
9---
10 configure.in | 57 +--------------------------------------------------------
11 1 file changed, 1 insertion(+), 56 deletions(-)
12
13diff --git a/configure.in b/configure.in
14index 8e1aa37..3086503 100644
15--- a/configure.in
16+++ b/configure.in
17@@ -934,63 +934,8 @@ AC_SUBST(MONO_CFLAGS)
18 AC_SUBST(MONO_LIBS)
19 ])
20
21-# GObject Introspection
22-GIR_REQ=1.0.0
23-AC_ARG_ENABLE(introspection,
24- AS_HELP_STRING([--enable-introspection[=@<:@no/auto/yes@:>@]],
25- [Enable introspection for this build]),,
26- [enable_introspection=no])
27-
28-AC_MSG_CHECKING([for gobject-introspection])
29-
30-dnl presence/version checking
31-AS_CASE([$enable_introspection],
32-[no], [
33- found_introspection="no (disabled, use --enable-introspection to enable)"
34-],
35-[yes],[
36- PKG_CHECK_EXISTS([gobject-introspection-1.0],,
37- AC_MSG_ERROR([gobject-introspection-1.0 is not installed]))
38- PKG_CHECK_EXISTS([gobject-introspection-1.0 >= $GIR_REQ],
39- found_introspection=yes,
40- AC_MSG_ERROR([You need to have gobject-introspection >= $1 installed to build AC_PACKAGE_NAME]))
41-],
42-[auto],[
43- PKG_CHECK_EXISTS([gobject-introspection-1.0 >= $GIR_REQ], found_introspection=yes, found_introspection=no)
44-dnl Canonicalize enable_introspection
45-enable_introspection=$found_introspection
46-],
47-[
48- AC_MSG_ERROR([invalid argument passed to --enable-introspection, should be one of @<:@no/auto/yes@:>@])
49-])
50+GOBJECT_INTROSPECTION_CHECK([1.46.0])
51
52-AC_MSG_RESULT([$found_introspection])
53-
54-INTROSPECTION_SCANNER=
55-INTROSPECTION_COMPILER=
56-INTROSPECTION_GENERATE=
57-INTROSPECTION_GIRDIR=
58-INTROSPECTION_TYPELIBDIR=
59-if test "x$found_introspection" = "xyes"; then
60- INTROSPECTION_SCANNER=`$PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0`
61- INTROSPECTION_COMPILER=`$PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0`
62- INTROSPECTION_GENERATE=`$PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0`
63- INTROSPECTION_GIRDIR=`$PKG_CONFIG --variable=girdir gobject-introspection-1.0`
64- INTROSPECTION_TYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
65- INTROSPECTION_CFLAGS=`$PKG_CONFIG --cflags gobject-introspection-1.0`
66- INTROSPECTION_LIBS=`$PKG_CONFIG --libs gobject-introspection-1.0`
67- INTROSPECTION_MAKEFILE=`$PKG_CONFIG --variable=datadir gobject-introspection-1.0`/gobject-introspection-1.0/Makefile.introspection
68-fi
69-AC_SUBST(INTROSPECTION_SCANNER)
70-AC_SUBST(INTROSPECTION_COMPILER)
71-AC_SUBST(INTROSPECTION_GENERATE)
72-AC_SUBST(INTROSPECTION_GIRDIR)
73-AC_SUBST(INTROSPECTION_TYPELIBDIR)
74-AC_SUBST(INTROSPECTION_CFLAGS)
75-AC_SUBST(INTROSPECTION_LIBS)
76-AC_SUBST(INTROSPECTION_MAKEFILE)
77-
78-AM_CONDITIONAL(HAVE_INTROSPECTION, test "x$found_introspection" = "xyes")
79 dnl we need to change the install directories for distcheck
80 AC_ARG_WITH([gir-dir],
81 AS_HELP_STRING(
82--
832.7.0
84
diff --git a/meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb b/meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb
index 71f99cafb..3d3118a92 100644
--- a/meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb
+++ b/meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb
@@ -7,9 +7,10 @@ SUMMARY = "Gnumeric spreadsheet for GNOME"
7 7
8GNOME_COMPRESS_TYPE = "xz" 8GNOME_COMPRESS_TYPE = "xz"
9 9
10inherit gnome 10inherit gnome pythonnative gobject-introspection
11 11
12SRC_URI += "file://do-not-use-srcdir.patch" 12SRC_URI += "file://do-not-use-srcdir.patch \
13 file://0001-configure.in-drop-introspection-macros-replace-them-.patch"
13 14
14SRC_URI[archive.md5sum] = "3fd87cca95334b5d8ac922989670fe27" 15SRC_URI[archive.md5sum] = "3fd87cca95334b5d8ac922989670fe27"
15SRC_URI[archive.sha256sum] = "037b53d909e5d1454b2afda8c4fb1e7838e260343e36d4e36245f4a5d0e04111" 16SRC_URI[archive.sha256sum] = "037b53d909e5d1454b2afda8c4fb1e7838e260343e36d4e36245f4a5d0e04111"