summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-06-23 21:15:36 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-06-25 09:06:45 +0200
commit7e14b17c3725a4baf7558bbe108eb41f0a5f3f67 (patch)
tree057587ce8e8ec7d9fbc9524d022e0b52358b5a5a /meta-gnome
parentad36da04c87029a2c0517b015cb9c2d40a1a96d7 (diff)
downloadmeta-openembedded-7e14b17c3725a4baf7558bbe108eb41f0a5f3f67.tar.gz
abiword: reorder and simplify
* there was overlap from .inc and bb (e.g. do_configure/EXTRA_OECONF twice) * simplify SRC_URI Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb152
1 files changed, 71 insertions, 81 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
index 927c33af4..6e1dc4ef0 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
@@ -3,75 +3,13 @@ HOMEPAGE = "http://www.abiword.org"
3SECTION = "x11/office" 3SECTION = "x11/office"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20" 5LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
6DEPENDS = "perl-native wv libgsf libglade libfribidi jpeg libpng libxml2" 6DEPENDS = "perl-native wv libgsf libglade libfribidi jpeg libpng libxml2 \
7 librsvg loudmouth libwmf-native gtkmathview asio"
7RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \ 8RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
8 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1" 9 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
10RCONFLICTS_${PN} = "${PN}-embedded"
9 11
10SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \ 12SRC_URI = "http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \
11 file://fix.double.install.patch \
12"
13SRC_URI[md5sum] = "bbc9c124f8072875129bd67092f0fa0b"
14SRC_URI[sha256sum] = "db34eeb5457fb7572fc76ec2a73cdb4f7a67307e7468b6c4bde820b58c598b3f"
15
16#want 2.x from 2.x.y for the installation directory
17SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
18
19FILES_${PN} += " \
20 ${datadir}/icons/* \
21 ${datadir}/abiword-${SHRT_VER}/glade \
22 ${datadir}/abiword-${SHRT_VER}/scripts \
23 ${datadir}/abiword-${SHRT_VER}/system.profile-en \
24 ${datadir}/abiword-${SHRT_VER}/system.profile-en_GB \
25 ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
26 ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
27 ${datadir}/abiword-${SHRT_VER}/templates/Employee-Directory.awt \
28 ${datadir}/abiword-${SHRT_VER}/templates/Business-Report.awt \
29 ${datadir}/abiword-${SHRT_VER}/templates/Fax-Coversheet.awt \
30 ${datadir}/abiword-${SHRT_VER}/templates/Resume.awt \
31 ${datadir}/abiword-${SHRT_VER}/templates/Two-Columns.awt \
32 ${datadir}/abiword-${SHRT_VER}/templates/Memo.awt \
33 ${datadir}/abiword-${SHRT_VER}/templates/Press-Release.awt "
34
35inherit autotools pkgconfig
36
37PARALLEL_MAKE = ""
38
39EXTRA_OECONF = " --disable-pspell \
40 --disable-spellcheck \
41 --disable-printing \
42 --disable-exports \
43 --with-sys-wv"
44
45# AbiWord configure.ac does not play nicely with autoreconf
46# so use the autogen.sh script that comes with AbiWord
47#
48do_configure() {
49 cd ${S}
50 export NOCONFIGURE="no"; ./autogen.sh
51 oe_runconf
52}
53
54
55do_install_append() {
56 install -d ${D}${datadir}/pixmaps/
57 mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
58 rmdir ${D}${datadir}/icons
59}
60
61PACKAGES += " abiword-clipart abiword-icons abiword-strings abiword-systemprofiles abiword-templates "
62
63FILES_abiword-clipart += "${datadir}/abiword-${SHRT_VER}/clipart"
64FILES_abiword-icons += "${datadir}/abiword-${SHRT_VER}/icons"
65FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/AbiWord/strings"
66FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/AbiWord/system.profile*"
67FILES_abiword-templates += "${datadir}/abiword-${SHRT_VER}/templates"
68
69DEPENDS += " librsvg loudmouth libwmf-native gtkmathview asio"
70RCONFLICTS_${PN} = "abiword-embedded"
71
72PR = "r4"
73
74SRC_URI = "http://www.abisource.com/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz;name=abiword \
75 file://autogen-common.sh \ 13 file://autogen-common.sh \
76 file://nodolt.patch \ 14 file://nodolt.patch \
77 file://fix.no.undefined.param.patch \ 15 file://fix.no.undefined.param.patch \
@@ -79,9 +17,17 @@ SRC_URI = "http://www.abisource.com/downloads/abiword/${PV}/source/abiword-${PV}
79 17
80LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20" 18LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
81 19
82SRC_URI[abiword.md5sum] = "f883b0a7f26229a9c66fd6a1a94381aa" 20SRC_URI[md5sum] = "f883b0a7f26229a9c66fd6a1a94381aa"
83SRC_URI[abiword.sha256sum] = "d99089a63a6cfc1a6a4a026be9278028d47d224088d24b1853acb67e95683a15" 21SRC_URI[sha256sum] = "d99089a63a6cfc1a6a4a026be9278028d47d224088d24b1853acb67e95683a15"
22
23#want 2.x from 2.x.y for the installation directory
24SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
25
26PR = "r6"
27
28inherit autotools pkgconfig
84 29
30PARALLEL_MAKE = ""
85 31
86EXTRA_OECONF = " --disable-static \ 32EXTRA_OECONF = " --disable-static \
87 --enable-plugins \ 33 --enable-plugins \
@@ -92,6 +38,8 @@ EXTRA_OECONF = " --disable-static \
92 --with-libwmf-config=${STAGING_DIR} \ 38 --with-libwmf-config=${STAGING_DIR} \
93" 39"
94 40
41# AbiWord configure.ac does not play nicely with autoreconf
42# so use the autogen.sh script that comes with AbiWord
95do_configure() { 43do_configure() {
96 install -m 0755 ${WORKDIR}/autogen-common.sh ${S}/autogen-common.sh 44 install -m 0755 ${WORKDIR}/autogen-common.sh ${S}/autogen-common.sh
97 cd ${S} 45 cd ${S}
@@ -99,11 +47,59 @@ do_configure() {
99 autotools_do_configure 47 autotools_do_configure
100} 48}
101 49
102FILES_${PN} += "${libdir}/libabiword-*.so ${datadir}/mime-info ${datadir}/abiword-${SHRT_VER}/certs ${datadir}/abiword-${SHRT_VER}/ui ${datadir}/abiword-${SHRT_VER}/xsl* ${datadir}/abiword-${SHRT_VER}/mime-info ${datadir}/abiword-${SHRT_VER}/Pr*.xml" 50do_install_append() {
103FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings" 51 install -d ${D}${datadir}/pixmaps/
104FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*" 52 mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
53 rmdir ${D}${datadir}/icons
54}
55
56PACKAGES += " ${PN}-clipart ${PN}-icons ${PN}-strings ${PN}-systemprofiles ${PN}-templates "
105 57
106PACKAGES_DYNAMIC = "abiword-meta abiword-plugin-*" 58FILES_${PN} += " \
59 ${libdir}/lib${PN}-*.so \
60 ${datadir}/mime-info \
61 ${datadir}/icons/* \
62 ${datadir}/${PN}-${SHRT_VER}/glade \
63 ${datadir}/${PN}-${SHRT_VER}/scripts \
64 ${datadir}/${PN}-${SHRT_VER}/system.profile-en \
65 ${datadir}/${PN}-${SHRT_VER}/system.profile-en_GB \
66 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt \
67 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt-en_GB \
68 ${datadir}/${PN}-${SHRT_VER}/templates/Employee-Directory.awt \
69 ${datadir}/${PN}-${SHRT_VER}/templates/Business-Report.awt \
70 ${datadir}/${PN}-${SHRT_VER}/templates/Fax-Coversheet.awt \
71 ${datadir}/${PN}-${SHRT_VER}/templates/Resume.awt \
72 ${datadir}/${PN}-${SHRT_VER}/templates/Two-Columns.awt \
73 ${datadir}/${PN}-${SHRT_VER}/templates/Memo.awt \
74 ${datadir}/${PN}-${SHRT_VER}/templates/Press-Release.awt \
75 ${datadir}/${PN}-${SHRT_VER}/certs \
76 ${datadir}/${PN}-${SHRT_VER}/ui \
77 ${datadir}/${PN}-${SHRT_VER}/xsl* \
78 ${datadir}/${PN}-${SHRT_VER}/mime-info \
79 ${datadir}/${PN}-${SHRT_VER}/Pr*.xml \
80"
81
82# don't steal /usr/lib/libabiword-2.8.so from ${PN}
83# in this case it's needed in ${PN}
84FILES_${PN}-dev = " \
85 ${includedir} \
86 ${libdir}/pkgconfig \
87 ${libdir}/${PN}*.la \
88 ${libdir}/lib${PN}*.la \
89 ${libdir}/${PN}-${SHRT_VER}/plugins/*.la \
90"
91FILES_${PN}-dbg += "${libdir}/${PN}-${SHRT_VER}/plugins/.debug"
92FILES_${PN}-doc += "${datadir}/${PN}-*/readme*"
93
94FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/strings"
95FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/system.profile*"
96FILES_${PN}-clipart += "${datadir}/${PN}-${SHRT_VER}/clipart"
97FILES_${PN}-icons += "${datadir}/${PN}-${SHRT_VER}/icons"
98FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings"
99FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*"
100FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates"
101
102PACKAGES_DYNAMIC = "${PN}-meta ${PN}-plugin-*"
107 103
108python populate_packages_prepend () { 104python populate_packages_prepend () {
109 abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d) 105 abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d)
@@ -116,17 +112,11 @@ python populate_packages_prepend () {
116 metapkg_rdepends = [] 112 metapkg_rdepends = []
117 packages = bb.data.getVar('PACKAGES', d, 1).split() 113 packages = bb.data.getVar('PACKAGES', d, 1).split()
118 for pkg in packages[1:]: 114 for pkg in packages[1:]:
119 if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"): 115 if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
120 print "Modifying ", pkg 116 print "Modifying ", pkg
121 metapkg_rdepends.append(pkg) 117 metapkg_rdepends.append(pkg)
122 bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d) 118 bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
123 bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d) 119 bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d)
124 packages.append(metapkg) 120 packages.append(metapkg)
125 bb.data.setVar('PACKAGES', ' '.join(packages), d) 121 bb.data.setVar('PACKAGES', ' '.join(packages), d)
126} 122}
127
128# don't steal /usr/lib/libabiword-2.8.so from ${PN}
129# in this case it's needed in ${PN}
130FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig ${libdir}/abiword*.la ${libdir}/abiword-${SHRT_VER}/plugins/*.la ${libdir}/libabiword*.la"
131FILES_${PN}-dbg += "${libdir}/abiword-${SHRT_VER}/plugins/.debug"
132FILES_${PN}-doc += "${datadir}/abiword-*/readme*"