summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:55 +0100
committerArmin Kuster <akuster808@gmail.com>2016-05-02 14:03:04 -0700
commit2e3d033cbff6ff657d299c8b83bf9e031b407ea0 (patch)
tree1773d6c5180cec513bbdd7357dd738792027713a /meta-gnome
parent33837ef82ade4d2b04f32e263c42538b19ca59ae (diff)
downloadmeta-openembedded-2e3d033cbff6ff657d299c8b83bf9e031b407ea0.tar.gz
meta-gnome: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb4
-rw-r--r--meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb2
-rw-r--r--meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb2
-rw-r--r--meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb2
4 files changed, 5 insertions, 5 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
index 6fdb43472..f8f5dddfb 100644
--- a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
@@ -17,10 +17,10 @@ inherit autotools gnome gtk-doc pkgconfig gsettings
17 17
18SRC_URI += "file://egg-asn1x.patch" 18SRC_URI += "file://egg-asn1x.patch"
19 19
20DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} intltool-native" 20DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} intltool-native"
21RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils" 21RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils"
22 22
23EXTRA_OECONF = "${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam --with-pam-dir=${base_libdir}/security', '--disable-pam', d)}" 23EXTRA_OECONF = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam --with-pam-dir=${base_libdir}/security', '--disable-pam', d)}"
24 24
25SRC_URI[archive.md5sum] = "9a8aa74e03361676f29d6e73155786fc" 25SRC_URI[archive.md5sum] = "9a8aa74e03361676f29d6e73155786fc"
26SRC_URI[archive.sha256sum] = "31fecec1430a97f59a6159a5a2ea8d6a1b44287f1e9e595b3594df46bf7f18f9" 26SRC_URI[archive.sha256sum] = "31fecec1430a97f59a6159a5a2ea8d6a1b44287f1e9e595b3594df46bf7f18f9"
diff --git a/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb
index 000db3506..c6fb75b8f 100644
--- a/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb
@@ -24,6 +24,6 @@ do_configure_append() {
24 done 24 done
25} 25}
26 26
27RRECOMMENDS_${PN} += "${@base_contains('DISTRO_FEATURES', 'pam', 'pam-plugin-ck-connector', '', d)}" 27RRECOMMENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-ck-connector', '', d)}"
28FILES_${PN} += "${datadir}/xsessions ${datadir}/icons ${datadir}/gnome ${libdir}/gnome-session/helpers" 28FILES_${PN} += "${datadir}/xsessions ${datadir}/icons ${datadir}/gnome ${libdir}/gnome-session/helpers"
29FILES_${PN}-dbg += "${libexecdir}/gnome-session/helpers/.debug" 29FILES_${PN}-dbg += "${libexecdir}/gnome-session/helpers/.debug"
diff --git a/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb
index f8ece3721..393eb256e 100644
--- a/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb
@@ -16,7 +16,7 @@ SRCREV = "0160f6725cfb872e017f3958f108792c3b882872"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)}" 19PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)}"
20PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio glib-2.0 libcanberra" 20PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio glib-2.0 libcanberra"
21PACKAGECONFIG[smartcard] = "--enable-smartcard-support,--disable-smartcard-support,nss" 21PACKAGECONFIG[smartcard] = "--enable-smartcard-support,--disable-smartcard-support,nss"
22 22
diff --git a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
index 48132ff89..f9b02b1db 100644
--- a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
+++ b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
@@ -31,7 +31,7 @@ SRC_URI[archive.md5sum] = "a05fab03eeef10a47dd156b758982f2e"
31SRC_URI[archive.sha256sum] = "62de64b5b804eb04104ff98fcd6a8b7276d510a49fbd9c0feb568f8996444faa" 31SRC_URI[archive.sha256sum] = "62de64b5b804eb04104ff98fcd6a8b7276d510a49fbd9c0feb568f8996444faa"
32GNOME_COMPRESS_TYPE="bz2" 32GNOME_COMPRESS_TYPE="bz2"
33 33
34PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)}" 34PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)}"
35PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi" 35PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
36PACKAGECONFIG[fam] = "--enable-fam,--disable-fam,gamin" 36PACKAGECONFIG[fam] = "--enable-fam,--disable-fam,gamin"
37 37