diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-12-06 23:20:18 -0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-12-21 19:16:52 +0100 |
commit | 1cf6cecfeb93091f450ec0745c63100d4496648c (patch) | |
tree | fd7e7291b255e9b43250d385bfaaa3c1eeaab5f4 /meta-gnome | |
parent | 3766a8d15fd5940072b7ac94f21910fa5b44ce3a (diff) | |
download | meta-openembedded-1cf6cecfeb93091f450ec0745c63100d4496648c.tar.gz |
libgnomeprint: Add missing dependency on freetype
Fixes compile errors like
| gnome-rfont.c:31:30: fatal error: freetype/ftglyph.h: No such file or
directory
| #include <freetype/ftglyph.h>
| ^
| compilation terminated.
| make[3]: *** [gnome-rfont.lo] Error 1
Fix header inclusion mechanism for freetype headers
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r-- | meta-gnome/recipes-gnome/gnome/libgnomeprint/freetype.patch | 38 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.7.bb | 6 |
2 files changed, 42 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomeprint/freetype.patch b/meta-gnome/recipes-gnome/gnome/libgnomeprint/freetype.patch new file mode 100644 index 000000000..7a27ecd23 --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome/libgnomeprint/freetype.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | Use proper method to include freetype headers | ||
2 | |||
3 | FreeType wants to use these special macros to include its APIs | ||
4 | so be it. | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | Upstream-Status: Pending | ||
8 | |||
9 | Index: libgnomeprint-2.18.7/libgnomeprint/gnome-font-face.c | ||
10 | =================================================================== | ||
11 | --- libgnomeprint-2.18.7.orig/libgnomeprint/gnome-font-face.c | ||
12 | +++ libgnomeprint-2.18.7/libgnomeprint/gnome-font-face.c | ||
13 | @@ -36,7 +36,9 @@ | ||
14 | #include <stdarg.h> | ||
15 | #include <locale.h> | ||
16 | |||
17 | -#include <freetype/ftoutln.h> | ||
18 | +#include <ft2build.h> | ||
19 | +#include FT_FREETYPE_H | ||
20 | + | ||
21 | |||
22 | #include <libgnomeprint/gnome-print-private.h> | ||
23 | #include <libgnomeprint/gnome-font-private.h> | ||
24 | Index: libgnomeprint-2.18.7/libgnomeprint/gnome-rfont.c | ||
25 | =================================================================== | ||
26 | --- libgnomeprint-2.18.7.orig/libgnomeprint/gnome-rfont.c | ||
27 | +++ libgnomeprint-2.18.7/libgnomeprint/gnome-rfont.c | ||
28 | @@ -28,8 +28,8 @@ | ||
29 | |||
30 | #include <ft2build.h> | ||
31 | #include FT_FREETYPE_H | ||
32 | -#include <freetype/ftglyph.h> | ||
33 | -#include <freetype/ftbbox.h> | ||
34 | +#include FT_GLYPH_H | ||
35 | +#include FT_BBOX_H | ||
36 | #include <libart_lgpl/art_misc.h> | ||
37 | #include <libart_lgpl/art_affine.h> | ||
38 | #include <libart_lgpl/art_vpath.h> | ||
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.7.bb b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.7.bb index 8e31f1dcd..606c752e2 100644 --- a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.7.bb +++ b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.7.bb | |||
@@ -3,13 +3,15 @@ SECTION = "x11/gnome/libs" | |||
3 | 3 | ||
4 | PR = "r2" | 4 | PR = "r2" |
5 | 5 | ||
6 | DEPENDS = "libxml2 libgnomecups glib-2.0 pango libart-lgpl fontconfig popt gnome-common" | 6 | DEPENDS = "libxml2 libgnomecups glib-2.0 pango libart-lgpl fontconfig popt gnome-common freetype" |
7 | 7 | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
9 | 9 | ||
10 | inherit pkgconfig gnome | 10 | inherit pkgconfig gnome |
11 | 11 | ||
12 | SRC_URI += "file://fix.includes.patch" | 12 | SRC_URI += "file://fix.includes.patch \ |
13 | file://freetype.patch \ | ||
14 | " | ||
13 | 15 | ||
14 | SRC_URI[archive.md5sum] = "d66b81ee8aa3b3a33f5efc9a47ce07e3" | 16 | SRC_URI[archive.md5sum] = "d66b81ee8aa3b3a33f5efc9a47ce07e3" |
15 | SRC_URI[archive.sha256sum] = "8b34f81599423ef3da9c43775495da602f83cbbee069c9e760ffeae6aa4768e6" | 17 | SRC_URI[archive.sha256sum] = "8b34f81599423ef3da9c43775495da602f83cbbee069c9e760ffeae6aa4768e6" |