diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2014-04-01 17:10:46 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-04-20 10:40:28 +0200 |
commit | 0aaf18723d7280b62af3e66106859bc5c51a185a (patch) | |
tree | bd6905332eeb2a993dff50d598f578b7879a42d8 /meta-gnome | |
parent | 4328d8f4035fe3990eae7e877df6bdf65480c97a (diff) | |
download | meta-openembedded-0aaf18723d7280b62af3e66106859bc5c51a185a.tar.gz |
abiword: update to 3.0.0 to fix build
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword/abiword-cxx-for-ld-fix.patch | 12 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword/abiword.fix.glib-2.32.patch | 21 | ||||
-rwxr-xr-x | meta-gnome/recipes-gnome/abiword/abiword/cdump.pl | 32 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword/debian_patches_boost54.patch | 32 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword/fix.no.undefined.param.patch | 104 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword/libpng15.patch | 102 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword/nodolt.patch | 12 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb (renamed from meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb) | 39 |
8 files changed, 47 insertions, 307 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/abiword-cxx-for-ld-fix.patch b/meta-gnome/recipes-gnome/abiword/abiword/abiword-cxx-for-ld-fix.patch deleted file mode 100644 index e49b1e92e..000000000 --- a/meta-gnome/recipes-gnome/abiword/abiword/abiword-cxx-for-ld-fix.patch +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | libstc++ isn't in staging anymore, so we must use g++ for linking | ||
2 | |||
3 | --- /tmp/configure.ac 2008-03-31 11:39:13.130631737 +0200 | ||
4 | +++ abiword-plugins-2.6.0/configure.ac 2008-03-31 11:39:22.754586487 +0200 | ||
5 | @@ -14,6 +14,7 @@ | ||
6 | AC_PROG_INSTALL | ||
7 | AC_PROG_LN_S | ||
8 | AC_PROG_MAKE_SET | ||
9 | +AC_LANG_CPLUSPLUS | ||
10 | |||
11 | AM_INIT_AUTOMAKE | ||
12 | |||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/abiword.fix.glib-2.32.patch b/meta-gnome/recipes-gnome/abiword/abiword/abiword.fix.glib-2.32.patch deleted file mode 100644 index e466ef6c9..000000000 --- a/meta-gnome/recipes-gnome/abiword/abiword/abiword.fix.glib-2.32.patch +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | --- abiword-2.8.6/goffice-bits/goffice/app/goffice-app.h 2012-04-30 15:06:28.000000000 +0200 | ||
2 | +++ abiword-2.8.6.orig/goffice-bits/goffice/app/goffice-app.h 2007-01-17 00:17:27.000000000 +0100 | ||
3 | @@ -22,7 +22,7 @@ | ||
4 | #ifndef GOFFICE_APP_H | ||
5 | #define GOFFICE_APP_H | ||
6 | |||
7 | -#include <glib/gmacros.h> | ||
8 | +#include <glib.h> | ||
9 | |||
10 | G_BEGIN_DECLS | ||
11 | |||
12 | --- abiword-2.8.6/src/af/util/xp/ut_go_file.h 2012-04-30 15:08:43.000000000 +0200 | ||
13 | +++ abiword-2.8.6.orig/src/af/util/xp/ut_go_file.h 2009-08-27 15:27:10.000000000 +0200 | ||
14 | @@ -31,7 +31,6 @@ | ||
15 | |||
16 | #include <glib.h> | ||
17 | #include <gsf/gsf.h> | ||
18 | -#include <glib/gerror.h> | ||
19 | #include <time.h> | ||
20 | |||
21 | G_BEGIN_DECLS | ||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/cdump.pl b/meta-gnome/recipes-gnome/abiword/abiword/cdump.pl deleted file mode 100755 index 76f9c8841..000000000 --- a/meta-gnome/recipes-gnome/abiword/abiword/cdump.pl +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | #!/usr/bin/perl | ||
2 | |||
3 | # This script replace the cdump tool we used to build the ap_wp_Splash.cpp | ||
4 | # Because the cdump tool has to be run as a part of building the AW package, | ||
5 | # it breaks cross-compilation. A perl script seemed like a generic solution | ||
6 | |||
7 | |||
8 | if ($#ARGV != 1 ) | ||
9 | { | ||
10 | print "Usage: $0 datafile arrayname $#ARGV $ARGV[0] $ARGV[1]\n"; | ||
11 | exit(-1); | ||
12 | } | ||
13 | |||
14 | open FROM, "<$ARGV[0]" or die "Could not open file $ARGV[0]"; | ||
15 | binmode FROM; | ||
16 | |||
17 | print "unsigned char $ARGV[1] [] = {\n"; | ||
18 | |||
19 | while ($len = read(FROM, $buf, 16)) | ||
20 | { | ||
21 | foreach(split(//,$buf)) | ||
22 | { | ||
23 | printf("0x%02x,", ord($_)); | ||
24 | } | ||
25 | |||
26 | print "\n"; | ||
27 | } | ||
28 | |||
29 | |||
30 | printf "};\nunsigned long $ARGV[1]_sizeof = sizeof($ARGV[1]);\n"; | ||
31 | |||
32 | close FROM; \ No newline at end of file | ||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/debian_patches_boost54.patch b/meta-gnome/recipes-gnome/abiword/abiword/debian_patches_boost54.patch new file mode 100644 index 000000000..cf50cb2c9 --- /dev/null +++ b/meta-gnome/recipes-gnome/abiword/abiword/debian_patches_boost54.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | Last-Update: 2014-02-05 | ||
2 | Forwarded: yes | ||
3 | Author: Dmitry Smirnov <onlyjob@member.fsf.org> | ||
4 | Bug-Debian: http://bugs.debian.org/737551 | ||
5 | Bug-Abiword: http://bugzilla.abisource.com/13602 | ||
6 | Description: fix FTBFS with libboost1.54-dev | ||
7 | Upstream-Status: Applied | ||
8 | |||
9 | --- a/plugins/collab/core/sync/xp/SynchronizedQueue.h | ||
10 | +++ b/plugins/collab/core/sync/xp/SynchronizedQueue.h | ||
11 | @@ -21,8 +21,9 @@ | ||
12 | |||
13 | #include <deque> | ||
14 | #include <boost/bind.hpp> | ||
15 | #include <boost/function.hpp> | ||
16 | +#include <boost/noncopyable.hpp> | ||
17 | #include <sync/xp/lock.h> | ||
18 | #include <sync/xp/Synchronizer.h> | ||
19 | |||
20 | class EmptyQueueException {}; | ||
21 | --- a/plugins/collab/backends/tcp/xp/Session.h | ||
22 | +++ b/plugins/collab/backends/tcp/xp/Session.h | ||
23 | @@ -21,8 +21,9 @@ | ||
24 | |||
25 | #include <boost/function.hpp> | ||
26 | #include <boost/bind.hpp> | ||
27 | #include <boost/enable_shared_from_this.hpp> | ||
28 | +#include <boost/noncopyable.hpp> | ||
29 | #include <deque> | ||
30 | #include <sync/xp/lock.h> | ||
31 | #include <sync/xp/Synchronizer.h> | ||
32 | |||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/fix.no.undefined.param.patch b/meta-gnome/recipes-gnome/abiword/abiword/fix.no.undefined.param.patch deleted file mode 100644 index aaccf090b..000000000 --- a/meta-gnome/recipes-gnome/abiword/abiword/fix.no.undefined.param.patch +++ /dev/null | |||
@@ -1,104 +0,0 @@ | |||
1 | | make[3]: Entering directory | ||
2 | `/OE/shr-core/tmp/work/armv7a-vfp-neon-oe-linux-gnueabi/abiword-2.8.6-r0/abiword-2.8.6/src' | ||
3 | | /bin/sh ../arm-oe-linux-gnueabi-libtool --tag=CXX --mode=link | ||
4 | arm-oe-linux-gnueabi-g++ -march=armv7-a -fno-tree-vectorize | ||
5 | -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a8 | ||
6 | --sysroot=/OE/shr-core/tmp/sysroots/nokia900 -O2 -pipe -g | ||
7 | -feliminate-unused-debug-types -fpermissive | ||
8 | -fvisibility-inlines-hidden --no-undefined -avoid-version | ||
9 | -export-dynamic -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -o | ||
10 | abiword abiword-UnixMain.o libabiword-2.8.la -pthread -lfribidi -lwv | ||
11 | -lpng -lgsf-1 -lxml2 -lenchant -lz -lgtk-x11-2.0 -lgdk-x11-2.0 | ||
12 | -latk-1.0 -lpangoft2-1.0 -lpangocairo-1.0 -lpango-1.0 -lfreetype | ||
13 | -lfontconfig -lrsvg-2 -lm -lgio-2.0 -lgdk_pixbuf-2.0 -lcairo | ||
14 | -lgmodule-2.0 -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0 -ljpeg | ||
15 | | arm-oe-linux-gnueabi-libtool: link: arm-oe-linux-gnueabi-g++ | ||
16 | -march=armv7-a -fno-tree-vectorize -mthumb-interwork | ||
17 | -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a8 | ||
18 | --sysroot=/OE/shr-core/tmp/sysroots/nokia900 -O2 -pipe -g | ||
19 | -feliminate-unused-debug-types -fpermissive | ||
20 | -fvisibility-inlines-hidden --no-undefined -Wl,-O1 | ||
21 | -Wl,--hash-style=gnu -Wl,--as-needed -o .libs/abiword | ||
22 | abiword-UnixMain.o -pthread -Wl,--export-dynamic | ||
23 | ./.libs/libabiword-2.8.so -L=/usr/lib | ||
24 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libfribidi.so | ||
25 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libwv.so | ||
26 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libgsf-1.so | ||
27 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libbz2.so | ||
28 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libenchant.so | ||
29 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libgtk-x11-2.0.so | ||
30 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libgdk-x11-2.0.so | ||
31 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libatk-1.0.so | ||
32 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/librsvg-2.so | ||
33 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libxml2.so | ||
34 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libpangocairo-1.0.so | ||
35 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libpangoft2-1.0.so | ||
36 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libstdc++.so | ||
37 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libpango-1.0.so | ||
38 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libgdk_pixbuf-2.0.so | ||
39 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libgio-2.0.so -lresolv | ||
40 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libcairo.so | ||
41 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libpixman-1.so | ||
42 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libfontconfig.so | ||
43 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libexpat.so | ||
44 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libfreetype.so | ||
45 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libpng12.so | ||
46 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libXrender.so | ||
47 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libX11.so | ||
48 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libxcb.so | ||
49 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libXau.so | ||
50 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libXdmcp.so | ||
51 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libERROR: Function | ||
52 | 'do_compile' failed (see | ||
53 | /OE/shr-core/tmp/work/armv7a-vfp-neon-oe-linux-gnueabi/abiword-2.8.6-r0/temp/log.do_compile.10916 | ||
54 | for further information) | ||
55 | | z.so -lm /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libgmodule-2.0.so | ||
56 | -ldl /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libgobject-2.0.so | ||
57 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libffi.so | ||
58 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libgthread-2.0.so -lpthread | ||
59 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libglib-2.0.so -lrt | ||
60 | /OE/shr-core/tmp/sysroots/nokia900/usr/lib/libjpeg.so -pthread | ||
61 | | arm-oe-linux-gnueabi-g++: error: unrecognized option '--no-undefined' | ||
62 | | make[3]: *** [abiword] Error 1 | ||
63 | | make[3]: Leaving directory | ||
64 | `/OE/shr-core/tmp/work/armv7a-vfp-neon-oe-linux-gnueabi/abiword-2.8.6-r0/abiword-2.8.6/src' | ||
65 | |||
66 | Maybe it's related to | ||
67 | http://lists.gnu.org/archive/html/libtool/2011-03/msg00015.html | ||
68 | |||
69 | Remove extra '-' in no-undefined. | ||
70 | |||
71 | Upstream-Status: Pending | ||
72 | |||
73 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
74 | |||
75 | diff -uNr abiword-2.8.6.orig/src/Makefile.am abiword-2.8.6/src/Makefile.am | ||
76 | --- abiword-2.8.6.orig/src/Makefile.am 2009-09-09 15:11:01.000000000 +0200 | ||
77 | +++ abiword-2.8.6/src/Makefile.am 2011-11-23 09:06:06.000000000 +0100 | ||
78 | @@ -44,7 +44,7 @@ | ||
79 | |||
80 | libabiword_2_8_la_LDFLAGS = \ | ||
81 | $(DEPS_LIBS) \ | ||
82 | - --no-undefined \ | ||
83 | + -no-undefined \ | ||
84 | -avoid-version \ | ||
85 | -export-dynamic | ||
86 | |||
87 | @@ -107,7 +107,7 @@ | ||
88 | |||
89 | AbiWord_LDFLAGS = \ | ||
90 | $(DEPS_LIBS) \ | ||
91 | - --no-undefined \ | ||
92 | + -no-undefined \ | ||
93 | -avoid-version \ | ||
94 | -export-dynamic \ | ||
95 | -headerpad_max_install_names | ||
96 | @@ -129,7 +129,7 @@ | ||
97 | |||
98 | abiword_LDFLAGS = \ | ||
99 | $(platform_ldflags) \ | ||
100 | - --no-undefined \ | ||
101 | + -no-undefined \ | ||
102 | -avoid-version \ | ||
103 | -export-dynamic | ||
104 | |||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/libpng15.patch b/meta-gnome/recipes-gnome/abiword/abiword/libpng15.patch deleted file mode 100644 index 0fc93c55b..000000000 --- a/meta-gnome/recipes-gnome/abiword/abiword/libpng15.patch +++ /dev/null | |||
@@ -1,102 +0,0 @@ | |||
1 | Imported from gentoo | ||
2 | |||
3 | $NetBSD: patch-plugins_bmp_xp_ie__impGraphic__BMP.cpp,v 1.1 2011/02/01 10:48:15 wiz Exp $ | ||
4 | |||
5 | Fix build with png-1.5. | ||
6 | |||
7 | --- a/plugins/bmp/xp/ie_impGraphic_BMP.cpp.orig 2009-06-25 04:02:06.000000000 +0000 | ||
8 | +++ b/plugins/bmp/xp/ie_impGraphic_BMP.cpp | ||
9 | @@ -191,7 +191,10 @@ UT_Error IE_ImpGraphic_BMP::_convertGrap | ||
10 | |||
11 | /* Clean Up Memory Used */ | ||
12 | |||
13 | - FREEP(m_pPNGInfo->palette); | ||
14 | + png_colorp palette; | ||
15 | + int num_palette; | ||
16 | + png_get_PLTE( m_pPNG, m_pPNGInfo, &palette, &num_palette ); | ||
17 | + FREEP(palette); | ||
18 | DELETEP(pBB); | ||
19 | png_destroy_write_struct(&m_pPNG, &m_pPNGInfo); | ||
20 | |||
21 | @@ -313,7 +316,7 @@ UT_Error IE_ImpGraphic_BMP::Initialize_P | ||
22 | * the normal method of doing things with libpng). REQUIRED unless you | ||
23 | * set up your own error handlers in the png_create_read_struct() earlier. | ||
24 | */ | ||
25 | - if (setjmp(m_pPNG->jmpbuf)) | ||
26 | + if (setjmp(png_jmpbuf(m_pPNG))) | ||
27 | { | ||
28 | /* Free all of the memory associated with the png_ptr and info_ptr */ | ||
29 | png_destroy_write_struct(&m_pPNG, &m_pPNGInfo); | ||
30 | @@ -332,7 +335,7 @@ UT_Error IE_ImpGraphic_BMP::Initialize_P | ||
31 | UT_Error IE_ImpGraphic_BMP::Convert_BMP_Pallet(UT_ByteBuf* pBB) | ||
32 | { | ||
33 | /* Reset error handling for libpng */ | ||
34 | - if (setjmp(m_pPNG->jmpbuf)) | ||
35 | + if (setjmp(png_jmpbuf(m_pPNG))) | ||
36 | { | ||
37 | png_destroy_write_struct(&m_pPNG, &m_pPNGInfo); | ||
38 | return UT_ERROR; | ||
39 | @@ -372,7 +375,7 @@ UT_Error IE_ImpGraphic_BMP::Initialize_P | ||
40 | UT_Error IE_ImpGraphic_BMP::Convert_BMP(UT_ByteBuf* pBB) | ||
41 | { | ||
42 | /* Reset error handling for libpng */ | ||
43 | - if (setjmp(m_pPNG->jmpbuf)) | ||
44 | + if (setjmp(png_jmpbuf(m_pPNG))) | ||
45 | { | ||
46 | png_destroy_write_struct(&m_pPNG, &m_pPNGInfo); | ||
47 | return UT_ERROR; | ||
48 | |||
49 | $NetBSD: patch-plugins_garble_xp_abiword-garble-png.cpp,v 1.1 2011/02/01 10:48:15 wiz Exp $ | ||
50 | |||
51 | Fix build with png-1.5. | ||
52 | |||
53 | --- a/plugins/garble/xp/abiword-garble-png.cpp.orig 2009-09-05 15:34:44.000000000 +0000 | ||
54 | +++ b/plugins/garble/xp/abiword-garble-png.cpp | ||
55 | @@ -79,7 +79,7 @@ bool abiword_document::garble_png( void* | ||
56 | png_set_strip_alpha( png_ptr ); | ||
57 | png_set_interlace_handling( png_ptr ); | ||
58 | png_set_bgr( png_ptr ); | ||
59 | - rowbytes = info_ptr->rowbytes; | ||
60 | + rowbytes = png_get_rowbytes( png_ptr, info_ptr ); | ||
61 | png_destroy_read_struct( &png_ptr, &info_ptr, NULL ); | ||
62 | } | ||
63 | |||
64 | $NetBSD: patch-af,v 1.12 2011/01/15 15:07:11 wiz Exp $ | ||
65 | |||
66 | Fix build with png-1.5. | ||
67 | |||
68 | --- a/src/wp/impexp/gtk/ie_impGraphic_GdkPixbuf.cpp.orig 2009-07-01 04:02:04.000000000 +0000 | ||
69 | +++ b/src/wp/impexp/gtk/ie_impGraphic_GdkPixbuf.cpp | ||
70 | @@ -185,7 +185,7 @@ UT_Error IE_ImpGraphic_GdkPixbuf::import | ||
71 | /** needed for the stejmp context */ | ||
72 | UT_Error IE_ImpGraphic_GdkPixbuf::_png_write(GdkPixbuf * pixbuf) | ||
73 | { | ||
74 | - if (setjmp(m_pPNG->jmpbuf)) | ||
75 | + if (setjmp(png_jmpbuf(m_pPNG))) | ||
76 | { | ||
77 | DELETEP(m_pPngBB); | ||
78 | png_destroy_write_struct(&m_pPNG, &m_pPNGInfo); | ||
79 | @@ -446,7 +446,7 @@ UT_Error IE_ImpGraphic_GdkPixbuf::Initia | ||
80 | * the normal method of doing things with libpng). REQUIRED unless you | ||
81 | * set up your own error handlers in the png_create_read_struct() earlier. | ||
82 | */ | ||
83 | - if (setjmp(m_pPNG->jmpbuf)) | ||
84 | + if (setjmp(png_jmpbuf(m_pPNG))) | ||
85 | { | ||
86 | /* Free all of the memory associated with the png_ptr and info_ptr */ | ||
87 | png_destroy_write_struct(&m_pPNG, &m_pPNGInfo); | ||
88 | $NetBSD: patch-ae,v 1.21 2011/01/15 15:07:11 wiz Exp $ | ||
89 | |||
90 | Fix build with png-1.5. | ||
91 | |||
92 | --- a/src/af/util/xp/ut_png.cpp.orig 2008-02-24 03:33:07.000000000 +0000 | ||
93 | +++ b/src/af/util/xp/ut_png.cpp | ||
94 | @@ -71,7 +71,7 @@ bool UT_PNG_getDimensions(const UT_ByteB | ||
95 | * the normal method of doing things with libpng). REQUIRED unless you | ||
96 | * set up your own error handlers in the png_create_read_struct() earlier. | ||
97 | */ | ||
98 | - if (setjmp(png_ptr->jmpbuf)) | ||
99 | + if (setjmp(png_jmpbuf(png_ptr))) | ||
100 | { | ||
101 | /* Free all of the memory associated with the png_ptr and info_ptr */ | ||
102 | png_destroy_read_struct(&png_ptr, &info_ptr, static_cast<png_infopp>(NULL)); | ||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/nodolt.patch b/meta-gnome/recipes-gnome/abiword/abiword/nodolt.patch deleted file mode 100644 index 154672080..000000000 --- a/meta-gnome/recipes-gnome/abiword/abiword/nodolt.patch +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | Index: abiword-2.8.1/configure.in | ||
2 | =================================================================== | ||
3 | --- abiword-2.8.1.orig/configure.in | ||
4 | +++ abiword-2.8.1/configure.in | ||
5 | @@ -132,7 +132,6 @@ AC_PROG_INSTALL | ||
6 | #AC_DISABLE_STATIC | ||
7 | AC_LIBTOOL_WIN32_DLL | ||
8 | AC_PROG_LIBTOOL | ||
9 | -DOLT | ||
10 | AC_PROG_LN_S | ||
11 | |||
12 | AC_MSG_CHECKING([for platform and toolkit]) | ||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb index de1b3356b..69d62efa1 100644 --- a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb +++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb | |||
@@ -4,36 +4,29 @@ SECTION = "x11/office" | |||
4 | LICENSE = "GPLv2" | 4 | LICENSE = "GPLv2" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20" |
6 | DEPENDS = "perl-native wv libglade libfribidi jpeg libpng \ | 6 | DEPENDS = "perl-native wv libglade libfribidi jpeg libpng \ |
7 | librsvg libwmf-native gtkmathview asio" | 7 | librsvg libwmf-native gtkmathview asio gtk+" |
8 | RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \ | 8 | RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \ |
9 | glibc-gconv-iso8859-15 glibc-gconv-iso8859-1" | 9 | glibc-gconv-iso8859-15 glibc-gconv-iso8859-1" |
10 | RCONFLICTS_${PN} = "${PN}-embedded" | 10 | RCONFLICTS_${PN} = "${PN}-embedded" |
11 | 11 | ||
12 | SRC_URI = "http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \ | 12 | SRC_URI = "http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \ |
13 | file://debian_patches_boost54.patch \ | ||
13 | file://autogen-common.sh \ | 14 | file://autogen-common.sh \ |
14 | file://nodolt.patch \ | ||
15 | file://fix.no.undefined.param.patch \ | ||
16 | file://abiword.fix.glib-2.32.patch \ | ||
17 | file://libpng15.patch \ | ||
18 | " | 15 | " |
19 | 16 | ||
20 | LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20" | 17 | LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a" |
21 | 18 | ||
22 | SRC_URI[md5sum] = "f883b0a7f26229a9c66fd6a1a94381aa" | 19 | SRC_URI[md5sum] = "8d9c41cff3a8fbef8d0c835c65600e65" |
23 | SRC_URI[sha256sum] = "d99089a63a6cfc1a6a4a026be9278028d47d224088d24b1853acb67e95683a15" | 20 | SRC_URI[sha256sum] = "d17e318c00ff4eb353e0e7994b098b1d4f9ddd8712ac0261a0e38b89081fac01" |
24 | 21 | ||
25 | #want 2.x from 2.x.y for the installation directory | 22 | #want 3.x from 3.x.y for the installation directory |
26 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" | 23 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" |
27 | 24 | ||
28 | PR = "r8" | ||
29 | |||
30 | inherit autotools pkgconfig | 25 | inherit autotools pkgconfig |
31 | 26 | ||
32 | PARALLEL_MAKE = "" | ||
33 | |||
34 | PACKAGECONFIG ??= "collab-backend-xmpp collab-backend-tcp collab-backend-service" | 27 | PACKAGECONFIG ??= "collab-backend-xmpp collab-backend-tcp collab-backend-service" |
35 | PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant" | 28 | PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant" |
36 | PACKAGECONFIG[collab-backend-xmpp] = "--enable-collab-backend-xmpp,--disable-collab-backend-xmpp,libgsf libxml2 loudmouth gtk+" | 29 | PACKAGECONFIG[collab-backend-xmpp] = "--enable-collab-backend-xmpp,--disable-collab-backend-xmpp,libgsf libxml2 loudmouth" |
37 | PACKAGECONFIG[collab-backend-tcp] = "--enable-collab-backend-tcp,--disable-collab-backend-tcp,libgsf libxml2" | 30 | PACKAGECONFIG[collab-backend-tcp] = "--enable-collab-backend-tcp,--disable-collab-backend-tcp,libgsf libxml2" |
38 | PACKAGECONFIG[collab-backend-service] = "--enable-collab-backend-service,--disable-collab-backend-service,libgsf libxml2 libsoup-2.4 gnutls" | 31 | PACKAGECONFIG[collab-backend-service] = "--enable-collab-backend-service,--disable-collab-backend-service,libgsf libxml2 libsoup-2.4 gnutls" |
39 | PACKAGECONFIG[collab-backend-telepathy] = "--enable-collab-backend-telepathy,--disable-collab-backend-telepathy,libgsf libxml2 telepathy-glib telepathy-mission-control" | 32 | PACKAGECONFIG[collab-backend-telepathy] = "--enable-collab-backend-telepathy,--disable-collab-backend-telepathy,libgsf libxml2 telepathy-glib telepathy-mission-control" |
@@ -41,7 +34,10 @@ PACKAGECONFIG[collab-backend-sugar] = "--enable-collab-backend-sugar,--disable-c | |||
41 | 34 | ||
42 | EXTRA_OECONF = " --disable-static \ | 35 | EXTRA_OECONF = " --disable-static \ |
43 | --enable-plugins \ | 36 | --enable-plugins \ |
37 | --enable-clipart \ | ||
38 | --enable-templates \ | ||
44 | --without-gnomevfs \ | 39 | --without-gnomevfs \ |
40 | --with-gtk2 \ | ||
45 | --with-libwmf-config=${STAGING_DIR} \ | 41 | --with-libwmf-config=${STAGING_DIR} \ |
46 | " | 42 | " |
47 | 43 | ||
@@ -54,13 +50,7 @@ do_configure() { | |||
54 | autotools_do_configure | 50 | autotools_do_configure |
55 | } | 51 | } |
56 | 52 | ||
57 | do_install_append() { | 53 | PACKAGES += " ${PN}-clipart ${PN}-strings ${PN}-systemprofiles ${PN}-templates " |
58 | install -d ${D}${datadir}/pixmaps/ | ||
59 | mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/ | ||
60 | rmdir ${D}${datadir}/icons | ||
61 | } | ||
62 | |||
63 | PACKAGES += " ${PN}-clipart ${PN}-icons ${PN}-strings ${PN}-systemprofiles ${PN}-templates " | ||
64 | 54 | ||
65 | FILES_${PN} += " \ | 55 | FILES_${PN} += " \ |
66 | ${libdir}/lib${PN}-*.so \ | 56 | ${libdir}/lib${PN}-*.so \ |
@@ -86,7 +76,7 @@ FILES_${PN} += " \ | |||
86 | ${datadir}/${PN}-${SHRT_VER}/Pr*.xml \ | 76 | ${datadir}/${PN}-${SHRT_VER}/Pr*.xml \ |
87 | " | 77 | " |
88 | 78 | ||
89 | # don't steal /usr/lib/libabiword-2.8.so from ${PN} | 79 | # don't steal /usr/lib/libabiword-3.0.so from ${PN} |
90 | # in this case it's needed in ${PN} | 80 | # in this case it's needed in ${PN} |
91 | FILES_${PN}-dev = " \ | 81 | FILES_${PN}-dev = " \ |
92 | ${includedir} \ | 82 | ${includedir} \ |
@@ -101,7 +91,6 @@ FILES_${PN}-doc += "${datadir}/${PN}-*/readme*" | |||
101 | FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/strings" | 91 | FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/strings" |
102 | FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/system.profile*" | 92 | FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/system.profile*" |
103 | FILES_${PN}-clipart += "${datadir}/${PN}-${SHRT_VER}/clipart" | 93 | FILES_${PN}-clipart += "${datadir}/${PN}-${SHRT_VER}/clipart" |
104 | FILES_${PN}-icons += "${datadir}/${PN}-${SHRT_VER}/icons" | ||
105 | FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings" | 94 | FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings" |
106 | FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*" | 95 | FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*" |
107 | FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates" | 96 | FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates" |
@@ -109,7 +98,7 @@ FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates" | |||
109 | PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*" | 98 | PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*" |
110 | 99 | ||
111 | python populate_packages_prepend () { | 100 | python populate_packages_prepend () { |
112 | abiword_libdir = d.expand('${libdir}/abiword-2.8/plugins') | 101 | abiword_libdir = d.expand('${libdir}/${PN}-${SHRT_VER}/plugins') |
113 | do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='') | 102 | do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='') |
114 | 103 | ||
115 | metapkg = "abiword-meta" | 104 | metapkg = "abiword-meta" |
@@ -127,3 +116,5 @@ python populate_packages_prepend () { | |||
127 | packages.append(metapkg) | 116 | packages.append(metapkg) |
128 | d.setVar('PACKAGES', ' '.join(packages)) | 117 | d.setVar('PACKAGES', ' '.join(packages)) |
129 | } | 118 | } |
119 | |||
120 | FILES_${PN}-plugin-openxml += "${datadir}/${PN}-${SHRT_VER}/omml_xslt" | ||