summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-02-09 16:10:52 +0100
committerKhem Raj <raj.khem@gmail.com>2020-02-09 22:31:31 -0800
commit3b3f73379864a3d49b81db068436800198ab26d9 (patch)
treeb530d756978ca9b68a938bb1d92ef0c0864b051f /meta-gnome
parentc8734f7d5a6c552b9981513dfe08b8541650e24d (diff)
downloadmeta-openembedded-3b3f73379864a3d49b81db068436800198ab26d9.tar.gz
gimp: upgrade 2.8.22 -> 2.10.14
* patches don't apply any more * get sources from location gimp's homepage suggests * license checksum was changed by replacing http -> https [1] [1] https://gitlab.gnome.org/GNOME/gimp/commit/bab75b7365cc87639cd5aaa9840ebe1f6228d556 Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gimp/gimp/gimp_2.10.14.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gimp/gimp/gimp_2.10.14.bb b/meta-gnome/recipes-gimp/gimp/gimp_2.10.14.bb
new file mode 100644
index 000000000..045958d0a
--- /dev/null
+++ b/meta-gnome/recipes-gimp/gimp/gimp_2.10.14.bb
@@ -0,0 +1,60 @@
1SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
6
7DEPENDS = " \
8 gdk-pixbuf-native \
9 intltool-native \
10 libxslt-native \
11 gegl-native \
12 dbus-glib \
13 gtk+ \
14 babl \
15 gegl \
16 libmypaint \
17 mypaint-brushes-1.0 \
18 gexiv2 \
19 jpeg \
20 libpng \
21 libexif \
22 tiff \
23 lcms \
24 poppler \
25 poppler-data \
26 jasper \
27 bzip2 \
28 libgudev \
29 libmng \
30 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)} \
31"
32
33inherit features_check gnomebase gtk-icon-cache gtk-doc mime-xdg
34
35REQUIRED_DISTRO_FEATURES = "x11"
36
37SHPV = "${@gnome_verdir("${PV}")}"
38
39SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2"
40SRC_URI[md5sum] = "a64f2be299755a2da130306cad9b1d26"
41SRC_URI[sha256sum] = "df9b0f11c2078eea1de3ebc66529a5d3854c5e28636cd25a8dd077bd9d6ddc54"
42
43EXTRA_OECONF = "--disable-python \
44 --without-webkit \
45 --without-wmf"
46
47do_configure_append() {
48 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
49 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
50}
51
52do_compile_prepend() {
53 # Let native babl/gegl find their plugins
54 export BABL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'babl-*'`
55 export GEGL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'gegl-*'`
56}
57
58FILES_${PN} += "${datadir}/metainfo"
59
60RDEPENDS_${PN} += "mypaint-brushes-1.0"