summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-12-22 17:56:43 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-23 09:32:56 +0100
commit28c25eb268b4f40a2c16a249d7a9fb7d8a94909a (patch)
tree47b35a6b363a1667325c82c58f35205126f4d78b /meta-gnome
parent44eea8e0790ca6a2d19ab372aa4eb2b74dad2602 (diff)
downloadmeta-openembedded-28c25eb268b4f40a2c16a249d7a9fb7d8a94909a.tar.gz
abiword: fix build with libpng-1.5 from oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword/libpng15.patch102
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb6
2 files changed, 106 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/libpng15.patch b/meta-gnome/recipes-gnome/abiword/abiword/libpng15.patch
new file mode 100644
index 000000000..0fc93c55b
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword/libpng15.patch
@@ -0,0 +1,102 @@
1Imported from gentoo
2
3$NetBSD: patch-plugins_bmp_xp_ie__impGraphic__BMP.cpp,v 1.1 2011/02/01 10:48:15 wiz Exp $
4
5Fix build with png-1.5.
6
7--- a/plugins/bmp/xp/ie_impGraphic_BMP.cpp.orig 2009-06-25 04:02:06.000000000 +0000
8+++ b/plugins/bmp/xp/ie_impGraphic_BMP.cpp
9@@ -191,7 +191,10 @@ UT_Error IE_ImpGraphic_BMP::_convertGrap
10
11 /* Clean Up Memory Used */
12
13- FREEP(m_pPNGInfo->palette);
14+ png_colorp palette;
15+ int num_palette;
16+ png_get_PLTE( m_pPNG, m_pPNGInfo, &palette, &num_palette );
17+ FREEP(palette);
18 DELETEP(pBB);
19 png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
20
21@@ -313,7 +316,7 @@ UT_Error IE_ImpGraphic_BMP::Initialize_P
22 * the normal method of doing things with libpng). REQUIRED unless you
23 * set up your own error handlers in the png_create_read_struct() earlier.
24 */
25- if (setjmp(m_pPNG->jmpbuf))
26+ if (setjmp(png_jmpbuf(m_pPNG)))
27 {
28 /* Free all of the memory associated with the png_ptr and info_ptr */
29 png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
30@@ -332,7 +335,7 @@ UT_Error IE_ImpGraphic_BMP::Initialize_P
31 UT_Error IE_ImpGraphic_BMP::Convert_BMP_Pallet(UT_ByteBuf* pBB)
32 {
33 /* Reset error handling for libpng */
34- if (setjmp(m_pPNG->jmpbuf))
35+ if (setjmp(png_jmpbuf(m_pPNG)))
36 {
37 png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
38 return UT_ERROR;
39@@ -372,7 +375,7 @@ UT_Error IE_ImpGraphic_BMP::Initialize_P
40 UT_Error IE_ImpGraphic_BMP::Convert_BMP(UT_ByteBuf* pBB)
41 {
42 /* Reset error handling for libpng */
43- if (setjmp(m_pPNG->jmpbuf))
44+ if (setjmp(png_jmpbuf(m_pPNG)))
45 {
46 png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
47 return UT_ERROR;
48
49$NetBSD: patch-plugins_garble_xp_abiword-garble-png.cpp,v 1.1 2011/02/01 10:48:15 wiz Exp $
50
51Fix build with png-1.5.
52
53--- a/plugins/garble/xp/abiword-garble-png.cpp.orig 2009-09-05 15:34:44.000000000 +0000
54+++ b/plugins/garble/xp/abiword-garble-png.cpp
55@@ -79,7 +79,7 @@ bool abiword_document::garble_png( void*
56 png_set_strip_alpha( png_ptr );
57 png_set_interlace_handling( png_ptr );
58 png_set_bgr( png_ptr );
59- rowbytes = info_ptr->rowbytes;
60+ rowbytes = png_get_rowbytes( png_ptr, info_ptr );
61 png_destroy_read_struct( &png_ptr, &info_ptr, NULL );
62 }
63
64$NetBSD: patch-af,v 1.12 2011/01/15 15:07:11 wiz Exp $
65
66Fix build with png-1.5.
67
68--- a/src/wp/impexp/gtk/ie_impGraphic_GdkPixbuf.cpp.orig 2009-07-01 04:02:04.000000000 +0000
69+++ b/src/wp/impexp/gtk/ie_impGraphic_GdkPixbuf.cpp
70@@ -185,7 +185,7 @@ UT_Error IE_ImpGraphic_GdkPixbuf::import
71 /** needed for the stejmp context */
72 UT_Error IE_ImpGraphic_GdkPixbuf::_png_write(GdkPixbuf * pixbuf)
73 {
74- if (setjmp(m_pPNG->jmpbuf))
75+ if (setjmp(png_jmpbuf(m_pPNG)))
76 {
77 DELETEP(m_pPngBB);
78 png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
79@@ -446,7 +446,7 @@ UT_Error IE_ImpGraphic_GdkPixbuf::Initia
80 * the normal method of doing things with libpng). REQUIRED unless you
81 * set up your own error handlers in the png_create_read_struct() earlier.
82 */
83- if (setjmp(m_pPNG->jmpbuf))
84+ if (setjmp(png_jmpbuf(m_pPNG)))
85 {
86 /* Free all of the memory associated with the png_ptr and info_ptr */
87 png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
88$NetBSD: patch-ae,v 1.21 2011/01/15 15:07:11 wiz Exp $
89
90Fix build with png-1.5.
91
92--- a/src/af/util/xp/ut_png.cpp.orig 2008-02-24 03:33:07.000000000 +0000
93+++ b/src/af/util/xp/ut_png.cpp
94@@ -71,7 +71,7 @@ bool UT_PNG_getDimensions(const UT_ByteB
95 * the normal method of doing things with libpng). REQUIRED unless you
96 * set up your own error handlers in the png_create_read_struct() earlier.
97 */
98- if (setjmp(png_ptr->jmpbuf))
99+ if (setjmp(png_jmpbuf(png_ptr)))
100 {
101 /* Free all of the memory associated with the png_ptr and info_ptr */
102 png_destroy_read_struct(&png_ptr, &info_ptr, static_cast<png_infopp>(NULL));
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
index c4bf3448d..a2cd1cc16 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
@@ -13,7 +13,9 @@ SRC_URI = "http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \
13 file://autogen-common.sh \ 13 file://autogen-common.sh \
14 file://nodolt.patch \ 14 file://nodolt.patch \
15 file://fix.no.undefined.param.patch \ 15 file://fix.no.undefined.param.patch \
16 file://abiword.fix.glib-2.32.patch" 16 file://abiword.fix.glib-2.32.patch \
17 file://libpng15.patch \
18"
17 19
18LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20" 20LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
19 21
@@ -23,7 +25,7 @@ SRC_URI[sha256sum] = "d99089a63a6cfc1a6a4a026be9278028d47d224088d24b1853acb67e95
23#want 2.x from 2.x.y for the installation directory 25#want 2.x from 2.x.y for the installation directory
24SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" 26SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
25 27
26PR = "r7" 28PR = "r8"
27 29
28inherit autotools pkgconfig 30inherit autotools pkgconfig
29 31