summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-10-12 10:13:12 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-19 11:42:13 +0200
commit8402b7ac0f2e3b0afd9d56e16e7935e1887c7698 (patch)
treea91a90f104a11aa51c5abc40c3dfd4972f735881 /meta-gnome
parent4cd60deb11a8a6f9134d7f6ec39255a35d921426 (diff)
downloadmeta-openembedded-8402b7ac0f2e3b0afd9d56e16e7935e1887c7698.tar.gz
PACKAGES_DYNAMIC: use regexp not glob
* bitbake uses PACKAGES_DYNAMIC as regexp ^ could make matching faster (and it will be more clear that we're expecting regexp not glob) * made all those last '-' optional, use .* (or nothing) * use += instead of = in most cases to keep ${PN}-locale from bitbake.conf:PACKAGES_DYNAMIC = "^${PN}-locale-.*" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb2
-rw-r--r--meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb2
-rw-r--r--meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb2
-rw-r--r--meta-gnome/recipes-support/goffice/goffice_0.8.17.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
index 8c3aab455..60b970bab 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
@@ -99,7 +99,7 @@ FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings"
99FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*" 99FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*"
100FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates" 100FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates"
101 101
102PACKAGES_DYNAMIC = "${PN}-meta ${PN}-plugin-*" 102PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*"
103 103
104python populate_packages_prepend () { 104python populate_packages_prepend () {
105 abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d) 105 abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d)
diff --git a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
index 586eed84f..46be86fce 100644
--- a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
+++ b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
@@ -40,7 +40,7 @@ FILES_${PN}-dbg += " ${libdir}/gnome-vfs-2.0/modules/.debug"
40FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/include" 40FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/include"
41FILES_${PN}-doc += " ${datadir}/gtk-doc" 41FILES_${PN}-doc += " ${datadir}/gtk-doc"
42 42
43PACKAGES_DYNAMIC = "gnome-vfs-plugin-*" 43PACKAGES_DYNAMIC += "^gnome-vfs-plugin-.*"
44 44
45python populate_packages_prepend () { 45python populate_packages_prepend () {
46 print bb.data.getVar('FILES_gnome-vfs', d, 1) 46 print bb.data.getVar('FILES_gnome-vfs', d, 1)
diff --git a/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb b/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb
index c1f535bd4..32b54ef0c 100644
--- a/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb
+++ b/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb
@@ -72,7 +72,7 @@ FILES_${PN}-dbg += " \
72 ${libdir}/gtk-3.0/modules/.debug" 72 ${libdir}/gtk-3.0/modules/.debug"
73 73
74 74
75PACKAGES_DYNAMIC += "gtk3-immodule-* gtk3-printbackend-*" 75PACKAGES_DYNAMIC += "^gtk3-immodule-.* ^gtk3-printbackend-.*"
76 76
77python populate_packages_prepend () { 77python populate_packages_prepend () {
78 import os.path 78 import os.path
diff --git a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
index c55a8acf6..4b6473149 100644
--- a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
+++ b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
@@ -36,7 +36,7 @@ FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS}
36 ${datadir}/idl ${datadir}/omf ${datadir}/sounds \ 36 ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
37 ${libdir}/bonobo/servers" 37 ${libdir}/bonobo/servers"
38 38
39PACKAGES_DYNAMIC = "goffice-plugin-*" 39PACKAGES_DYNAMIC += "^goffice-plugin-.*"
40 40
41python populate_packages_prepend () { 41python populate_packages_prepend () {
42 goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d) 42 goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d)