summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-06-11 23:16:04 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-20 12:29:55 +0200
commitd6e39a37749377225ee1e4b50dc70e33fb35c17a (patch)
tree6afd6f595e7190994d26af11df0b6bd5747ba5ef /meta-gnome
parent9c698137be199fe01dbdff801e5cd6561bdaae48 (diff)
downloadmeta-openembedded-d6e39a37749377225ee1e4b50dc70e33fb35c17a.tar.gz
gnome-keyring: Fix build error due to missing asn1 prototypes
This fixes the errors that started to pop up recently while building gnome-keyring as part of gnome images The error is decribed in patch header Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/egg-asn1x.patch55
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb3
2 files changed, 57 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/egg-asn1x.patch b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/egg-asn1x.patch
new file mode 100644
index 000000000..ad8a40ccf
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/egg-asn1x.patch
@@ -0,0 +1,55 @@
1Fixed build error with gcc 4.8
2
3Errors like below
4
5egg-asn1x.c: In function 'anode_encode_build':
6egg-asn1x.c:1280:7: warning: variable 'type' set but not used [-Wunused-but-set-variable]
7egg-asn1x.c: In function 'traverse_and_prepare':
8egg-asn1x.c:3354:3: warning: passing argument 1 of 'egg_asn1x_create' from incompatible pointer type [enabled by default]
9In file included from egg-asn1x.c:50:0:
10egg-asn1x.h:38:8: note: expected 'const struct static_struct_asn *' but argument is of type 'const struct asn1_static_node *'
11egg-asn1x.c: At top level:
12egg-asn1x.c:3509:1: error: conflicting types for 'egg_asn1x_create'
13In file included from egg-asn1x.c:50:0:
14egg-asn1x.h:38:8: note: previous declaration of 'egg_asn1x_create' was here
15egg-asn1x.c:3572:1: error: conflicting types for 'egg_asn1x_create_quark'
16In file included from egg-asn1x.c:50:0:
17egg-asn1x.h:41:8: note: previous declaration of 'egg_asn1x_create_quark' was here
18egg-asn1x.c:3579:1: error: conflicting types for 'egg_asn1x_create_and_decode'
19In file included from egg-asn1x.c:50:0:
20egg-asn1x.h:44:8: note: previous declaration of 'egg_asn1x_create_and_decode' was here
21make[4]: *** [libegg_la-egg-asn1x.lo] Error 1
22
23
24Signed-off-by: Khem Raj <raj.khem@gmail.com>
25
26Upstream-Status: Pending
27Index: gnome-keyring-2.32.1/egg/egg-asn1x.h
28===================================================================
29--- gnome-keyring-2.32.1.orig/egg/egg-asn1x.h 2010-10-18 19:11:38.000000000 -0700
30+++ gnome-keyring-2.32.1/egg/egg-asn1x.h 2013-06-11 15:15:00.675399263 -0700
31@@ -25,6 +25,7 @@
32 #define EGG_ASN1X_H_
33
34 #include <glib.h>
35+#include <libtasn1.h>
36
37 #ifndef HAVE_EGG_ALLOCATOR
38 typedef void* (*EggAllocator) (void* p, gsize);
39@@ -35,13 +36,13 @@
40
41 struct static_struct_asn;
42
43-GNode* egg_asn1x_create (const struct static_struct_asn *defs,
44+GNode* egg_asn1x_create (const ASN1_ARRAY_TYPE *defs,
45 const gchar *type);
46
47-GNode* egg_asn1x_create_quark (const struct static_struct_asn *defs,
48+GNode* egg_asn1x_create_quark (const ASN1_ARRAY_TYPE *defs,
49 GQuark type);
50
51-GNode* egg_asn1x_create_and_decode (const struct static_struct_asn *defs,
52+GNode* egg_asn1x_create_and_decode (const ASN1_ARRAY_TYPE *defs,
53 const gchar *type,
54 gconstpointer data,
55 gsize n_data);
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
index 72f272257..0d0f17124 100644
--- a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
@@ -15,6 +15,8 @@ PR = "r12"
15 15
16inherit autotools gnome gtk-doc pkgconfig gsettings 16inherit autotools gnome gtk-doc pkgconfig gsettings
17 17
18SRC_URI += "file://egg-asn1x.patch"
19
18DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" 20DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
19RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils" 21RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils"
20 22
@@ -24,7 +26,6 @@ SRC_URI[archive.md5sum] = "9a8aa74e03361676f29d6e73155786fc"
24SRC_URI[archive.sha256sum] = "31fecec1430a97f59a6159a5a2ea8d6a1b44287f1e9e595b3594df46bf7f18f9" 26SRC_URI[archive.sha256sum] = "31fecec1430a97f59a6159a5a2ea8d6a1b44287f1e9e595b3594df46bf7f18f9"
25 27
26FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr" 28FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr"
27
28 29
29FILES_${PN}-dev += "${libdir}/${BPN}/devel/*.la \ 30FILES_${PN}-dev += "${libdir}/${BPN}/devel/*.la \
30 ${libdir}/${BPN}/devel/*${SOLIBSDEV} \ 31 ${libdir}/${BPN}/devel/*${SOLIBSDEV} \