summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-06-12 07:06:12 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-20 12:29:55 +0200
commitb905770a499394923c5b62680c7ffe1014b7512b (patch)
tree32041f7b06772a88fcb4c16a4a58860e6f0bc242 /meta-gnome
parentd6e39a37749377225ee1e4b50dc70e33fb35c17a (diff)
downloadmeta-openembedded-b905770a499394923c5b62680c7ffe1014b7512b.tar.gz
gnome-session: Fix build on 64bit targets
use more portable G_GINT64_FORMAT instead of lld printf format Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-session/gnome-session/use_G_GINT64_FORMAT.patch61
-rw-r--r--meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb2
2 files changed, 63 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-session/gnome-session/use_G_GINT64_FORMAT.patch b/meta-gnome/recipes-gnome/gnome-session/gnome-session/use_G_GINT64_FORMAT.patch
new file mode 100644
index 000000000..b09f8d200
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-session/gnome-session/use_G_GINT64_FORMAT.patch
@@ -0,0 +1,61 @@
1This patch fixes the build errors when building gnome-session for 64bit target using gcc 4.8
2
3| gs-idle-monitor.c: In function 'handle_alarm_notify_event':
4| gs-idle-monitor.c:196:9: error: format '%lld' expects argument of type 'long long int', but argument 5 has type 'gint64' [-Werror=format=]
5| g_debug ("Watch %d fired, idle time = %lld",
6| ^
7| gs-idle-monitor.c: In function '_xsync_alarm_set':
8| gs-idle-monitor.c:453:17: error: format '%lld' expects argument of type 'long long int', but argument 4 has type 'gint64' [-Werror=format=]
9| g_debug ("GSIdleMonitor: updating alarm for positive transition wait=%lld",
10| ^
11| gs-idle-monitor.c:457:17: error: format '%lld' expects argument of type 'long long int', but argument 4 has type 'gint64' [-Werror=format=]
12| g_debug ("GSIdleMonitor: creating new alarm for positive transition wait=%lld",
13| ^
14| gs-idle-monitor.c:464:17: error: format '%lld' expects argument of type 'long long int', but argument 4 has type 'gint64' [-Werror=format=]
15| g_debug ("GSIdleMonitor: updating alarm for negative transition wait=%lld",
16| ^
17| gs-idle-monitor.c:468:17: error: format '%lld' expects argument of type 'long long int', but argument 4 has type 'gint64' [-Werror=format=]
18
19Upstream-Status: Unknown
20
21Signed-off-by: Khem Raj <raj.khem@gmail.com>
22Index: gnome-session-2.32.1/gnome-session/gs-idle-monitor.c
23===================================================================
24--- gnome-session-2.32.1.orig/gnome-session/gs-idle-monitor.c 2010-11-17 03:17:04.000000000 -0800
25+++ gnome-session-2.32.1/gnome-session/gs-idle-monitor.c 2013-06-11 23:33:12.239960082 -0700
26@@ -193,7 +193,7 @@
27 return;
28 }
29
30- g_debug ("Watch %d fired, idle time = %lld",
31+ g_debug ("Watch %d fired, idle time = %" G_GINT64_FORMAT "",
32 watch->id,
33 _xsyncvalue_to_int64 (alarm_event->counter_value));
34
35@@ -450,22 +450,22 @@
36
37 attr.trigger.test_type = XSyncPositiveTransition;
38 if (watch->xalarm_positive != None) {
39- g_debug ("GSIdleMonitor: updating alarm for positive transition wait=%lld",
40+ g_debug ("GSIdleMonitor: updating alarm for positive transition wait=%" G_GINT64_FORMAT "",
41 _xsyncvalue_to_int64 (attr.trigger.wait_value));
42 XSyncChangeAlarm (GDK_DISPLAY (), watch->xalarm_positive, flags, &attr);
43 } else {
44- g_debug ("GSIdleMonitor: creating new alarm for positive transition wait=%lld",
45+ g_debug ("GSIdleMonitor: creating new alarm for positive transition wait=%" G_GINT64_FORMAT "",
46 _xsyncvalue_to_int64 (attr.trigger.wait_value));
47 watch->xalarm_positive = XSyncCreateAlarm (GDK_DISPLAY (), flags, &attr);
48 }
49
50 attr.trigger.test_type = XSyncNegativeTransition;
51 if (watch->xalarm_negative != None) {
52- g_debug ("GSIdleMonitor: updating alarm for negative transition wait=%lld",
53+ g_debug ("GSIdleMonitor: updating alarm for negative transition wait=%" G_GINT64_FORMAT "",
54 _xsyncvalue_to_int64 (attr.trigger.wait_value));
55 XSyncChangeAlarm (GDK_DISPLAY (), watch->xalarm_negative, flags, &attr);
56 } else {
57- g_debug ("GSIdleMonitor: creating new alarm for negative transition wait=%lld",
58+ g_debug ("GSIdleMonitor: creating new alarm for negative transition wait=%" G_GINT64_FORMAT "",
59 _xsyncvalue_to_int64 (attr.trigger.wait_value));
60 watch->xalarm_negative = XSyncCreateAlarm (GDK_DISPLAY (), flags, &attr);
61 }
diff --git a/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb
index 93b0284a2..73f1ad596 100644
--- a/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb
@@ -9,6 +9,8 @@ DEPENDS = "libxtst gtk+ glib-2.0 upower dbus-glib gconf pango gdk-pixbuf-native
9 9
10inherit gnome 10inherit gnome
11 11
12SRC_URI += "file://use_G_GINT64_FORMAT.patch"
13
12SRC_URI[archive.md5sum] = "222bad6b446cb19a6b9028ea24538002" 14SRC_URI[archive.md5sum] = "222bad6b446cb19a6b9028ea24538002"
13SRC_URI[archive.sha256sum] = "22d93ce433fcf9c7ce6b5f36dd81f64e692ea0e41faaa0f61159ddac28c3686a" 15SRC_URI[archive.sha256sum] = "22d93ce433fcf9c7ce6b5f36dd81f64e692ea0e41faaa0f61159ddac28c3686a"
14 16