summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-08-04 13:49:00 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-14 13:34:28 +0200
commita38fbdb4f88ecfd624de3d3a41a1a42401f5451d (patch)
treee079f695929964f136ed07e8cc4aa44cc28d43eb /meta-gnome
parentc52054f3383120438cb52252f8c1622e73946349 (diff)
downloadmeta-openembedded-a38fbdb4f88ecfd624de3d3a41a1a42401f5451d.tar.gz
dates: make it compatible with newer evolution-data-server
* drop 0.4.8 recipe, git recipe is default version for long time and pimlico-project.org is gone anyway: wget: unable to resolve host address 'pimlico-project.org' Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/pimlico/dates/0001-Update-to-new-evolution-data-server-e_source_-color-.patch72
-rw-r--r--meta-gnome/recipes-gnome/pimlico/dates_0.4.8.bb5
-rw-r--r--meta-gnome/recipes-gnome/pimlico/dates_git.bb1
3 files changed, 73 insertions, 5 deletions
diff --git a/meta-gnome/recipes-gnome/pimlico/dates/0001-Update-to-new-evolution-data-server-e_source_-color-.patch b/meta-gnome/recipes-gnome/pimlico/dates/0001-Update-to-new-evolution-data-server-e_source_-color-.patch
new file mode 100644
index 000000000..4550d298d
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/dates/0001-Update-to-new-evolution-data-server-e_source_-color-.patch
@@ -0,0 +1,72 @@
1From a8ddfc4b91f2ab3d955fe528ddb98ce2c5545795 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sun, 4 Aug 2013 13:44:50 +0200
4Subject: [PATCH] Update to new evolution-data-server e_source_*color APIs
5
6Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
7---
8 src/dates_gtk.c | 6 +++---
9 src/dates_main.c | 2 +-
10 src/dates_view.c | 6 +++++-
11 3 files changed, 9 insertions(+), 5 deletions(-)
12
13diff --git a/src/dates_gtk.c b/src/dates_gtk.c
14index 78e71bb..ac539d2 100644
15--- a/src/dates_gtk.c
16+++ b/src/dates_gtk.c
17@@ -1072,7 +1072,7 @@ calendar_do_new_dialog (GtkWindow *parent, DatesData *d)
18 #endif
19
20 /* Set the colour */
21- e_source_set_color (source, new_colour);
22+ e_source_set_color_spec (source, new_colour);
23
24 /* Set the group for the source */
25 e_source_set_group (source, group);
26@@ -1335,7 +1335,7 @@ calendar_do_edit_dialog (GtkWindow *parent, ESource *source, DatesData *d)
27 gtk_misc_set_alignment (GTK_MISC (label), 0, 0.5);
28
29 /* Get the colour from the the source */
30- e_source_get_color (source, &raw_colour);
31+ raw_colour = e_source_peek_color_spec (source);
32
33 /* Munge this into something usable */
34 colour.red = (guint16)(((raw_colour & 0xff0000) >> 16) << 8);
35@@ -1459,7 +1459,7 @@ calendar_do_edit_dialog (GtkWindow *parent, ESource *source, DatesData *d)
36 new_colour <<= 8;
37 #endif
38 /* Update the colour */
39- e_source_set_color (source, new_colour);
40+ e_source_set_color_spec (source, new_colour);
41
42 /* And the name */
43 e_source_set_name (source, (gtk_entry_get_text (GTK_ENTRY (name_entry))));
44diff --git a/src/dates_main.c b/src/dates_main.c
45index ce05fe8..7273c63 100644
46--- a/src/dates_main.c
47+++ b/src/dates_main.c
48@@ -112,7 +112,7 @@ dates_load_calendars (DatesData *d)
49 system_source = e_source_new (_("Personal"), "system");
50
51 /* Default Evolution colour */
52- e_source_set_color (system_source, 0xBECEDD);
53+ e_source_set_color_spec (system_source, 0xBECEDD);
54
55 /* Set the group for the source and put it in the group */
56 e_source_set_group (system_source, local_group);
57diff --git a/src/dates_view.c b/src/dates_view.c
58index d65db2f..f8efb9c 100644
59--- a/src/dates_view.c
60+++ b/src/dates_view.c
61@@ -4876,7 +4880,7 @@ dates_view_add_calendar (DatesView *view, ECal *ecal)
62 cal->text_gc = gdk_gc_new (
63 GDK_DRAWABLE (priv->main->window));
64
65- if (e_source_get_color (source, &colour)) {
66+ if (colour = e_source_peek_color_spec (source)) {
67 GdkColor gcolour, dgcolour, tgcolour;
68 gcolour.red = ((colour & 0xFF0000) >> 16) * 0x101;
69 gcolour.green = ((colour & 0xFF00) >> 8) * 0x101;
70--
711.8.3.2
72
diff --git a/meta-gnome/recipes-gnome/pimlico/dates_0.4.8.bb b/meta-gnome/recipes-gnome/pimlico/dates_0.4.8.bb
deleted file mode 100644
index da3f27349..000000000
--- a/meta-gnome/recipes-gnome/pimlico/dates_0.4.8.bb
+++ /dev/null
@@ -1,5 +0,0 @@
1require dates.inc
2
3PR = "r6"
4
5SRC_URI = "http://pimlico-project.org/sources/dates/dates-${PV}.tar.gz"
diff --git a/meta-gnome/recipes-gnome/pimlico/dates_git.bb b/meta-gnome/recipes-gnome/pimlico/dates_git.bb
index 8966303ae..086abc772 100644
--- a/meta-gnome/recipes-gnome/pimlico/dates_git.bb
+++ b/meta-gnome/recipes-gnome/pimlico/dates_git.bb
@@ -15,4 +15,5 @@ SRC_URI = "git://git.gnome.org/${BPN};protocol=git \
15 file://make-382.patch \ 15 file://make-382.patch \
16 file://dso_linking_change_build_fix.patch \ 16 file://dso_linking_change_build_fix.patch \
17 file://uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch \ 17 file://uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch \
18 file://0001-Update-to-new-evolution-data-server-e_source_-color-.patch \
18" 19"