summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-07-02 06:46:36 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-08 10:35:57 +0200
commit519e7f1ccb9f6bdab2f37c1f4def75ed4e2a0fbc (patch)
treefbfd1bd6d006cc7a8cea49fdf480eb2186f36e26 /meta-gnome
parent830baf380ea86782a5a52fbe8762904840e05691 (diff)
downloadmeta-openembedded-519e7f1ccb9f6bdab2f37c1f4def75ed4e2a0fbc.tar.gz
abiword: remove abiword.inc - it is of no use
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword.inc64
1 files changed, 0 insertions, 64 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword.inc b/meta-gnome/recipes-gnome/abiword/abiword.inc
deleted file mode 100644
index 39c590c41..000000000
--- a/meta-gnome/recipes-gnome/abiword/abiword.inc
+++ /dev/null
@@ -1,64 +0,0 @@
1DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
2SECTION = "gnome/office"
3HOMEPAGE = "http://www.abiword.org""
4LICENSE = "GPLv2"
5
6DEPENDS = "libgsf libglade libfribidi libxml2 wv"
7RRECOMMENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
8 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
9
10# Share this file between recipes that use cvs and that pull tarballs
11# (one day change this to differentiate automatically based on PV and set the
12# SRC_URI and S var directly)
13RELURI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
14RELSRC = "${WORKDIR}/abiword-${PV}/abi"
15
16CVSURI = "cvs://anoncvs:anoncvs@anoncvs.abisource.com/cvsroot;module=abi"
17CVSSRC = "${WORKDIR}/abi"
18
19#want 2.x from 2.x.y for the installation directory
20SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
21
22FILES_${PN} += " \
23 ${datadir}/icons/* \
24 ${datadir}/mime-info \
25 ${datadir}/abiword-${SHRT_VER}/glade \
26 ${datadir}/abiword-${SHRT_VER}/system.profile-en \
27 ${datadir}/abiword-${SHRT_VER}/system.profile-en-GB \
28"
29
30# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
31# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
32
33inherit autotools pkgconfig
34
35PARALLEL_MAKE = ""
36
37# This is a minimalistic AbiWord build
38#
39# if you are planning to build plugins, make sure to comment out the
40# --disable-exports options
41
42EXTRA_OECONF = " --enable-embedded=poky \
43 --disable-printing \
44 --with-sys-wv \
45 --disable-exports \
46 --disable-spellcheck"
47
48# TODO -- refactor this, so that instead of two strings and profiles
49# packages we have lots of locale packages, each with a set of strings and
50# a profile
51#
52PACKAGES += " abiword-strings abiword-systemprofiles"
53
54FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
55FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
56
57# AbiWord configure.ac does not play nicely with autoreconf
58# so use the autogen.sh script that comes with AbiWord
59#
60do_configure() {
61 cd ${S}
62 export NOCONFIGURE="no"; ./autogen.sh
63 oe_runconf
64}