summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-04-26 13:34:44 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-03 20:47:02 +0200
commit8e1213bd66e7c5356a698f46c824424c02e2bc81 (patch)
tree398ecb24f27b352e47f0e392842c10c440f48c8a /meta-gnome
parent9df13b4140e8c6bfa0e4fb89107a6146981d2cdc (diff)
downloadmeta-openembedded-8e1213bd66e7c5356a698f46c824424c02e2bc81.tar.gz
abiword: Fix build when S != B
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
index 073622a72..39780bb3d 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
@@ -4,7 +4,7 @@ SECTION = "x11/office"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20" 5LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
6DEPENDS = "perl-native wv libglade libfribidi jpeg libpng \ 6DEPENDS = "perl-native wv libglade libfribidi jpeg libpng \
7 librsvg libwmf-native gtkmathview asio gtk+" 7 librsvg libwmf-native gtkmathview asio gtk+ evolution-data-server"
8RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \ 8RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
9 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1" 9 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
10RCONFLICTS_${PN} = "${PN}-embedded" 10RCONFLICTS_${PN} = "${PN}-embedded"
@@ -22,7 +22,7 @@ SRC_URI[sha256sum] = "d17e318c00ff4eb353e0e7994b098b1d4f9ddd8712ac0261a0e38b8908
22#want 3.x from 3.x.y for the installation directory 22#want 3.x from 3.x.y for the installation directory
23SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" 23SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
24 24
25inherit autotools pkgconfig 25inherit autotools-brokensep pkgconfig
26 26
27PACKAGECONFIG ??= "collab-backend-xmpp collab-backend-tcp collab-backend-service" 27PACKAGECONFIG ??= "collab-backend-xmpp collab-backend-tcp collab-backend-service"
28PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant" 28PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant"
@@ -44,17 +44,16 @@ EXTRA_OECONF = " --disable-static \
44# AbiWord configure.ac does not play nicely with autoreconf 44# AbiWord configure.ac does not play nicely with autoreconf
45# so use the autogen.sh script that comes with AbiWord 45# so use the autogen.sh script that comes with AbiWord
46do_configure() { 46do_configure() {
47 install -m 0755 ${WORKDIR}/autogen-common.sh ${S}/autogen-common.sh 47 install -m 0755 ${WORKDIR}/autogen-common.sh ${B}/autogen-common.sh
48 cd ${S}
49 ./autogen-common.sh 48 ./autogen-common.sh
50 autotools_do_configure 49 autotools_do_configure
51} 50}
52 51
53do_compile() { 52do_compile() {
54 cd ${S}/goffice-bits2 53 cd goffice-bits2
55 make goffice-paths.h 54 make goffice-paths.h
56 make libgoffice.la 55 make libgoffice.la
57 cd ${S} 56 cd ${B}
58 oe_runmake 57 oe_runmake
59} 58}
60 59