summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-04-19 04:57:59 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-21 13:31:48 +0200
commit3811927ec19f9995bc48277d70c296275fea0bd4 (patch)
tree5d34a38c1427e2255116bdcb25f8d3ffd46f476c /meta-gnome
parenta5cc93d8e3593ed055572a87d6c5a9c2e239b3d3 (diff)
downloadmeta-openembedded-3811927ec19f9995bc48277d70c296275fea0bd4.tar.gz
gnome-themes: enables the path to the icon-name-mapping to be specified
Ported a patch from sato-icon-theme which enables the path to the icon-name-mapping tool to be specified to fix the build failure: configure: error: icon-naming-utils >= 0.8.7 is required to build and install gnome-themes Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/themes/gnome-themes/iconpath-option.patch52
-rw-r--r--meta-gnome/recipes-gnome/themes/gnome-themes_2.32.1.bb10
2 files changed, 56 insertions, 6 deletions
diff --git a/meta-gnome/recipes-gnome/themes/gnome-themes/iconpath-option.patch b/meta-gnome/recipes-gnome/themes/gnome-themes/iconpath-option.patch
new file mode 100644
index 000000000..1b4096dd0
--- /dev/null
+++ b/meta-gnome/recipes-gnome/themes/gnome-themes/iconpath-option.patch
@@ -0,0 +1,52 @@
1
2The patch is ported from sato-icon-theme.
3
4pkg-config will only search the target sysroot and we want the native script. This
5patch adds an option to allow the path to the tool to be specified.
6
7Upstream-Status: Pending
8Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
9---
10 configure.in | 26 ++++++++++++++++----------
11 1 file changed, 16 insertions(+), 10 deletions(-)
12
13diff --git a/configure.in b/configure.in
14index 5f7a18c..e8fc31e 100644
15--- a/configure.in
16+++ b/configure.in
17@@ -74,16 +74,22 @@ AC_ARG_ENABLE([icon-mapping],
18 ICONMAP="true"
19 if test "x$enable_mapping" != "xno"; then
20 UTILS_REQUIRED=0.8.7
21-
22- AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
23- PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED, have_utils=yes, have_utils=no)
24- if test "x$have_utils" = "xyes"; then
25- UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
26- ICONMAP="$UTILS_PATH/icon-name-mapping"
27- AC_MSG_RESULT([yes])
28- else
29- AC_MSG_RESULT([no])
30- AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build and install gnome-themes])
31+ PKG_PROG_PKG_CONFIG()
32+ AC_ARG_WITH(iconmap,
33+ AC_HELP_STRING([--with-iconmap=<dir>], [The location of the icon-name-mapping script to use]),
34+ ICONMAP=$withval, ICONMAP="")
35+ if test "x$ICONMAP" = "x"; then
36+ AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
37+ PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED, have_utils=yes, have_utils=no)
38+ if test "x$have_utils" = "xyes"; then
39+ UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
40+ ICONMAP="$UTILS_PATH/icon-name-mapping"
41+
42+ AC_MSG_RESULT([yes])
43+ else
44+ AC_MSG_RESULT([no])
45+ AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build and install gnome-themes"])
46+ fi
47 fi
48 fi
49 AC_SUBST(ICONMAP)
50--
511.7.9.5
52
diff --git a/meta-gnome/recipes-gnome/themes/gnome-themes_2.32.1.bb b/meta-gnome/recipes-gnome/themes/gnome-themes_2.32.1.bb
index 7863c5cbc..6664bfa2b 100644
--- a/meta-gnome/recipes-gnome/themes/gnome-themes_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/themes/gnome-themes_2.32.1.bb
@@ -8,14 +8,12 @@ SECTION = "x11/gnome"
8DEPENDS = "gtk-engines icon-naming-utils icon-naming-utils-native glib-2.0 intltool-native libxml-simple-perl-native" 8DEPENDS = "gtk-engines icon-naming-utils icon-naming-utils-native glib-2.0 intltool-native libxml-simple-perl-native"
9RDEPENDS_${PN} = "gnome-icon-theme" 9RDEPENDS_${PN} = "gnome-icon-theme"
10 10
11EXTRA_OECONF += "--enable-all-themes --disable-hicolor-check" 11EXTRA_OECONF += "--enable-all-themes --disable-hicolor-check \
12 --with-iconmap=${STAGING_LIBDIR_NATIVE}/icon-naming-utils/icon-name-mapping \
13"
12 14
13inherit gnomebase perlnative 15inherit gnomebase perlnative
14 16
15do_configure_prepend() {
16 sed -i -e 's:`$PKG_CONFIG --variable=program_path icon-naming-utils`:${STAGING_DIR_NATIVE}${libdir}/icon-naming-utils:g' configure.in
17}
18
19PACKAGES =+ " gnome-theme-crux gnome-theme-highcontrast gnome-theme-highcontrastinverse gnome-theme-highcontrastlargeprint gnome-theme-highcontrastlargeprintinverse gnome-theme-largeprint gnome-theme-mist" 17PACKAGES =+ " gnome-theme-crux gnome-theme-highcontrast gnome-theme-highcontrastinverse gnome-theme-highcontrastlargeprint gnome-theme-highcontrastlargeprintinverse gnome-theme-largeprint gnome-theme-mist"
20FILES_gnome-theme-crux = "${datadir}/themes/Crux ${datadir}/icons/Crux" 18FILES_gnome-theme-crux = "${datadir}/themes/Crux ${datadir}/icons/Crux"
21FILES_gnome-theme-highcontrast = "${datadir}/themes/HighContrast ${datadir}/icons/HighContrast" 19FILES_gnome-theme-highcontrast = "${datadir}/themes/HighContrast ${datadir}/icons/HighContrast"
@@ -27,6 +25,6 @@ FILES_gnome-theme-mist = "${datadir}/themes/Mist ${datadir}/icons/Mist"
27 25
28FILES_${PN} += "${datadir}/themes ${datadir}/icons" 26FILES_${PN} += "${datadir}/themes ${datadir}/icons"
29 27
28SRC_URI += "file://iconpath-option.patch"
30SRC_URI[archive.md5sum] = "41db9e3cb25d35af2675c599e67944d1" 29SRC_URI[archive.md5sum] = "41db9e3cb25d35af2675c599e67944d1"
31SRC_URI[archive.sha256sum] = "8601ee24c2e096593221cbd6ebdb6686042225a03c02a01c0d67c163f9febd1a" 30SRC_URI[archive.sha256sum] = "8601ee24c2e096593221cbd6ebdb6686042225a03c02a01c0d67c163f9febd1a"
32