summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-24 16:45:38 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-24 17:34:02 +0200
commit040daebc80af5bdcad3636604ac55fc6a9ac1e5d (patch)
tree25ad7d2bc87fe2b33bcea1a3a3b5dcc123a45b5e /meta-gnome/recipes-support
parentcbcf7323bf48752fe3ca81d4634d3e626507f2e9 (diff)
downloadmeta-openembedded-040daebc80af5bdcad3636604ac55fc6a9ac1e5d.tar.gz
goffice 0.8.17: import from OE classic
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-support')
-rw-r--r--meta-gnome/recipes-support/goffice/goffice/c99math.patch12
-rw-r--r--meta-gnome/recipes-support/goffice/goffice/nodolt.patch12
-rw-r--r--meta-gnome/recipes-support/goffice/goffice_0.8.17.bb46
3 files changed, 70 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/goffice/goffice/c99math.patch b/meta-gnome/recipes-support/goffice/goffice/c99math.patch
new file mode 100644
index 000000000..24e6c31a7
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice/c99math.patch
@@ -0,0 +1,12 @@
1Index: goffice-0.7.14/configure.in
2===================================================================
3--- goffice-0.7.14.orig/configure.in 2009-11-14 19:14:37.106109501 +0100
4+++ goffice-0.7.14/configure.in 2009-11-14 19:19:40.907333188 +0100
5@@ -66,6 +66,7 @@
6
7 AC_ISC_POSIX
8 AC_PROG_CC
9+AC_PROG_CC_C99
10 AC_PROG_YACC
11 AM_PROG_LEX
12 AC_PROG_LN_S
diff --git a/meta-gnome/recipes-support/goffice/goffice/nodolt.patch b/meta-gnome/recipes-support/goffice/goffice/nodolt.patch
new file mode 100644
index 000000000..ea1777a99
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice/nodolt.patch
@@ -0,0 +1,12 @@
1Index: goffice-0.7.14/configure.in
2===================================================================
3--- goffice-0.7.14.orig/configure.in
4+++ goffice-0.7.14/configure.in
5@@ -71,7 +71,6 @@ AC_PROG_YACC
6 AM_PROG_LEX
7 AC_PROG_LN_S
8 AM_PROG_LIBTOOL
9-DOLT
10 AC_STDC_HEADERS
11 AC_SYS_LARGEFILE
12
diff --git a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
new file mode 100644
index 000000000..9988c4120
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
@@ -0,0 +1,46 @@
1DESCRIPTION="Gnome Office Library"
2
3LICENSE="GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fa1348b178f4a7322170203c6c36f4c3"
5
6DEPENDS = "libxml-parser-perl-native glib-2.0 gtk+ pango cairo libgsf libpcre libxml2 libart-lgpl"
7
8inherit gnome pkgconfig perlnative
9
10SRC_URI += " file://c99math.patch \
11 file://nodolt.patch "
12
13SRC_URI[archive.md5sum] = "b4c924457163e02daf8a8d2428f51d10"
14SRC_URI[archive.sha256sum] = "dd8caef5fefffbc53938fa619de9f58e7c4dc71a1803de134065d42138a68c06"
15
16FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
17
18RRECOMMENDS_${PN} = " \
19 goffice-plugin-plot-barcol \
20 goffice-plugin-plot-distrib \
21 goffice-plugin-plot-pie \
22 goffice-plugin-plot-radar \
23 goffice-plugin-plot-surface \
24 goffice-plugin-plot-xy \
25 goffice-plugin-reg-linear \
26 goffice-plugin-reg-logfit \
27 goffice-plugin-smoothing \
28"
29
30FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
31 ${sysconfdir} ${sharedstatedir} ${localstatedir} \
32 ${base_bindir}/* ${base_sbindir}/* \
33 ${base_libdir}/*${SOLIBS} \
34 ${datadir}/${PN} \
35 ${datadir}/pixmaps ${datadir}/applications \
36 ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
37 ${libdir}/bonobo/servers"
38
39PACKAGES_DYNAMIC = "goffice-plugin-*"
40
41python populate_packages_prepend () {
42 goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d)
43
44 do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
45}
46