diff options
author | Markus Volk <f_l_k@t-online.de> | 2023-03-25 09:02:48 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-03-28 10:44:00 -0700 |
commit | 89ed607ea5642eed2822515c4bfd7cf6a6b9bb86 (patch) | |
tree | 2c6d417536a065d13e31969a9f254f200653c020 /meta-gnome/recipes-gnome | |
parent | d348914e40db47367ebf341a2f97d0645a95220b (diff) | |
download | meta-openembedded-89ed607ea5642eed2822515c4bfd7cf6a6b9bb86.tar.gz |
libgtop: update 2.40.0 -> 2.41.1
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome')
-rw-r--r-- | meta-gnome/recipes-gnome/libgtop/libgtop/0001-Pass-correct-parameter.patch | 29 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/libgtop/libgtop/0001-fix-compile-error-for-cross-compile.patch | 37 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/libgtop/libgtop/0001-netload-Include-libc-net-headers-unconditionally.patch | 46 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/libgtop/libgtop_2.41.1.bb (renamed from meta-gnome/recipes-gnome/libgtop/libgtop_2.40.0.bb) | 6 |
4 files changed, 1 insertions, 117 deletions
diff --git a/meta-gnome/recipes-gnome/libgtop/libgtop/0001-Pass-correct-parameter.patch b/meta-gnome/recipes-gnome/libgtop/libgtop/0001-Pass-correct-parameter.patch deleted file mode 100644 index 5ea8eed51..000000000 --- a/meta-gnome/recipes-gnome/libgtop/libgtop/0001-Pass-correct-parameter.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From e969ac59335d3fb1cd228f8e7c4f6c2dda4fa536 Mon Sep 17 00:00:00 2001 | ||
2 | From: Avinash Sonawane <rootkea@gmail.com> | ||
3 | Date: Mon, 20 Dec 2021 13:33:42 +0530 | ||
4 | Subject: [PATCH] Pass correct parameter | ||
5 | |||
6 | Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/libgtop/-/merge_requests/35] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | src/daemon/main.c | 3 ++- | ||
10 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/src/daemon/main.c b/src/daemon/main.c | ||
13 | index b51addf..eaee3b3 100644 | ||
14 | --- a/src/daemon/main.c | ||
15 | +++ b/src/daemon/main.c | ||
16 | @@ -222,8 +222,9 @@ handle_parent_connection (int s) | ||
17 | 0, NULL); | ||
18 | break; | ||
19 | case GLIBTOP_CMND_PROC_IO: | ||
20 | + memcpy (&pid, parameter, sizeof (pid_t)); | ||
21 | glibtop_get_proc_io_l | ||
22 | - (server, &resp->u.data.proc_io, parameter); | ||
23 | + (server, &resp->u.data.proc_io, pid); | ||
24 | do_output (s, resp, _offset_data (proc_io), | ||
25 | 0, NULL); | ||
26 | break; | ||
27 | -- | ||
28 | 2.37.2 | ||
29 | |||
diff --git a/meta-gnome/recipes-gnome/libgtop/libgtop/0001-fix-compile-error-for-cross-compile.patch b/meta-gnome/recipes-gnome/libgtop/libgtop/0001-fix-compile-error-for-cross-compile.patch deleted file mode 100644 index 1bd6e101b..000000000 --- a/meta-gnome/recipes-gnome/libgtop/libgtop/0001-fix-compile-error-for-cross-compile.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From e865a93000913b4597607289356114cd159f4e28 Mon Sep 17 00:00:00 2001 | ||
2 | From: Your Name <you@example.com> | ||
3 | Date: Fri, 21 May 2021 03:02:29 +0000 | ||
4 | Subject: [PATCH] fix compile error for cross compile | ||
5 | |||
6 | On some distros, such as fedora32, cross compile failed with following | ||
7 | error since host library is used. undefined reference to | ||
8 | `stat64@GLIBC_2.33' | ||
9 | |||
10 | According doc of ld, set searchdir begins with "=", but not hardcoded | ||
11 | locations. | ||
12 | |||
13 | Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/libgtop/-/merge_requests/26] | ||
14 | |||
15 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | ||
16 | --- | ||
17 | configure.ac | 4 ++-- | ||
18 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
19 | |||
20 | diff --git a/configure.ac b/configure.ac | ||
21 | index 472f44b..ed6a4d7 100644 | ||
22 | --- a/configure.ac | ||
23 | +++ b/configure.ac | ||
24 | @@ -270,8 +270,8 @@ AC_ARG_ENABLE(fatal-warnings, | ||
25 | [Define to enable fatal warnings])) | ||
26 | |||
27 | dnl These definitions are expanded in make. | ||
28 | -LIBGTOP_LIBS='-L$(libdir)' | ||
29 | -LIBGTOP_INCS='-I$(includedir)/libgtop-2.0' | ||
30 | +LIBGTOP_LIBS='-L=$(libdir)' | ||
31 | +LIBGTOP_INCS='-I=$(includedir)/libgtop-2.0' | ||
32 | |||
33 | if test x$libgtop_have_sysinfo = xyes ; then | ||
34 | LIBGTOP_INCS="$LIBGTOP_INCS -DHAVE_LIBGTOP_SYSINFO" | ||
35 | -- | ||
36 | 2.26.2 | ||
37 | |||
diff --git a/meta-gnome/recipes-gnome/libgtop/libgtop/0001-netload-Include-libc-net-headers-unconditionally.patch b/meta-gnome/recipes-gnome/libgtop/libgtop/0001-netload-Include-libc-net-headers-unconditionally.patch deleted file mode 100644 index c4f7da4bf..000000000 --- a/meta-gnome/recipes-gnome/libgtop/libgtop/0001-netload-Include-libc-net-headers-unconditionally.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | From 3c6f70e50cb586ac4add4dea627c316242691040 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 13 Jul 2017 09:17:29 -0700 | ||
4 | Subject: [PATCH] netload: Include libc net headers unconditionally | ||
5 | |||
6 | This fixes compile with musl, and this conditional | ||
7 | is not needed now a days if we are still using glibc < 1.0 | ||
8 | we have other bigger problems | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | sysdeps/linux/netload.c | 11 ----------- | ||
13 | 1 file changed, 11 deletions(-) | ||
14 | |||
15 | diff --git a/sysdeps/linux/netload.c b/sysdeps/linux/netload.c | ||
16 | index c275db2..446bddd 100644 | ||
17 | --- a/sysdeps/linux/netload.c | ||
18 | +++ b/sysdeps/linux/netload.c | ||
19 | @@ -34,8 +34,6 @@ | ||
20 | #include <sys/socket.h> | ||
21 | #include <sys/ioctl.h> | ||
22 | |||
23 | -#if !defined (_LIBC) && defined (__GNU_LIBRARY__) && __GNU_LIBRARY__ > 1 | ||
24 | -/* GNU LibC */ | ||
25 | #include <net/if.h> | ||
26 | #include <netinet/ip_icmp.h> | ||
27 | #include <netinet/in.h> | ||
28 | @@ -43,15 +41,6 @@ | ||
29 | #include <netinet/tcp.h> | ||
30 | #include <netinet/udp.h> | ||
31 | #include <net/if.h> | ||
32 | -#else /* Libc 5 */ | ||
33 | -#include <linux/if.h> | ||
34 | -#include <linux/in.h> | ||
35 | -#include <linux/ip.h> | ||
36 | -#include <linux/icmp.h> | ||
37 | -#include <linux/tcp.h> | ||
38 | -#include <linux/udp.h> | ||
39 | -#endif | ||
40 | - | ||
41 | |||
42 | #ifdef HAVE_IFADDRS_H | ||
43 | /* needed for IPV6 support */ | ||
44 | -- | ||
45 | 2.13.2 | ||
46 | |||
diff --git a/meta-gnome/recipes-gnome/libgtop/libgtop_2.40.0.bb b/meta-gnome/recipes-gnome/libgtop/libgtop_2.41.1.bb index fa95e0bee..9a50b5e82 100644 --- a/meta-gnome/recipes-gnome/libgtop/libgtop_2.40.0.bb +++ b/meta-gnome/recipes-gnome/libgtop/libgtop_2.41.1.bb | |||
@@ -6,10 +6,6 @@ inherit gnomebase lib_package gtk-doc gobject-introspection gettext upstream-ver | |||
6 | 6 | ||
7 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" | 7 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
8 | 8 | ||
9 | SRC_URI += "file://0001-fix-compile-error-for-cross-compile.patch \ | 9 | SRC_URI[archive.sha256sum] = "43ea9ad13f7caf98303e64172b191be9b96bab340b019deeec72251ee140fe3b" |
10 | file://0001-Pass-correct-parameter.patch \ | ||
11 | " | ||
12 | |||
13 | SRC_URI[archive.sha256sum] = "78f3274c0c79c434c03655c1b35edf7b95ec0421430897fb1345a98a265ed2d4" | ||
14 | 10 | ||
15 | DEPENDS = "glib-2.0 libxau" | 11 | DEPENDS = "glib-2.0 libxau" |