summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmx.de>2012-01-08 19:02:23 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-09 10:31:00 +0100
commit5b8522e3b592c96ec9325aff4bbaa68972e52d5b (patch)
tree4b4fb90a11c5fc3ecf3bd6f7ae8a649eaca26a48 /meta-gnome/recipes-gnome
parent6ae89951a73c97f6f1b4bbde39f3dadb72fa3dcd (diff)
downloadmeta-openembedded-5b8522e3b592c96ec9325aff4bbaa68972e52d5b.tar.gz
gvfs: rework and add recipe for gvfs-gdu-volume-monitor
To make gvfs work with removable devices/volumes, gvfs-gdu-volume-monitor ( gdu = gnome-disk-utility ) is required. During a build from scratch gvfs-configure disables gdu because it can not find gnome-disk-utility. It can not be added to gvfs DEPENDS because this causes circular dependencies: nautilus DEPENDS gvfs gvfs DEPENDS gnome-disk-utility gnome-disk-utility DEPENDS nautilus The solution is a new recipe for gvfs-gdu-volume-monitor. To reduce maintenance efforts and to ensure that gvfs-gdu-volume-monitor is build under same conditions as gvfs, as much settings as possible were moved to gvfs.inc. INC_PR is started at 6 to ensure rebuilding. run-tested for incremental build and build from scratch. Signed-off-by: Andreas Müller <schnitzeltony@gmx.de> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gvfs/gvfs-gdu-volume-monitor_1.8.2.bb22
-rw-r--r--meta-gnome/recipes-gnome/gvfs/gvfs.inc19
-rw-r--r--meta-gnome/recipes-gnome/gvfs/gvfs_1.8.2.bb22
3 files changed, 47 insertions, 16 deletions
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs-gdu-volume-monitor_1.8.2.bb b/meta-gnome/recipes-gnome/gvfs/gvfs-gdu-volume-monitor_1.8.2.bb
new file mode 100644
index 000000000..c87b63e8f
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gvfs/gvfs-gdu-volume-monitor_1.8.2.bb
@@ -0,0 +1,22 @@
1require gvfs.inc
2
3BPN = "gvfs"
4
5DEPENDS = "gvfs gnome-disk-utility"
6
7PR = "${INC_PR}.0"
8
9# we need gdu files only: reduce files to delete in libexecdir
10EXTRA_OECONF += "--disable-gphoto2"
11
12do_install_append() {
13 rm -rf ${D}${sysconfdir}
14 rm -rf ${D}${bindir}
15 rm -rf ${D}${includedir}
16 rm -rf ${D}${libdir}
17 rm -rf ${D}${datadir}/gvfs/mounts
18 rm -f ${D}${datadir}/dbus-1/services/gvfs-*
19 rm -f ${D}${libexecdir}/gvfsd*
20 rm -f ${D}${libexecdir}/gvfs-fuse-daemon
21 rm -f ${D}${libexecdir}/gvfs-gphoto2-volume-monitor
22}
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs.inc b/meta-gnome/recipes-gnome/gvfs/gvfs.inc
new file mode 100644
index 000000000..b6a0526f4
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gvfs/gvfs.inc
@@ -0,0 +1,19 @@
1DESCRIPTION = "gvfs is a userspace virtual filesystem"
2LICENSE = "LGPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
4
5inherit gnome
6
7INC_PR = "r6"
8
9SRC_URI[archive.md5sum] = "402f94b187b197b403d25c85caeb9562"
10SRC_URI[archive.sha256sum] = "0895ac8f6d416e1b15433b6b6b68eb119c6e8b04fdb66db665d684355ef89345"
11
12EXTRA_OECONF = "--disable-samba \
13 --with-samba-includes=${STAGING_INCDIR} \
14 --with-samba-libs=${STAGING_LIBDIR} \
15 --with-archive-includes=${STAGING_INCDIR} \
16 "
17
18FILES_${PN} += "${datadir}/dbus-1/services/*"
19
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs_1.8.2.bb b/meta-gnome/recipes-gnome/gvfs/gvfs_1.8.2.bb
index 5a230ebd7..297d6819c 100644
--- a/meta-gnome/recipes-gnome/gvfs/gvfs_1.8.2.bb
+++ b/meta-gnome/recipes-gnome/gvfs/gvfs_1.8.2.bb
@@ -1,27 +1,16 @@
1DESCRIPTION = "gvfs is a userspace virtual filesystem" 1require gvfs.inc
2LICENSE = "LGPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
4 2
5DEPENDS = "gnome-keyring glib-2.0 fuse avahi fuse gconf libgphoto2" 3DEPENDS = "gnome-keyring glib-2.0 fuse avahi fuse gconf libgphoto2"
6# optional: obexftp libcdio libimobiledevice 4# optional: obexftp libcdio libimobiledevice
7# building against gnome-disk-utility is also possible, but brings dependency loops :(
8 5
9PR = "r6" 6PR = "${INC_PR}.0"
10 7
11inherit gnome 8# in case of gnome-disk-utility was alresdy built: avoid double files
12 9EXTRA_OECONF += "--disable-gdu"
13SRC_URI[archive.md5sum] = "402f94b187b197b403d25c85caeb9562"
14SRC_URI[archive.sha256sum] = "0895ac8f6d416e1b15433b6b6b68eb119c6e8b04fdb66db665d684355ef89345"
15
16EXTRA_OECONF = "--disable-samba \
17 --with-samba-includes=${STAGING_INCDIR} \
18 --with-samba-libs=${STAGING_LIBDIR} \
19 --with-archive-includes=${STAGING_INCDIR} \
20 "
21 10
22PACKAGES =+ "gvfsd-ftp gvfsd-sftp gvfsd-trash" 11PACKAGES =+ "gvfsd-ftp gvfsd-sftp gvfsd-trash"
23 12
24FILES_${PN} += "${datadir}/dbus-1/services/* ${datadir}/GConf ${datadir}/glib-2.0 ${libdir}/gio/modules/*.so" 13FILES_${PN} += "${datadir}/glib-2.0 ${datadir}/GConf ${libdir}/gio/modules/*.so"
25FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/*" 14FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/*"
26FILES_${PN}-dev += "${libdir}/gio/modules/*.la" 15FILES_${PN}-dev += "${libdir}/gio/modules/*.la"
27 16
@@ -29,4 +18,5 @@ FILES_gvfsd-ftp = "${libexecdir}/gvfsd-ftp ${datadir}/gvfs/mounts/ftp.mount"
29FILES_gvfsd-sftp = "${libexecdir}/gvfsd-sftp ${datadir}/gvfs/mounts/sftp.mount" 18FILES_gvfsd-sftp = "${libexecdir}/gvfsd-sftp ${datadir}/gvfs/mounts/sftp.mount"
30FILES_gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.mount" 19FILES_gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.mount"
31 20
21RDEPENDS_${PN} = "gvfs-gdu-volume-monitor"
32RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh" 22RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh"