summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/pimlico
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-gnome/recipes-gnome/pimlico
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/pimlico')
-rw-r--r--meta-gnome/recipes-gnome/pimlico/contacts.inc28
-rw-r--r--meta-gnome/recipes-gnome/pimlico/contacts/contacts-conditionally-install-schema.patch37
-rw-r--r--meta-gnome/recipes-gnome/pimlico/contacts/make-382.patch16
-rw-r--r--meta-gnome/recipes-gnome/pimlico/contacts/stock_contact.pngbin0 -> 2311 bytes
-rw-r--r--meta-gnome/recipes-gnome/pimlico/contacts/stock_person.pngbin0 -> 2280 bytes
-rw-r--r--meta-gnome/recipes-gnome/pimlico/contacts_0.9.bb18
-rw-r--r--meta-gnome/recipes-gnome/pimlico/contacts_git.bb19
-rw-r--r--meta-gnome/recipes-gnome/pimlico/dates.inc11
-rw-r--r--meta-gnome/recipes-gnome/pimlico/dates/0001-Update-to-new-evolution-data-server-e_source_-color-.patch72
-rw-r--r--meta-gnome/recipes-gnome/pimlico/dates/dso_linking_change_build_fix.patch44
-rw-r--r--meta-gnome/recipes-gnome/pimlico/dates/make-382.patch18
-rw-r--r--meta-gnome/recipes-gnome/pimlico/dates/uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch37
-rw-r--r--meta-gnome/recipes-gnome/pimlico/dates_git.bb19
-rw-r--r--meta-gnome/recipes-gnome/pimlico/tasks.inc10
-rw-r--r--meta-gnome/recipes-gnome/pimlico/tasks_0.19.bb13
-rw-r--r--meta-gnome/recipes-gnome/pimlico/tasks_git.bb9
16 files changed, 351 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/pimlico/contacts.inc b/meta-gnome/recipes-gnome/pimlico/contacts.inc
new file mode 100644
index 000000000..6535bbf54
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/contacts.inc
@@ -0,0 +1,28 @@
1DESCRIPTION = "Address-book application."
2HOMEPAGE = "http://pimlico-project.org/contacts.html"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "GPLv2 & GPLv2+ & GPLv3+ "
6SECTION = "x11"
7DEPENDS = "glib-2.0 gtk+ evolution-data-server intltool-native"
8RDEPENDS_${PN} = "libedata-book"
9
10inherit autotools pkgconfig
11
12EXTRA_OECONF += "--disable-gnome-vfs"
13EXTRA_OEMAKE += "GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1"
14
15do_install_append () {
16 install -d ${D}/${datadir}/pixmaps
17 install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/pixmaps
18 install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/pixmaps
19}
20
21FILES_${PN} += "${datadir}/pixmaps/stock_contact.png \
22 ${datadir}/pixmaps/stock_person.png \
23 ${datadir}/icons/hicolor"
24
25SRC_URI = "file://stock_contact.png \
26 file://stock_person.png \
27 file://contacts-conditionally-install-schema.patch \
28"
diff --git a/meta-gnome/recipes-gnome/pimlico/contacts/contacts-conditionally-install-schema.patch b/meta-gnome/recipes-gnome/pimlico/contacts/contacts-conditionally-install-schema.patch
new file mode 100644
index 000000000..2ab7882c8
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/contacts/contacts-conditionally-install-schema.patch
@@ -0,0 +1,37 @@
1Install schema should respect to GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
2
3If GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL is set, the schema should not
4be installed.
5
6Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
7
8Upstream-Status: Pending
9---
10 data/Makefile.am | 7 ++++---
11 1 files changed, 4 insertions(+), 3 deletions(-)
12
13diff --git a/data/Makefile.am b/data/Makefile.am
14index f790823..b6fd643 100644
15--- a/data/Makefile.am
16+++ b/data/Makefile.am
17@@ -14,13 +14,14 @@ dist_man1_MANS = contacts.1
18
19 if HAVE_GCONF
20 install-data-local:
21- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) \
22+ if [ "$(GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL)" != "1" ]; then \
23+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) \
24 $(GCONFTOOL) --makefile-install-rule $(schema_DATA) || \
25 (echo ;\
26 echo "*****************************************************"; \
27 echo "Installation of schemas failed, install them manually"; \
28- echo "*****************************************************";)
29- @true
30+ echo "*****************************************************";); \
31+ fi
32 endif
33
34 CLEANFILES = $(desktop_DATA)
35--
361.7.7.6
37
diff --git a/meta-gnome/recipes-gnome/pimlico/contacts/make-382.patch b/meta-gnome/recipes-gnome/pimlico/contacts/make-382.patch
new file mode 100644
index 000000000..a7cfee3a0
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/contacts/make-382.patch
@@ -0,0 +1,16 @@
1Fix for stricter parser in make 3.82. This fix has been pushed to upstream git.
2
3JL - 15/12/10
4
5Upstream-Status: Accepted
6
7Index: git/Makefile.am
8===================================================================
9--- git.orig/Makefile.am
10+++ git/Makefile.am
11@@ -11,4 +11,4 @@ DISTCLEANFILES = $(INTLTOOL_BUILT)
12 MAINTAINERCLEANFILES = aclocal.m4 compile config.guess config.sub configure depcomp $(INTLTOOL_BUILT:=.in) install-sh ltmain.sh mkinstalldirs Makefile.in missing
13
14 snapshot:
15- $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
16+ $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
diff --git a/meta-gnome/recipes-gnome/pimlico/contacts/stock_contact.png b/meta-gnome/recipes-gnome/pimlico/contacts/stock_contact.png
new file mode 100644
index 000000000..123b4485a
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/contacts/stock_contact.png
Binary files differ
diff --git a/meta-gnome/recipes-gnome/pimlico/contacts/stock_person.png b/meta-gnome/recipes-gnome/pimlico/contacts/stock_person.png
new file mode 100644
index 000000000..2b1328b4e
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/contacts/stock_person.png
Binary files differ
diff --git a/meta-gnome/recipes-gnome/pimlico/contacts_0.9.bb b/meta-gnome/recipes-gnome/pimlico/contacts_0.9.bb
new file mode 100644
index 000000000..bdc7f4886
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/contacts_0.9.bb
@@ -0,0 +1,18 @@
1require contacts.inc
2
3PR = "r8"
4
5SRC_URI =+ "http://pimlico-project.org/sources/${BPN}/${BPN}-${PV}.tar.gz"
6
7SRC_URI[md5sum] = "aab5affbf93d6fa7b978b323a8d44de0"
8SRC_URI[sha256sum] = "9cacec98f8123993033aaa255f3f4c04c86a1be65e487dd21f0aaa54384a6f6d"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
11 file://src/contacts-main.h;endline=18;md5=0371af46fbc72e33575e0072dca5fb19 \
12 file://src/contacts-dbus.c;endline=18;md5=e4da9ac1a0539fafc7df431010904fd5 \
13 file://src/contacts-gtk.c;endline=21;md5=1c2e3f55b215635eff4ba76f7696f8ee"
14
15do_configure_prepend () {
16 # It used 8 spaces to instead of a tab, but it doesn't work for us
17 sed -i 's/^ $(MAKE) dist distdir=/\t$(MAKE) dist distdir/' Makefile.am
18}
diff --git a/meta-gnome/recipes-gnome/pimlico/contacts_git.bb b/meta-gnome/recipes-gnome/pimlico/contacts_git.bb
new file mode 100644
index 000000000..8a4a07166
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/contacts_git.bb
@@ -0,0 +1,19 @@
1require contacts.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
4 file://src/contacts-main.h;endline=20;md5=9dc3531c914fb6d6d4a8d1aee4519fef \
5 file://src/contacts-dbus.c;endline=20;md5=95e02d77f155fbd07a14dba3348b9b03 \
6 file://src/contacts-gtk.c;endline=23;md5=e1ee9b9e72045f2d3aa44cf17313b46e"
7
8SRCREV = "19853893fdb595de6aa59db0d9dc2f9451ed2933"
9PV = "0.12+git${SRCPV}"
10PR = "r4"
11
12S = "${WORKDIR}/git"
13
14SRC_URI =+ "git://git.gnome.org/${BPN} \
15 file://make-382.patch"
16
17S = "${WORKDIR}/git"
18
19
diff --git a/meta-gnome/recipes-gnome/pimlico/dates.inc b/meta-gnome/recipes-gnome/pimlico/dates.inc
new file mode 100644
index 000000000..12d2f83f9
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/dates.inc
@@ -0,0 +1,11 @@
1DESCRIPTION = "Dates is a calendar application."
2HOMEPAGE = "http://pimlico-project.org/dates.html"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+"
6
7SECTION = "x11"
8DEPENDS = "glib-2.0 gtk+ libglade evolution-data-server intltool-native"
9RDEPENDS_${PN} = "libedata-cal"
10
11inherit autotools gettext pkgconfig gtk-icon-cache
diff --git a/meta-gnome/recipes-gnome/pimlico/dates/0001-Update-to-new-evolution-data-server-e_source_-color-.patch b/meta-gnome/recipes-gnome/pimlico/dates/0001-Update-to-new-evolution-data-server-e_source_-color-.patch
new file mode 100644
index 000000000..4550d298d
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/dates/0001-Update-to-new-evolution-data-server-e_source_-color-.patch
@@ -0,0 +1,72 @@
1From a8ddfc4b91f2ab3d955fe528ddb98ce2c5545795 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sun, 4 Aug 2013 13:44:50 +0200
4Subject: [PATCH] Update to new evolution-data-server e_source_*color APIs
5
6Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
7---
8 src/dates_gtk.c | 6 +++---
9 src/dates_main.c | 2 +-
10 src/dates_view.c | 6 +++++-
11 3 files changed, 9 insertions(+), 5 deletions(-)
12
13diff --git a/src/dates_gtk.c b/src/dates_gtk.c
14index 78e71bb..ac539d2 100644
15--- a/src/dates_gtk.c
16+++ b/src/dates_gtk.c
17@@ -1072,7 +1072,7 @@ calendar_do_new_dialog (GtkWindow *parent, DatesData *d)
18 #endif
19
20 /* Set the colour */
21- e_source_set_color (source, new_colour);
22+ e_source_set_color_spec (source, new_colour);
23
24 /* Set the group for the source */
25 e_source_set_group (source, group);
26@@ -1335,7 +1335,7 @@ calendar_do_edit_dialog (GtkWindow *parent, ESource *source, DatesData *d)
27 gtk_misc_set_alignment (GTK_MISC (label), 0, 0.5);
28
29 /* Get the colour from the the source */
30- e_source_get_color (source, &raw_colour);
31+ raw_colour = e_source_peek_color_spec (source);
32
33 /* Munge this into something usable */
34 colour.red = (guint16)(((raw_colour & 0xff0000) >> 16) << 8);
35@@ -1459,7 +1459,7 @@ calendar_do_edit_dialog (GtkWindow *parent, ESource *source, DatesData *d)
36 new_colour <<= 8;
37 #endif
38 /* Update the colour */
39- e_source_set_color (source, new_colour);
40+ e_source_set_color_spec (source, new_colour);
41
42 /* And the name */
43 e_source_set_name (source, (gtk_entry_get_text (GTK_ENTRY (name_entry))));
44diff --git a/src/dates_main.c b/src/dates_main.c
45index ce05fe8..7273c63 100644
46--- a/src/dates_main.c
47+++ b/src/dates_main.c
48@@ -112,7 +112,7 @@ dates_load_calendars (DatesData *d)
49 system_source = e_source_new (_("Personal"), "system");
50
51 /* Default Evolution colour */
52- e_source_set_color (system_source, 0xBECEDD);
53+ e_source_set_color_spec (system_source, 0xBECEDD);
54
55 /* Set the group for the source and put it in the group */
56 e_source_set_group (system_source, local_group);
57diff --git a/src/dates_view.c b/src/dates_view.c
58index d65db2f..f8efb9c 100644
59--- a/src/dates_view.c
60+++ b/src/dates_view.c
61@@ -4876,7 +4880,7 @@ dates_view_add_calendar (DatesView *view, ECal *ecal)
62 cal->text_gc = gdk_gc_new (
63 GDK_DRAWABLE (priv->main->window));
64
65- if (e_source_get_color (source, &colour)) {
66+ if (colour = e_source_peek_color_spec (source)) {
67 GdkColor gcolour, dgcolour, tgcolour;
68 gcolour.red = ((colour & 0xFF0000) >> 16) * 0x101;
69 gcolour.green = ((colour & 0xFF00) >> 8) * 0x101;
70--
711.8.3.2
72
diff --git a/meta-gnome/recipes-gnome/pimlico/dates/dso_linking_change_build_fix.patch b/meta-gnome/recipes-gnome/pimlico/dates/dso_linking_change_build_fix.patch
new file mode 100644
index 000000000..649d59d91
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/dates/dso_linking_change_build_fix.patch
@@ -0,0 +1,44 @@
1after gcc linking has changed, all the libraries must be explicitely specified
2This patch avoids these linking errors:
3
4
5| make[2]: Entering directory `/disk0/pokybuild/build1/tmp/work/i586-poky-linux/dates-0.4.11+git0+514185dc1f6588085fda41eb59898b93d0487dd4-r2/git/src'^M
6...
7| /disk0/pokybuild/build1/tmp/sysroots/x86_64-linux/usr/libexec/i586-poky-linux/gcc/i586-poky-linux/4.5.1/ld: e: invalid DSO for symbol `pow@@GLIBC_2.0' definition^M
8| /disk0/pokybuild/build1/tmp/sysroots/i586-poky-linux/usr/lib/libm.so: could not read symbols: Bad value^M
9| collect2: ld returned 1 exit status^M
10| make[2]: *** [dates] Error 1
11
12
13
14| /disk0/pokybuild/build1/tmp/sysroots/x86_64-linux/usr/libexec/i586-poky-linux/gcc/i586-poky-linux/4.5.1/ld: z: invalid DSO for symbol `pango_layout_get_extents' definition
15| /disk0/pokybuild/build1/tmp/sysroots/i586-poky-linux/usr/lib/libpango-1.0.so: could not read symbols: Bad value
16| collect2: ld returned 1 exit status
17| make[2]: *** [dates] Error 1
18
19
20Nitin A Kamble <nitin.a.kamble@intel.com>
21Date: 2011/01/11
22
23Update:
24This is identified as a libtool issue. While creating the libgtkdatesview.la
25file, libtool should have added these needed libraries in there.
26 A bug has been created for this issue:
27 http://bugzilla.pokylinux.org/show_bug.cgi?id=664
28Nitin A Kamble <nitin.a.kamble@intel.com>
29Date: 2011/01/19
30
31Upstream-Status: Pending
32
33Index: git/src/Makefile.am
34===================================================================
35--- git.orig/src/Makefile.am
36+++ git/src/Makefile.am
37@@ -34,6 +34,6 @@ dates_SOURCES = $(platform) \
38 gconf-bridge.h \
39 gconf-bridge.c
40
41-dates_LDADD = $(DATES_LIBS) $(OWL_LIBS) libgtkdatesview.la
42+dates_LDADD = $(DATES_LIBS) $(OWL_LIBS) libgtkdatesview.la -lm -lpango-1.0
43
44 MAINTAINERCLEANFILES = config.h.in Makefile.in
diff --git a/meta-gnome/recipes-gnome/pimlico/dates/make-382.patch b/meta-gnome/recipes-gnome/pimlico/dates/make-382.patch
new file mode 100644
index 000000000..fad3c5826
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/dates/make-382.patch
@@ -0,0 +1,18 @@
1Make 3.82 is offended by the use of spaces instead of tabs. This has been fixed
2in upstream git.
3
4JL - 15/12/10
5
6Upstream-Status: Accepted
7
8Index: git/Makefile.am
9===================================================================
10--- git.orig/Makefile.am
11+++ git/Makefile.am
12@@ -7,5 +7,5 @@ DISTCLEANFILES = intltool-extract intlto
13 MAINTAINERCLEANFILES = $(DISTCLEANFILES) aclocal.m4 compile config.guess config.sub configure depcomp install-sh ltmain.sh Makefile.in missing
14
15 snapshot:
16- $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
17+ $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
18
diff --git a/meta-gnome/recipes-gnome/pimlico/dates/uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch b/meta-gnome/recipes-gnome/pimlico/dates/uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch
new file mode 100644
index 000000000..6ade4708f
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/dates/uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch
@@ -0,0 +1,37 @@
1uclibc has langinfo.h but it does not define _NL_TIME_FIRST_WEEKDAY
2therefore we introduce a check in configure for the this define
3and then we make sure that we use it when it really exists
4
5Signed-off-by: Khem Raj <raj.khem@gmail.com>
6
7Upstream-Status: Pending
8
9Index: git/configure.ac
10===================================================================
11--- git.orig/configure.ac 2011-07-18 10:34:15.000000000 -0700
12+++ git/configure.ac 2011-07-18 10:54:26.403798188 -0700
13@@ -98,6 +98,8 @@
14 src/libgtkdatesview.pc
15 ])
16
17+AC_CHECK_DECLS([_NL_TIME_FIRST_WEEKDAY],[],[],[[#include <langinfo.h>]])
18+
19 AC_OUTPUT
20
21 echo " "
22Index: git/src/dates_view.c
23===================================================================
24--- git.orig/src/dates_view.c 2011-07-18 10:34:15.000000000 -0700
25+++ git/src/dates_view.c 2011-07-18 10:58:46.093798136 -0700
26@@ -1505,7 +1505,11 @@
27 priv->days = 1;
28 priv->months = 0;
29 priv->months_in_row = 4;
30+#if HAVE_DECL__NL_TIME_FIRST_WEEKDAY
31 priv->week_start = *nl_langinfo (_NL_TIME_FIRST_WEEKDAY) - 1;
32+#else
33+ priv->week_start = 0;
34+#endif
35 priv->dragbox = TRUE;
36 priv->single_click = TRUE;
37 priv->double_click = FALSE;
diff --git a/meta-gnome/recipes-gnome/pimlico/dates_git.bb b/meta-gnome/recipes-gnome/pimlico/dates_git.bb
new file mode 100644
index 000000000..a4a572f85
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/dates_git.bb
@@ -0,0 +1,19 @@
1require dates.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
4 file://src/dates_view.h;endline=22;md5=29f934f356eb970309cdeb6693b3123a \
5 file://src/dates_hildon.c;endline=19;md5=63938904198b25de429abb65fbdbdb8a \
6 file://src/gconf-bridge.c;endline=22;md5=ad7626c6daf4aec590474a243f4912fa"
7
8SRCREV = "514185dc1f6588085fda41eb59898b93d0487dd4"
9PV = "0.4.11+git${SRCPV}"
10PR = "r9"
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://git.gnome.org/${BPN} \
15 file://make-382.patch \
16 file://dso_linking_change_build_fix.patch \
17 file://uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch \
18 file://0001-Update-to-new-evolution-data-server-e_source_-color-.patch \
19"
diff --git a/meta-gnome/recipes-gnome/pimlico/tasks.inc b/meta-gnome/recipes-gnome/pimlico/tasks.inc
new file mode 100644
index 000000000..f8217dc3a
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/tasks.inc
@@ -0,0 +1,10 @@
1DESCRIPTION = "Task list application"
2HOMEPAGE = "http://pimlico-project.org/tasks.html"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "GPLv2 & GPLv2+"
6
7SECTION = "x11"
8DEPENDS = "glib-2.0 gtk+ evolution-data-server intltool-native"
9
10inherit autotools pkgconfig gtk-icon-cache
diff --git a/meta-gnome/recipes-gnome/pimlico/tasks_0.19.bb b/meta-gnome/recipes-gnome/pimlico/tasks_0.19.bb
new file mode 100644
index 000000000..992596eaf
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/tasks_0.19.bb
@@ -0,0 +1,13 @@
1require tasks.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
4 file://src/gtk/main.c;endline=19;md5=8659d0b7fd68a2ad6ac30c6539ea5b82 \
5 file://src/omoko/openmoko-tasks.c;endline=20;md5=04d56a46863c9f4247694f40257a836a \
6 file://src/hildon/hildon-tasks.c;endline=21;md5=488ddf31dc14b2196dec7cc736211b52"
7
8SRC_URI = "http://pimlico-project.org/sources/${BPN}/${BPN}-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "0afd969758561599fd782e1effb39c08"
11SRC_URI[sha256sum] = "1a7fdc5f95a2193a1a25fdb13f071867fb7e42245ce19ccee4bcccb69e557f2e"
12
13PR = "r3"
diff --git a/meta-gnome/recipes-gnome/pimlico/tasks_git.bb b/meta-gnome/recipes-gnome/pimlico/tasks_git.bb
new file mode 100644
index 000000000..6a06da336
--- /dev/null
+++ b/meta-gnome/recipes-gnome/pimlico/tasks_git.bb
@@ -0,0 +1,9 @@
1require tasks.inc
2
3SRC_URI = "git://git.gnome.org/${BPN}"
4
5SRCREV = "ea52d46d691c5fce4473ea4e24a35411381f3a65"
6PV = "0.13+git${SRCPV}"
7PR = "r3"
8
9S = "${WORKDIR}/git"