summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/pimlico/contacts
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-08-30 10:10:55 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-24 19:34:31 +0200
commit55855cd569fbff7182974ca08b1de8435bf0f597 (patch)
tree9f7518e2e48367fcbd15a7c58101dd601940331f /meta-gnome/recipes-gnome/pimlico/contacts
parente0fe08a35ae6e1a4458c13daa13167c9a1e74bde (diff)
downloadmeta-openembedded-55855cd569fbff7182974ca08b1de8435bf0f597.tar.gz
pimlico: remove Poky overrides
There was a poky distro override to enable the "owl" window menu functionality. As these packages are in meta-oe now and only Sato/poky supported owl, remove the override and patches. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/pimlico/contacts')
-rw-r--r--meta-gnome/recipes-gnome/pimlico/contacts/contacts-owl-window-menu.patch54
1 files changed, 0 insertions, 54 deletions
diff --git a/meta-gnome/recipes-gnome/pimlico/contacts/contacts-owl-window-menu.patch b/meta-gnome/recipes-gnome/pimlico/contacts/contacts-owl-window-menu.patch
deleted file mode 100644
index 532387667..000000000
--- a/meta-gnome/recipes-gnome/pimlico/contacts/contacts-owl-window-menu.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1Upstream-Status: Inappropriate [enable feature]
2
3Index: contacts-0.9/src/contacts-gtk.c
4===================================================================
5--- contacts-0.9.orig/src/contacts-gtk.c 2008-06-06 12:56:08.000000000 +0100
6+++ contacts-0.9/src/contacts-gtk.c 2008-06-16 08:14:28.000000000 +0100
7@@ -220,8 +220,8 @@
8 vbox7 = gtk_vbox_new (FALSE, 0);
9 gtk_container_add (GTK_CONTAINER (main_window), vbox7);
10
11- main_menubar = gtk_menu_bar_new ();
12- gtk_box_pack_start (GTK_BOX (vbox7), main_menubar, FALSE, FALSE, 0);
13+ main_menubar = gtk_menu_new ();
14+ gtk_widget_show (main_menubar);
15
16 contacts_menu = gtk_menu_item_new_with_mnemonic (_("C_ontacts"));
17 gtk_container_add (GTK_CONTAINER (main_menubar), contacts_menu);
18Index: contacts-0.9/src/Makefile.am
19===================================================================
20--- contacts-0.9.orig/src/Makefile.am 2008-06-03 09:16:56.000000000 +0100
21+++ contacts-0.9/src/Makefile.am 2008-06-16 08:15:34.000000000 +0100
22@@ -40,7 +40,7 @@
23 contacts-@FRONTEND@.c \
24 contacts-@FRONTEND@.h
25
26-contacts_LDADD = $(CONTACTS_LIBS) $(DBUS_LIBS)
27+contacts_LDADD = $(CONTACTS_LIBS) $(DBUS_LIBS) -lowl
28
29 contacts_LDFLAGS = @CONTACTS_LIBS@ @DBUS_LIBS@
30
31Index: contacts-0.9/src/contacts-main.c
32===================================================================
33--- contacts-0.9.orig/src/contacts-main.c 2008-06-06 10:26:52.000000000 +0100
34+++ contacts-0.9/src/contacts-main.c 2008-06-16 08:14:28.000000000 +0100
35@@ -27,6 +27,8 @@
36 #include <libgnomevfs/gnome-vfs.h>
37 #endif
38
39+#include <libowl/owlwindowmenu.h>
40+
41 #include "bacon-message-connection.h"
42 #include "contacts-defs.h"
43 #include "contacts-utils.h"
44@@ -266,6 +268,10 @@
45 gtk_widget_show_all (widget);
46 }
47
48+ gtk_widget_show_all (data->ui->main_menubar);
49+ owl_set_window_menu (GTK_WINDOW (data->ui->main_window),
50+ GTK_MENU (data->ui->main_menubar));
51+
52 gtk_main ();
53
54 /* if we have modified the current contact, but not saved it, do so now */