summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/orbit2
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-09 17:17:57 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-09 17:21:09 +0200
commitc35f42970ffe9f49dd1480c8ab279d68e443d000 (patch)
tree09b379f84a3845bde50b3bf7f58ca2f5d68eaf01 /meta-gnome/recipes-gnome/orbit2
parented365c1c4d3f2f43ccc074b4c9440f0ddd145615 (diff)
downloadmeta-openembedded-c35f42970ffe9f49dd1480c8ab279d68e443d000.tar.gz
move various GNOME recipes to meta-gnome
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/orbit2')
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2-2.14.17/configure-lossage.patch37
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2-native_2.14.12.bb27
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2.inc32
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2/configure-lossage.patch35
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2/gtk-doc.m453
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2/gtk-doc.make173
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2/pkgconfig-fix.patch12
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb5
8 files changed, 374 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2-2.14.17/configure-lossage.patch b/meta-gnome/recipes-gnome/orbit2/orbit2-2.14.17/configure-lossage.patch
new file mode 100644
index 000000000..5fc1de561
--- /dev/null
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2-2.14.17/configure-lossage.patch
@@ -0,0 +1,37 @@
1--- ORBit2-2.14.17/configure.in-orig 2009-01-10 09:36:18.000000000 -0800
2+++ ORBit2-2.14.17/configure.in 2009-06-17 15:10:59.000000000 -0700
3@@ -217,20 +217,20 @@ dnl
4 dnl So many people with broken linking setups asked about this
5 dnl it turned out to be necessary to check for this.
6 dnl
7-dofus_save_libs="$LIBS"
8-LIBS="$ORBIT_LIBS $LIBS"
9-AC_TRY_RUN([ #include <stdio.h>
10- main ()
11- {
12- return 0;
13- } ],,
14- AC_MSG_ERROR([
15-Linking is badly borked on your system. Please ensure your library path is correct
16-Check config.log for details - check near the end of the log above 'failed program was'
17-Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
18-prefix you're compiling on: '${prefix}' ]),
19-AC_MSG_WARN([Could not check for borked linking while cross-compiling]))
20-LIBS="$dofus_save_libs"
21+dnl dofus_save_libs="$LIBS"
22+dnl LIBS="$ORBIT_LIBS $LIBS"
23+dnl AC_TRY_RUN([ #include <stdio.h>
24+dnl main ()
25+dnl {
26+dnl return 0;
27+dnl } ],,
28+dnl AC_MSG_ERROR([
29+dnl Linking is badly borked on your system. Please ensure your library path is correct
30+dnl Check config.log for details - check near the end of the log above 'failed program was'
31+dnl Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
32+dnl prefix you're compiling on: '${prefix}' ]),
33+dnl AC_MSG_WARN([Could not check for borked linking while cross-compiling]))
34+dnl LIBS="$dofus_save_libs"
35
36 orig_CPPFLAGS=$CPPFLAGS
37 CPPFLAGS="$CPPFLAGS $ORBIT_CFLAGS"
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2-native_2.14.12.bb b/meta-gnome/recipes-gnome/orbit2/orbit2-native_2.14.12.bb
new file mode 100644
index 000000000..1db2496c3
--- /dev/null
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2-native_2.14.12.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "CORBA ORB"
2PR = "r0"
3LICENSE = "LGPL GPL"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5SECTION = "x11/gnome/libs"
6SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-${PV}.tar.bz2 \
7 file://configure-lossage.patch \
8 file://gtk-doc.m4 \
9 file://gtk-doc.make"
10DEPENDS = "libidl-native popt-native gtk-doc"
11
12S = "${WORKDIR}/ORBit2-${PV}"
13FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/orbit2"
14
15PARALLEL_MAKE = ""
16inherit autotools native pkgconfig
17
18EXTRA_OECONF = "--disable-gtk-doc"
19
20do_configure_prepend() {
21 mkdir -p m4
22 install ${WORKDIR}/gtk-doc.m4 ./m4/
23 install ${WORKDIR}/gtk-doc.make ./
24}
25
26SRC_URI[md5sum] = "6f4bf7d803d442e9d093a0daa203d506"
27SRC_URI[sha256sum] = "d60027a4a36e64d02723d00b76c08e8d92850cab6269b2edcda4a1bb30cc7723"
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2.inc b/meta-gnome/recipes-gnome/orbit2/orbit2.inc
new file mode 100644
index 000000000..51978909b
--- /dev/null
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2.inc
@@ -0,0 +1,32 @@
1LICENSE = "GPL"
2DESCRIPTION = "CORBA ORB"
3SECTION = "x11/gnome/libs"
4SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-${PV}.tar.bz2 \
5 file://configure-lossage.patch \
6 file://pkgconfig-fix.patch \
7 file://gtk-doc.m4 \
8 file://gtk-doc.make"
9DEPENDS = "libidl popt orbit2-native gtk-doc"
10PARALLEL_MAKE = ""
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
13
14FILES_${PN} += "${libdir}/orbit-2.0/*.so"
15FILES_${PN}-dev += "${libdir}/orbit-2.0/*.a ${libdir}/orbit-2.0/*.la"
16FILES_${PN}-dbg += "${libdir}/orbit-2.0/.debug"
17
18S = "${WORKDIR}/ORBit2-${PV}"
19
20LEAD_SONAME = "libORBit-2.so"
21
22inherit autotools pkgconfig
23
24EXTRA_OECONF = "--disable-gtk-doc"
25EXTRA_OEMAKE = "IDL_COMPILER='${STAGING_BINDIR_NATIVE}/orbit-idl-2'"
26
27do_configure_prepend() {
28 mkdir -p m4
29 install ${WORKDIR}/gtk-doc.m4 ./m4/
30 install ${WORKDIR}/gtk-doc.make ./
31}
32
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2/configure-lossage.patch b/meta-gnome/recipes-gnome/orbit2/orbit2/configure-lossage.patch
new file mode 100644
index 000000000..7485a0ce0
--- /dev/null
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2/configure-lossage.patch
@@ -0,0 +1,35 @@
1--- orbit/configure.in~ 2004-05-07 09:31:32.000000000 +0100
2+++ orbit/configure.in 2004-05-08 19:27:35.000000000 +0100
3@@ -193,19 +193,19 @@
4 dnl So many people with broken linking setups asked about this
5 dnl it turned out to be necessary to check for this.
6 dnl
7-dofus_save_libs="$LIBS"
8-LIBS="$ORBIT_LIBS $LIBS"
9-AC_TRY_RUN([ #include <stdio.h>
10- main ()
11- {
12- return 0;
13- } ],,
14- AC_MSG_ERROR([
15-Linking is badly borked on your system. Please ensure your library path is correct
16-Check config.log for details - check near the end of the log above 'failed program was'
17-Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
18-prefix you're compiling on: '${prefix}' ]))
19-LIBS="$dofus_save_libs"
20+dnl dofus_save_libs="$LIBS"
21+dnl LIBS="$ORBIT_LIBS $LIBS"
22+dnl AC_TRY_RUN([ #include <stdio.h>
23+dnl main ()
24+dnl {
25+dnl return 0;
26+dnl } ],,
27+dnl AC_MSG_ERROR([
28+dnl Linking is badly borked on your system. Please ensure your library path is correct
29+dnl Check config.log for details - check near the end of the log above 'failed program was'
30+dnl Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
31+dnl prefix you're compiling on: '${prefix}' ]))
32+dnl LIBS="$dofus_save_libs"
33
34 orig_CPPFLAGS=$CPPFLAGS
35 CPPFLAGS="$CPPFLAGS $ORBIT_CFLAGS"
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2/gtk-doc.m4 b/meta-gnome/recipes-gnome/orbit2/orbit2/gtk-doc.m4
new file mode 100644
index 000000000..3ec41666b
--- /dev/null
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2/gtk-doc.m4
@@ -0,0 +1,53 @@
1dnl -*- mode: autoconf -*-
2
3# serial 1
4
5dnl Usage:
6dnl GTK_DOC_CHECK([minimum-gtk-doc-version])
7AC_DEFUN([GTK_DOC_CHECK],
8[
9 AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first
10 AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first
11 dnl for overriding the documentation installation directory
12 AC_ARG_WITH(html-dir,
13 AC_HELP_STRING([--with-html-dir=PATH], [path to installed docs]),,
14 [with_html_dir='${datadir}/gtk-doc/html'])
15 HTML_DIR="$with_html_dir"
16 AC_SUBST(HTML_DIR)
17
18 dnl enable/disable documentation building
19 AC_ARG_ENABLE(gtk-doc,
20 AC_HELP_STRING([--enable-gtk-doc],
21 [use gtk-doc to build documentation [default=no]]),,
22 enable_gtk_doc=no)
23
24 have_gtk_doc=no
25 if test -z "$PKG_CONFIG"; then
26 AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
27 fi
28 if test "$PKG_CONFIG" != "no" && $PKG_CONFIG --exists gtk-doc; then
29 have_gtk_doc=yes
30 fi
31
32 dnl do we want to do a version check?
33ifelse([$1],[],,
34 [gtk_doc_min_version=$1
35 if test "$have_gtk_doc" = yes; then
36 AC_MSG_CHECKING([gtk-doc version >= $gtk_doc_min_version])
37 if $PKG_CONFIG --atleast-version $gtk_doc_min_version gtk-doc; then
38 AC_MSG_RESULT(yes)
39 else
40 AC_MSG_RESULT(no)
41 have_gtk_doc=no
42 fi
43 fi
44])
45 if test x$enable_gtk_doc = xyes; then
46 if test "$have_gtk_doc" != yes; then
47 enable_gtk_doc=no
48 fi
49 fi
50
51 AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
52 AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test -n "$LIBTOOL")
53])
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2/gtk-doc.make b/meta-gnome/recipes-gnome/orbit2/orbit2/gtk-doc.make
new file mode 100644
index 000000000..354ffb7c6
--- /dev/null
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2/gtk-doc.make
@@ -0,0 +1,173 @@
1# -*- mode: makefile -*-
2
3####################################
4# Everything below here is generic #
5####################################
6
7if GTK_DOC_USE_LIBTOOL
8GTKDOC_CC = $(LIBTOOL) --mode=compile $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
9GTKDOC_LD = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
10else
11GTKDOC_CC = $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
12GTKDOC_LD = $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
13endif
14
15# We set GPATH here; this gives us semantics for GNU make
16# which are more like other make's VPATH, when it comes to
17# whether a source that is a target of one rule is then
18# searched for in VPATH/GPATH.
19#
20GPATH = $(srcdir)
21
22TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
23
24EXTRA_DIST = \
25 $(content_files) \
26 $(HTML_IMAGES) \
27 $(DOC_MAIN_SGML_FILE) \
28 $(DOC_MODULE)-sections.txt \
29 $(DOC_MODULE)-overrides.txt
30
31DOC_STAMPS=scan-build.stamp tmpl-build.stamp sgml-build.stamp html-build.stamp \
32 $(srcdir)/tmpl.stamp $(srcdir)/sgml.stamp $(srcdir)/html.stamp
33
34SCANOBJ_FILES = \
35 $(DOC_MODULE).args \
36 $(DOC_MODULE).hierarchy \
37 $(DOC_MODULE).interfaces \
38 $(DOC_MODULE).prerequisites \
39 $(DOC_MODULE).signals
40
41REPORT_FILES = \
42 $(DOC_MODULE)-undocumented.txt \
43 $(DOC_MODULE)-undeclared.txt \
44 $(DOC_MODULE)-unused.txt
45
46CLEANFILES = $(SCANOBJ_FILES) $(REPORT_FILES) $(DOC_STAMPS)
47
48if ENABLE_GTK_DOC
49all-local: html-build.stamp
50else
51all-local:
52endif
53
54docs: html-build.stamp
55
56#### scan ####
57
58scan-build.stamp: $(HFILE_GLOB) $(CFILE_GLOB)
59 @echo 'gtk-doc: Scanning header files'
60 @-chmod -R u+w $(srcdir)
61 cd $(srcdir) && \
62 gtkdoc-scan --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --ignore-headers="$(IGNORE_HFILES)" $(SCAN_OPTIONS) $(EXTRA_HFILES)
63 if grep -l '^..*$$' $(srcdir)/$(DOC_MODULE).types > /dev/null 2>&1 ; then \
64 CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" CFLAGS="$(GTKDOC_CFLAGS)" LDFLAGS="$(GTKDOC_LIBS)" gtkdoc-scangobj $(SCANGOBJ_OPTIONS) --module=$(DOC_MODULE) --output-dir=$(srcdir) ; \
65 else \
66 cd $(srcdir) ; \
67 for i in $(SCANOBJ_FILES) ; do \
68 test -f $$i || touch $$i ; \
69 done \
70 fi
71 touch scan-build.stamp
72
73$(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt: scan-build.stamp
74 @true
75
76#### templates ####
77
78tmpl-build.stamp: $(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt
79 @echo 'gtk-doc: Rebuilding template files'
80 @-chmod -R u+w $(srcdir)
81 cd $(srcdir) && gtkdoc-mktmpl --module=$(DOC_MODULE) $(MKTMPL_OPTIONS)
82 touch tmpl-build.stamp
83
84tmpl.stamp: tmpl-build.stamp
85 @true
86
87tmpl/*.sgml:
88 @true
89
90
91#### xml ####
92
93sgml-build.stamp: tmpl.stamp $(HFILE_GLOB) $(CFILE_GLOB) $(DOC_MODULE)-sections.txt $(srcdir)/tmpl/*.sgml $(expand_content_files)
94 @echo 'gtk-doc: Building XML'
95 @-chmod -R u+w $(srcdir)
96 cd $(srcdir) && \
97 gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --output-format=xml --expand-content-files="$(expand_content_files)" --main-sgml-file=$(DOC_MAIN_SGML_FILE) $(MKDB_OPTIONS)
98 touch sgml-build.stamp
99
100sgml.stamp: sgml-build.stamp
101 @true
102
103#### html ####
104
105html-build.stamp: sgml.stamp $(DOC_MAIN_SGML_FILE) $(content_files)
106 @echo 'gtk-doc: Building HTML'
107 @-chmod -R u+w $(srcdir)
108 rm -rf $(srcdir)/html
109 mkdir $(srcdir)/html
110 cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
111 test "x$(HTML_IMAGES)" = "x" || ( cd $(srcdir) && cp $(HTML_IMAGES) html )
112 @echo 'gtk-doc: Fixing cross-references'
113 cd $(srcdir) && gtkdoc-fixxref --module-dir=html --html-dir=$(HTML_DIR) $(FIXXREF_OPTIONS)
114 touch html-build.stamp
115
116##############
117
118clean-local:
119 rm -f *~ *.bak
120 rm -rf .libs
121
122distclean-local:
123 cd $(srcdir) && \
124 rm -rf xml $(REPORT_FILES) \
125 $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
126
127maintainer-clean-local: clean
128 cd $(srcdir) && rm -rf xml html
129
130install-data-local:
131 -installfiles=`echo $(srcdir)/html/*`; \
132 if test "$$installfiles" = '$(srcdir)/html/*'; \
133 then echo '-- Nothing to install' ; \
134 else \
135 $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR); \
136 for i in $$installfiles; do \
137 echo '-- Installing '$$i ; \
138 $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
139 done; \
140 echo '-- Installing $(srcdir)/html/index.sgml' ; \
141 $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \
142 which gtkdoc-rebase >/dev/null && \
143 gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
144 fi
145
146
147uninstall-local:
148 rm -f $(DESTDIR)$(TARGET_DIR)/*
149
150#
151# Require gtk-doc when making dist
152#
153if ENABLE_GTK_DOC
154dist-check-gtkdoc:
155else
156dist-check-gtkdoc:
157 @echo "*** gtk-doc must be installed and enabled in order to make dist"
158 @false
159endif
160
161dist-hook: dist-check-gtkdoc dist-hook-local
162 mkdir $(distdir)/tmpl
163 mkdir $(distdir)/xml
164 mkdir $(distdir)/html
165 -cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
166 -cp $(srcdir)/xml/*.xml $(distdir)/xml
167 cp $(srcdir)/html/* $(distdir)/html
168 -cp $(srcdir)/$(DOC_MODULE).types $(distdir)/
169 -cp $(srcdir)/$(DOC_MODULE)-sections.txt $(distdir)/
170 cd $(distdir) && rm -f $(DISTCLEANFILES)
171 -gtkdoc-rebase --online --relative --html-dir=$(distdir)/html
172
173.PHONY : dist-hook-local docs
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2/pkgconfig-fix.patch b/meta-gnome/recipes-gnome/orbit2/orbit2/pkgconfig-fix.patch
new file mode 100644
index 000000000..f629e506d
--- /dev/null
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2/pkgconfig-fix.patch
@@ -0,0 +1,12 @@
1diff -urN ORBit2-2.14.12.orig/ORBit-2.0.pc.in ORBit2-2.14.12/ORBit-2.0.pc.in
2--- ORBit2-2.14.12.orig/ORBit-2.0.pc.in 2008-01-29 13:45:22.000000000 +0100
3+++ ORBit2-2.14.12/ORBit-2.0.pc.in 2008-09-23 20:13:07.000000000 +0200
4@@ -2,7 +2,7 @@
5 exec_prefix=@exec_prefix@
6 libdir=@libdir@
7 includedir=@includedir@
8-orbit_idl=@bindir@/orbit-idl-2@EXEEXT@
9+orbit_idl=@exec_prefix@/bin/orbit-idl-2@EXEEXT@
10
11
12 Name: ORBit-2.0
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb b/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb
new file mode 100644
index 000000000..47f632793
--- /dev/null
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb
@@ -0,0 +1,5 @@
1require orbit2.inc
2
3
4SRC_URI[md5sum] = "10bfb957fa4a8935a0b4afaee7d71df7"
5SRC_URI[sha256sum] = "62bfce3f678f9347a19c766944e8aef7b89bc32b25ac23eb3e4c25929ce8974c"