diff options
author | Andreas Müller <schnitzeltony@gmx.de> | 2011-10-17 07:51:07 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-10-17 08:58:21 +0200 |
commit | 38c82da4196c82af45e1538d005d703403e37ff4 (patch) | |
tree | 7004cbe4c62e9b315576efff85b10c8907944ee1 /meta-gnome/recipes-gnome/nautilus | |
parent | ce4f274e3d7d8078539aa05e21011410c4e18d7a (diff) | |
download | meta-openembedded-38c82da4196c82af45e1538d005d703403e37ff4.tar.gz |
nautilus: fix compile errors by removing G_DISABLE_DEPRECATED
* build tested
* reported gnome-bugzills [1]
* error messages:
| In file included from eel-alert-dialog.c:24:0:
| eel-i18n.h:31:16: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'char'
| eel-alert-dialog.c: In function 'eel_alert_dialog_class_init':
| eel-alert-dialog.c:114:43: warning: passing argument 2 of 'g_param_spec_int' makes pointer from integer without a cast
| /home/Superandy/tmp/oe-core-eglibc/sysroots/overo/usr/include/glib-2.0/gobject/gparamspecs.h:993:13: note: expected 'const gchar *' but argument is of type 'int'
| eel-alert-dialog.c:114:43: warning: passing argument 3 of 'g_param_spec_int' makes pointer from integer without a cast
| /home/Superandy/tmp/oe-core-eglibc/sysroots/overo/usr/include/glib-2.0/gobject/gparamspecs.h:993:13: note: expected 'const gchar *' but argument is of type 'int'
| eel-alert-dialog.c:123:35: warning: passing argument 2 of 'g_param_spec_enum' makes pointer from integer without a cast
| /home/Superandy/tmp/oe-core-eglibc/sysroots/overo/usr/include/glib-2.0/gobject/gparamspecs.h:1040:13: note: expected 'const gchar *' but argument is of type 'int'
| eel-alert-dialog.c:123:35: warning: passing argument 3 of 'g_param_spec_enum' makes pointer from integer without a cast
| /home/Superandy/tmp/oe-core-eglibc/sysroots/overo/usr/include/glib-2.0/gobject/gparamspecs.h:1040:13: note: expected 'const gchar *' but argument is of type 'int'
| eel-alert-dialog.c:132:35: warning: passing argument 2 of 'g_param_spec_enum' makes pointer from integer without a cast
| /home/Superandy/tmp/oe-core-eglibc/sysroots/overo/usr/include/glib-2.0/gobject/gparamspecs.h:1040:13: note: expected 'const gchar *' but argument is of type 'int'
| eel-alert-dialog.c:132:35: warning: passing argument 3 of 'g_param_spec_enum' makes pointer from integer without a cast
| /home/Superandy/tmp/oe-core-eglibc/sysroots/overo/usr/include/glib-2.0/gobject/gparamspecs.h:1040:13: note: expected 'const gchar *' but argument is of type 'int'
| eel-alert-dialog.c: In function 'eel_alert_dialog_init':
| eel-alert-dialog.c:193:2: warning: passing argument 1 of 'gtk_expander_new_with_mnemonic' makes pointer from integer without a cast
| /home/Superandy/tmp/oe-core-eglibc/sysroots/overo/usr/include/gtk-2.0/gtk/gtkexpander.h:66:12: note: expected 'const gchar *' but argument is of type 'int'
and
| In file included from nautilus-file.h:31:0,
| from nautilus-bookmark.c:28:
| ../libnautilus-private/nautilus-icon-info.h:75:16: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'char'
| ../libnautilus-private/nautilus-icon-info.h:76:16: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'char'
| make[2]: *** [nautilus-bookmark.lo] Error 1
[1] https://bugzilla.gnome.org/show_bug.cgi?id=661949
Signed-off-by: Andreas Müller <schnitzeltony@gmx.de>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/nautilus')
-rw-r--r-- | meta-gnome/recipes-gnome/nautilus/nautilus/no-G_DISABLE_DEPRECATED.patch | 44 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb | 3 |
2 files changed, 46 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus/no-G_DISABLE_DEPRECATED.patch b/meta-gnome/recipes-gnome/nautilus/nautilus/no-G_DISABLE_DEPRECATED.patch new file mode 100644 index 000000000..43a6152d8 --- /dev/null +++ b/meta-gnome/recipes-gnome/nautilus/nautilus/no-G_DISABLE_DEPRECATED.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From e7233d98c114b03c7c8b96d1f41770452da14aa7 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmx.de> | ||
3 | Date: Mon, 17 Oct 2011 00:59:01 +0200 | ||
4 | Subject: [PATCH] nautilus build fails for newer glib versions | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | build with glib-2.0 v2.30.0 run into errors for at least G_CONST_RETURN missing | ||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@gmx.de> | ||
12 | --- | ||
13 | configure.in | 2 +- | ||
14 | eel/Makefile.am | 1 - | ||
15 | 2 files changed, 1 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/configure.in b/configure.in | ||
18 | index 97e171e..859a097 100644 | ||
19 | --- a/configure.in | ||
20 | +++ b/configure.in | ||
21 | @@ -342,7 +342,7 @@ AC_SUBST(CORE_CFLAGS) | ||
22 | CORE_LIBS="`$PKG_CONFIG --libs $CORE_MODULES` $x_libs" | ||
23 | AC_SUBST(CORE_LIBS) | ||
24 | |||
25 | -DISABLE_DEPRECATED_CFLAGS="-DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED" | ||
26 | +DISABLE_DEPRECATED_CFLAGS="-DGDK_PIXBUF_DISABLE_DEPRECATED" | ||
27 | AC_SUBST(DISABLE_DEPRECATED_CFLAGS) | ||
28 | |||
29 | dnl Multimedia keys | ||
30 | diff --git a/eel/Makefile.am b/eel/Makefile.am | ||
31 | index b1fe356..c1d56cd 100644 | ||
32 | --- a/eel/Makefile.am | ||
33 | +++ b/eel/Makefile.am | ||
34 | @@ -10,7 +10,6 @@ INCLUDES = \ | ||
35 | -DDATADIR=\""$(datadir)"\" \ | ||
36 | -DSOURCE_DATADIR=\""$(top_srcdir)/data"\" \ | ||
37 | -DGNOMELOCALEDIR=\""$(prefix)/${DATADIRNAME}/locale"\" \ | ||
38 | - -DG_DISABLE_DEPRECATED \ | ||
39 | -DGDK_PIXBUF_DISABLE_DEPRECATED \ | ||
40 | -DGMENU_I_KNOW_THIS_IS_UNSTABLE \ | ||
41 | $(NULL) | ||
42 | -- | ||
43 | 1.7.4.4 | ||
44 | |||
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb b/meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb index 334679ca5..f34cbbe1c 100644 --- a/meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb +++ b/meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb | |||
@@ -6,7 +6,7 @@ LICENSE="GPLv2 && LGPLv2" | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=7c0048536e43642a1f3a724c2909872b \ | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=7c0048536e43642a1f3a724c2909872b \ |
7 | file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a" | 7 | file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a" |
8 | 8 | ||
9 | PR = "r4" | 9 | PR = "r5" |
10 | 10 | ||
11 | DEPENDS = "libunique gvfs librsvg libexif esound gnome-desktop orbit2-native" | 11 | DEPENDS = "libunique gvfs librsvg libexif esound gnome-desktop orbit2-native" |
12 | # optional: tracker | 12 | # optional: tracker |
@@ -18,6 +18,7 @@ SRC_URI[archive.sha256sum] = "2d4ff28c7a7aa5d40eb2468149954a564c257a305183773057 | |||
18 | 18 | ||
19 | SRC_URI += "file://idl-sysroot.patch \ | 19 | SRC_URI += "file://idl-sysroot.patch \ |
20 | file://no-try-run-strftime.diff \ | 20 | file://no-try-run-strftime.diff \ |
21 | file://no-G_DISABLE_DEPRECATED.patch \ | ||
21 | " | 22 | " |
22 | 23 | ||
23 | 24 | ||