diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2013-04-29 14:22:37 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-03 13:32:04 +0200 |
commit | 68ce4c403611fbb89865e6dabaf56d1d0d39e97b (patch) | |
tree | 32d0b3d65e8d6a914d1bfe50f3e5dcea1d6b524b /meta-gnome/recipes-gnome/libgnome | |
parent | 376a5b381f597dd87eb20d685b0f0f26f6347135 (diff) | |
download | meta-openembedded-68ce4c403611fbb89865e6dabaf56d1d0d39e97b.tar.gz |
libgnome: fix compile
error message was:
| gnome-program.c: In function 'gnome_program_init_common':
| gnome-program.c:2067:2: error: implicit declaration of function 'g_atexit' [-Werror=implicit-function-declaration]
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/libgnome')
-rw-r--r-- | meta-gnome/recipes-gnome/libgnome/libgnome/0001-libgnome-Makefile.am-allow-deprecated-symbols.patch | 35 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb | 3 |
2 files changed, 37 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/libgnome/libgnome/0001-libgnome-Makefile.am-allow-deprecated-symbols.patch b/meta-gnome/recipes-gnome/libgnome/libgnome/0001-libgnome-Makefile.am-allow-deprecated-symbols.patch new file mode 100644 index 000000000..b6583034f --- /dev/null +++ b/meta-gnome/recipes-gnome/libgnome/libgnome/0001-libgnome-Makefile.am-allow-deprecated-symbols.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From ce1cd20fceea7dbcc5b983d94de771461eccf7cf Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Mon, 29 Apr 2013 14:17:13 +0200 | ||
4 | Subject: [PATCH] libgnome/Makefile.am: allow deprecated symbols | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | fixes: | ||
10 | |||
11 | | gnome-program.c: In function 'gnome_program_init_common': | ||
12 | | gnome-program.c:2067:2: error: implicit declaration of function 'g_atexit' [-Werror=implicit-function-declaration] | ||
13 | |||
14 | Upstream-Status: Inappropriate [configuration] | ||
15 | |||
16 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
17 | --- | ||
18 | libgnome/Makefile.am | 1 - | ||
19 | 1 files changed, 0 insertions(+), 1 deletions(-) | ||
20 | |||
21 | diff --git a/libgnome/Makefile.am b/libgnome/Makefile.am | ||
22 | index 9c8cd3e..aa01f6c 100644 | ||
23 | --- a/libgnome/Makefile.am | ||
24 | +++ b/libgnome/Makefile.am | ||
25 | @@ -17,7 +17,6 @@ INCLUDES = \ | ||
26 | -I$(srcdir)/.. \ | ||
27 | $(WARN_CFLAGS) \ | ||
28 | $(LIBGNOME_CFLAGS) \ | ||
29 | - -DG_DISABLE_DEPRECATED \ | ||
30 | -DLIBGNOME_PREFIX=\""$(prefix)"\" \ | ||
31 | -DLIBGNOME_LIBDIR=\""$(libdir)"\" \ | ||
32 | -DLIBGNOME_DATADIR=\""$(datadir)"\" \ | ||
33 | -- | ||
34 | 1.7.6.5 | ||
35 | |||
diff --git a/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb b/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb index 08139735a..325912f43 100644 --- a/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb +++ b/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb | |||
@@ -5,10 +5,11 @@ SECTION = "x11/gnome/libs" | |||
5 | 5 | ||
6 | inherit gnome lib_package | 6 | inherit gnome lib_package |
7 | 7 | ||
8 | PR = "r1" | 8 | PR = "r2" |
9 | 9 | ||
10 | SRC_URI[archive.md5sum] = "a4345e6087ae6195d65a4674ffdca559" | 10 | SRC_URI[archive.md5sum] = "a4345e6087ae6195d65a4674ffdca559" |
11 | SRC_URI[archive.sha256sum] = "b2c63916866485793b87398266dd7778548c1734923c272a94d84ee011b6f7a4" | 11 | SRC_URI[archive.sha256sum] = "b2c63916866485793b87398266dd7778548c1734923c272a94d84ee011b6f7a4" |
12 | SRC_URI += "file://0001-libgnome-Makefile.am-allow-deprecated-symbols.patch" | ||
12 | 13 | ||
13 | DEPENDS += "libcanberra gconf-native gnome-vfs libbonobo esound" | 14 | DEPENDS += "libcanberra gconf-native gnome-vfs libbonobo esound" |
14 | 15 | ||