diff options
author | Noor <noor_ahsan@mentor.com> | 2013-06-17 11:11:42 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-07-12 12:06:02 +0200 |
commit | 54145480b0108b4f3e9f68f1b5572b9927076458 (patch) | |
tree | e54ebb78a9c02cd30b44605399fcd800f4de97e3 /meta-gnome/recipes-gnome/gvfs | |
parent | e33cb25d595e8698c3936410a4ab508125c94d15 (diff) | |
download | meta-openembedded-54145480b0108b4f3e9f68f1b5572b9927076458.tar.gz |
gvfs: Handle samba dependency based on GPLv3 license.
* Samba is GPLv3. In GPLv3 free environment one was not able to
build gvfs. Add PACKAGECONFIG for samba and enable is when GPLv3
is not present in INCOMPATIBLE_LICENSE.
Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gvfs')
-rw-r--r-- | meta-gnome/recipes-gnome/gvfs/gvfs.inc | 4 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gvfs/gvfs_1.10.1.bb | 7 |
2 files changed, 7 insertions, 4 deletions
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs.inc b/meta-gnome/recipes-gnome/gvfs/gvfs.inc index 491428585..288b205da 100644 --- a/meta-gnome/recipes-gnome/gvfs/gvfs.inc +++ b/meta-gnome/recipes-gnome/gvfs/gvfs.inc | |||
@@ -17,9 +17,7 @@ SRC_URI += " \ | |||
17 | file://0004-Adapt-to-glib-thread-API-changes.patch \ | 17 | file://0004-Adapt-to-glib-thread-API-changes.patch \ |
18 | " | 18 | " |
19 | 19 | ||
20 | EXTRA_OECONF = "--with-samba-includes=${STAGING_INCDIR} \ | 20 | EXTRA_OECONF = "--with-archive-includes=${STAGING_INCDIR} \ |
21 | --with-samba-libs=${STAGING_LIBDIR} \ | ||
22 | --with-archive-includes=${STAGING_INCDIR} \ | ||
23 | --with-archive-libs=${STAGING_LIBDIR} \ | 21 | --with-archive-libs=${STAGING_LIBDIR} \ |
24 | " | 22 | " |
25 | 23 | ||
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs_1.10.1.bb b/meta-gnome/recipes-gnome/gvfs/gvfs_1.10.1.bb index 9c21760b7..cab0d348e 100644 --- a/meta-gnome/recipes-gnome/gvfs/gvfs_1.10.1.bb +++ b/meta-gnome/recipes-gnome/gvfs/gvfs_1.10.1.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | require gvfs.inc | 1 | require gvfs.inc |
2 | 2 | ||
3 | DEPENDS = "samba libsoup-2.4 gnome-keyring glib-2.0 fuse avahi fuse gconf libgphoto2" | 3 | DEPENDS = "libsoup-2.4 gnome-keyring glib-2.0 fuse avahi fuse gconf libgphoto2" |
4 | # optional: obexftp libcdio libimobiledevice | 4 | # optional: obexftp libcdio libimobiledevice |
5 | 5 | ||
6 | PR = "${INC_PR}.0" | 6 | PR = "${INC_PR}.0" |
@@ -21,3 +21,8 @@ FILES_gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.moun | |||
21 | 21 | ||
22 | RDEPENDS_${PN} = "gvfs-gdu-volume-monitor" | 22 | RDEPENDS_${PN} = "gvfs-gdu-volume-monitor" |
23 | RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh" | 23 | RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh" |
24 | |||
25 | PACKAGECONFIG ?= "${@base_contains('INCOMPATIBLE_LICENSE', 'GPLv3', '', 'samba', d)}" | ||
26 | |||
27 | PACKAGECONFIG[samba] = "--enable-samba --with-samba-includes=${STAGING_INCDIR} \ | ||
28 | --with-samba-libs=${STAGING_LIBDIR}, --disable-samba, samba" | ||