summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gvfs/gvfs_1.24.2.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-01-09 22:47:20 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-27 12:36:30 +0100
commit52d0cb4348c2518af40d9019413ae046b9eb971b (patch)
tree432d57795a4d933af4d5c60f3ab0507640118937 /meta-gnome/recipes-gnome/gvfs/gvfs_1.24.2.bb
parent9ba1fa91b94fba7b55afe62b781bf9a270260cd0 (diff)
downloadmeta-openembedded-52d0cb4348c2518af40d9019413ae046b9eb971b.tar.gz
gvfs: update to 1.24.2 to make access to windows shares work again
* Our very old and heavily patched version was broken for windows shares by the update of samba to 4.x * Update to latest gvfs version (1.26.2 currently) is not possible due to | configure: error: Package requirements (glib-2.0 >= 2.45.7 gobject-2.0 gmodule-no-export-2.0 gio-unix-2.0 gio-2.0) were not met: | | Requested 'glib-2.0 >= 2.45.7' but version of GLib is 2.44.1 * Licence checksum changed by updating the address of the FSF [1] * obexftp support was removed in [2] * the gdu/circular dependency hack using very old gnome-disk-utility was solved by using udisk2 volume monitor * systemd-login detection was fixed * some more PACKAGECONFIGs disabled by default (all set -except 'cdda'- was build tested) [1] https://git.gnome.org/browse/gvfs/commit/?id=1e9c89eafaac6b3a759115df9981526fe9083461 [2] https://git.gnome.org/browse/gvfs/commit/?id=606ef241fb8677528bd5d5526854658f0f298a2c Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gvfs/gvfs_1.24.2.bb')
-rw-r--r--meta-gnome/recipes-gnome/gvfs/gvfs_1.24.2.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs_1.24.2.bb b/meta-gnome/recipes-gnome/gvfs/gvfs_1.24.2.bb
new file mode 100644
index 000000000..080fd8632
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gvfs/gvfs_1.24.2.bb
@@ -0,0 +1,61 @@
1DESCRIPTION = "gvfs is a userspace virtual filesystem"
2LICENSE = "LGPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e"
4
5inherit gnome
6
7DEPENDS += "libsecret glib-2.0 gconf intltool-native libgudev udisks2"
8
9SRC_URI[archive.md5sum] = "83ed317eb2a5264715d4273e90a5cfd8"
10SRC_URI[archive.sha256sum] = "0949eaedd1df7175f8d7ee2700df8210d1f854b8ee37d963bc32ee7091eeb228"
11SRC_URI += " \
12 file://0001-Add-support-for-libsystemd.patch \
13"
14
15EXTRA_OECONF = " \
16 --disable-gdu \
17 --enable-udisks2 \
18 --with-archive-includes=${STAGING_INCDIR} \
19 --with-archive-libs=${STAGING_LIBDIR} \
20"
21
22PACKAGES =+ "gvfsd-ftp gvfsd-sftp gvfsd-trash"
23
24FILES_${PN} += " \
25 ${datadir}/glib-2.0 \
26 ${datadir}/GConf \
27 ${datadir}/dbus-1/services \
28 ${libdir}/gio/modules/*.so \
29 ${libdir}/tmpfiles.d \
30"
31RDEPENDS_${PN} = "udisks2"
32
33FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/*"
34FILES_${PN}-dev += "${libdir}/gio/modules/*.la"
35
36FILES_gvfsd-ftp = "${libexecdir}/gvfsd-ftp ${datadir}/gvfs/mounts/ftp.mount"
37FILES_gvfsd-sftp = "${libexecdir}/gvfsd-sftp ${datadir}/gvfs/mounts/sftp.mount"
38FILES_gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.mount"
39
40RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh"
41
42PACKAGES += "${PN}-bash-completion"
43FILES_${PN}-bash-completion = "${datadir}/bash-completion"
44RDEPENDS_${PN}-bash-completion = "bash-completion"
45
46PACKAGECONFIG ?= "libgphoto2"
47
48PACKAGECONFIG[afc] = "--enable-afc, --disable-afc, libimobiledevice libplist"
49PACKAGECONFIG[archive] = "--enable-archive, --disable-archive, libarchive"
50PACKAGECONFIG[avahi] = "--enable-avahi, --disable-avahi, avahi"
51PACKAGECONFIG[gtk] = "--enable-gtk, --disable-gtk, gtk+3"
52PACKAGECONFIG[http] = "--enable-http, --disable-http, libsoup-2.4"
53PACKAGECONFIG[libmtp] = "--enable-libmtp, --disable-libmtp, libmtp"
54PACKAGECONFIG[libgphoto2] = "--enable-gphoto2, --disable-gphoto2, libgphoto2"
55PACKAGECONFIG[samba] = "--enable-samba, --disable-samba, samba"
56
57# needs meta-filesystems
58PACKAGECONFIG[fuse] = "--enable-fuse, --disable-fuse, fuse"
59
60# libcdio-paranoia recipe doesn't exist yet
61PACKAGECONFIG[cdda] = "--enable-cdda, --disable-cdda, libcdio-paranoia"