diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:35:16 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:36:45 +0200 |
commit | cdb428e7c49899675ee7b7a43f6cecdb5b4c2546 (patch) | |
tree | 42c4f0752df5a0bae2c3aeec8362faa029adc792 /meta-gnome/recipes-gnome/gnome | |
parent | 2af18f934cd6764ef87977c8b23a924a5cb7fbf7 (diff) | |
download | meta-openembedded-cdb428e7c49899675ee7b7a43f6cecdb5b4c2546.tar.gz |
recipes: add removal date to PNBLACKLIST messages
* based on discussion in pndeprecated thread:
https://patchwork.openembedded.org/patch/137573/
update the messages to warn possible users that the
recipe will be removed before the end of the next development
cycle (before Yocto 2.4 is released).
* updated with:
sed -i 's/^\(PNBLACKLIST.*".*\)"/\1 - the recipe will be removed on 2017-09-01 unless the issue is fixed"/g' `git grep PNBLACKLIST | sed 's/:.*//g' | sort -u | xargs`
* then noticed couple recipes being blacklisted only based on
DISTRO_FEATURES, so removed those:
meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.17.bb
meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.5.bb
meta-oe/recipes-connectivity/bluez/bluez4_4.101.bb
meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb
meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb
meta-oe/recipes-navigation/gypsy/gypsy.inc
meta-oe/recipes-navigation/navit/navit.inc
meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb
* if it isn't fixed by this date, it's fair game to be removed
whenever someone gets around to i
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome')
-rw-r--r-- | meta-gnome/recipes-gnome/gnome/gnome-terminal_2.30.2.bb | 2 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome/libgnomecups_0.2.3.bb | 2 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb | 2 |
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-gnome/recipes-gnome/gnome/gnome-terminal_2.30.2.bb b/meta-gnome/recipes-gnome/gnome/gnome-terminal_2.30.2.bb index 18e74dae6..6b3bf7654 100644 --- a/meta-gnome/recipes-gnome/gnome/gnome-terminal_2.30.2.bb +++ b/meta-gnome/recipes-gnome/gnome/gnome-terminal_2.30.2.bb | |||
@@ -19,4 +19,4 @@ GNOME_COMPRESS_TYPE="bz2" | |||
19 | RRECOMMENDS_${PN} += "gnome-common-schemas" | 19 | RRECOMMENDS_${PN} += "gnome-common-schemas" |
20 | 20 | ||
21 | # http://errors.yoctoproject.org/Errors/Details/68636/ | 21 | # http://errors.yoctoproject.org/Errors/Details/68636/ |
22 | PNBLACKLIST[gnome-terminal] ?= "BROKEN: fails to build with gcc-6" | 22 | PNBLACKLIST[gnome-terminal] ?= "BROKEN: fails to build with gcc-6 - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomecups_0.2.3.bb b/meta-gnome/recipes-gnome/gnome/libgnomecups_0.2.3.bb index 53cdf69f7..3480712b5 100644 --- a/meta-gnome/recipes-gnome/gnome/libgnomecups_0.2.3.bb +++ b/meta-gnome/recipes-gnome/gnome/libgnomecups_0.2.3.bb | |||
@@ -22,4 +22,4 @@ SRC_URI[archive.md5sum] = "dc4920c15c9f886f73ea74fbff0ae48b" | |||
22 | SRC_URI[archive.sha256sum] = "e130e80942b386de19a288a4c194ff3dbe9140315b31e982058c8bffbb6a1d29" | 22 | SRC_URI[archive.sha256sum] = "e130e80942b386de19a288a4c194ff3dbe9140315b31e982058c8bffbb6a1d29" |
23 | GNOME_COMPRESS_TYPE="bz2" | 23 | GNOME_COMPRESS_TYPE="bz2" |
24 | 24 | ||
25 | PNBLACKLIST[libgnomecups] ?= "Depends on blacklisted libgnomeui" | 25 | PNBLACKLIST[libgnomecups] ?= "Depends on blacklisted libgnomeui - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb index ff14616d2..a462a4b9e 100644 --- a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb +++ b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb | |||
@@ -25,4 +25,4 @@ FILES_${PN}-staticdev += "\ | |||
25 | ${libdir}/${PN}/${PV}/modules/*/*.a \ | 25 | ${libdir}/${PN}/${PV}/modules/*/*.a \ |
26 | " | 26 | " |
27 | 27 | ||
28 | PNBLACKLIST[libgnomeprint] ?= "Depends on broken libgnomecups" | 28 | PNBLACKLIST[libgnomeprint] ?= "Depends on broken libgnomecups - the recipe will be removed on 2017-09-01 unless the issue is fixed" |