summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-05-05 12:09:05 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-13 14:34:19 +0200
commite480ddd7b308b5dd5188a18eaa33301c0e833384 (patch)
tree2f212db4b454f306f3159b4fbfc711dfb346f48a /meta-gnome/recipes-gnome/gnome
parentb2c99948e118e394bfb64bf9536b417cbd2d6010 (diff)
downloadmeta-openembedded-e480ddd7b308b5dd5188a18eaa33301c0e833384.tar.gz
libgnomeprint: Fix build with newer bison >= 3
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome/libgnomeprint/bison3-support.patch30
-rw-r--r--meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb5
2 files changed, 33 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomeprint/bison3-support.patch b/meta-gnome/recipes-gnome/gnome/libgnomeprint/bison3-support.patch
new file mode 100644
index 000000000..29d410a0a
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome/libgnomeprint/bison3-support.patch
@@ -0,0 +1,30 @@
1Index: libgnomeprint-2.18.8/libgnomeprint/grammar.y
2===================================================================
3--- libgnomeprint-2.18.8.orig/libgnomeprint/grammar.y
4+++ libgnomeprint-2.18.8/libgnomeprint/grammar.y
5@@ -99,7 +99,7 @@ gnome_print_filter_parse_prop (GnomePrin
6 }
7
8 static int yylex (void *lvalp);
9-static int yyerror (const char *s);
10+static int yyerror (graph_t *g, const char *s);
11 %}
12
13 %union {
14@@ -117,6 +117,7 @@ static int yyerror (const char *s);
15 %type <p> pool
16
17 %pure_parser
18+%parse-param { graph_t *graph }
19
20 %start graph
21 %%
22@@ -185,7 +186,7 @@ graph: filter {
23 %%
24
25 static int
26-yyerror (const char *s)
27+yyerror (graph_t *g, const char *s)
28 {
29 return -1;
30 }
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb
index 15e513a78..b17062beb 100644
--- a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb
+++ b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb
@@ -1,15 +1,16 @@
1LICENSE = "GPLv2" 1LICENSE = "GPLv2"
2SECTION = "x11/gnome/libs" 2SECTION = "x11/gnome/libs"
3 3
4DEPENDS = "libxml2 libgnomecups glib-2.0 pango libart-lgpl fontconfig popt gnome-common freetype" 4DEPENDS = "bison-native flex-native libxml2 libgnomecups glib-2.0 pango libart-lgpl fontconfig popt gnome-common freetype"
5 5
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7 7
8inherit pkgconfig gnomebase 8inherit gnomebase
9 9
10SRC_URI += "file://fix.includes.patch \ 10SRC_URI += "file://fix.includes.patch \
11 file://freetype.patch \ 11 file://freetype.patch \
12 file://0001-configure-use-pkgconfig-for-freetype.patch \ 12 file://0001-configure-use-pkgconfig-for-freetype.patch \
13 file://bison3-support.patch \
13 " 14 "
14SRC_URI[archive.md5sum] = "63b05ffb5386e131487c6af30f4c56ac" 15SRC_URI[archive.md5sum] = "63b05ffb5386e131487c6af30f4c56ac"
15SRC_URI[archive.sha256sum] = "1034ec8651051f84d2424e7a1da61c530422cc20ce5b2d9e107e1e46778d9691" 16SRC_URI[archive.sha256sum] = "1034ec8651051f84d2424e7a1da61c530422cc20ce5b2d9e107e1e46778d9691"