diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2019-12-27 22:31:13 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-12-29 10:22:57 -0800 |
commit | d81bc0e5dcab2fe3f3fc792f3096837621f52bb3 (patch) | |
tree | 19a0ba2f7e7b65074140e2150fff4e05130fb26e /meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.2.bb | |
parent | 012038905e7e834d2a784ab56d6950b424662f7b (diff) | |
download | meta-openembedded-d81bc0e5dcab2fe3f3fc792f3096837621f52bb3.tar.gz |
gnome-settings-daemon: upgrade 3.34.1 -> 3.34.2
>From [1]:
==============
Version 3.34.2
==============
Media-keys:
- Place spawned processes into a systemd scope.
For this to work, gnome-settings-daemon needs to be build with
libgnome-desktop >= 3.34.2.1, as the API was added in that release.
- Fixed saving screenshots to clipboard on wayland.
For 3.34, this feature was fixed by using the X11 clipboard,
saving to clipboard will indefinitely raise Xwayland
if the Xwayland-on-demand experimental feature was enabled,
and will not work at all if --no-x11 is passed to gnome-shell.
- Fix crash on keybinding migration
Smartcard:
- Initialize pointer before use
[1] http://ftp.gnome.org/pub/gnome/sources/gnome-settings-daemon/3.34/gnome-settings-daemon-3.34.2.news
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.2.bb')
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.2.bb | 59 |
1 files changed, 59 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.2.bb b/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.2.bb new file mode 100644 index 000000000..0b6865d29 --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.2.bb | |||
@@ -0,0 +1,59 @@ | |||
1 | SUMMARY = "Window navigation construction toolkit" | ||
2 | LICENSE = "LGPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" | ||
4 | |||
5 | GNOMEBASEBUILDCLASS = "meson" | ||
6 | |||
7 | inherit gnomebase gsettings gobject-introspection gettext features_check upstream-version-is-even | ||
8 | |||
9 | SRC_URI[archive.md5sum] = "528b0b7cc2dd22c6026a9c8739c71fa7" | ||
10 | SRC_URI[archive.sha256sum] = "7ce4979817866911a94ecb75b36db56797e038c0c524c5c1a81aefccafc17337" | ||
11 | |||
12 | DEPENDS = " \ | ||
13 | colord \ | ||
14 | geocode-glib \ | ||
15 | gcr \ | ||
16 | gnome-desktop3 \ | ||
17 | libgweather \ | ||
18 | lcms \ | ||
19 | libcanberra \ | ||
20 | geoclue \ | ||
21 | libnotify \ | ||
22 | upower \ | ||
23 | libwacom \ | ||
24 | virtual/libx11 \ | ||
25 | " | ||
26 | |||
27 | # all these are mandatory | ||
28 | REQUIRED_DISTRO_FEATURES = "x11 polkit pulseaudio systemd gobject-introspection-data" | ||
29 | UNKNOWN_CONFIGURE_WHITELIST_append = " introspection" | ||
30 | |||
31 | SRC_URI[archive.md5sum] = "493332fa0f36645188468fed41c0060b" | ||
32 | SRC_URI[archive.sha256sum] = "9fbae67e217e53b99e4f9e7d392c91ffbe31253941c9b136ef09c2d9db7ad7ed" | ||
33 | |||
34 | # allow cross build mixed with build of native tools | ||
35 | do_write_config_append() { | ||
36 | cat >${WORKDIR}/meson.native <<EOF | ||
37 | [binaries] | ||
38 | pkgconfig = 'pkg-config-native' | ||
39 | EOF | ||
40 | } | ||
41 | EXTRA_OEMESON = "--native-file ${WORKDIR}/meson.native" | ||
42 | |||
43 | PACKAGECONFIG ??= " \ | ||
44 | cups nm \ | ||
45 | alsa gudev \ | ||
46 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \ | ||
47 | " | ||
48 | PACKAGECONFIG[alsa] = "-Dalsa=true,-Dalsa=false,alsa-lib" | ||
49 | PACKAGECONFIG[cups] = "-Dcups=true,-Dcups=false,cups" | ||
50 | PACKAGECONFIG[gudev] = "-Dgudev=true,-Dgudev=false,libgudev" | ||
51 | PACKAGECONFIG[nm] = "-Dnetwork_manager=true,-Dnetwork_manager=false,networkmanager" | ||
52 | PACKAGECONFIG[wayland] = "-Dwayland=true,-Dwayland=false,wayland" | ||
53 | |||
54 | FILES_${PN} += " \ | ||
55 | ${systemd_user_unitdir} \ | ||
56 | ${libdir}/gnome-settings-daemon-3.0/libgsd.so \ | ||
57 | " | ||
58 | |||
59 | RDEPEND_${PN} += "gdbus" | ||