summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-panel
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-24 14:57:01 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:26 +0200
commitb4d7caaff9ee7e3ba2f5756b3d2ea2de498d4c2f (patch)
treea6c368b68b1a6181cca37fda37bf5444e20e4512 /meta-gnome/recipes-gnome/gnome-panel
parentf0de8ed2c3301b8629d87a4e3357d580d4db154a (diff)
downloadmeta-openembedded-b4d7caaff9ee7e3ba2f5756b3d2ea2de498d4c2f.tar.gz
gnome-doc-utils-stub: add a recipe
Real gnome-doc-utils can no longer be build (because it requires both python 2 and libxml2, which can only be build for one version of Python), so a stub recipe which provides just m4 macros is provided, and usage of gnome-doc-utils is disabled where needed. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-panel')
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel/0001-Add-gnome-doc-utils.make.patch730
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb4
2 files changed, 732 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/0001-Add-gnome-doc-utils.make.patch b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/0001-Add-gnome-doc-utils.make.patch
new file mode 100644
index 000000000..fdcccb9d7
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/0001-Add-gnome-doc-utils.make.patch
@@ -0,0 +1,730 @@
1From 7345730ac882ee5a493254e5cf9162c96c648ef2 Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex.kanavin@gmail.com>
3Date: Tue, 17 May 2016 14:40:33 +0300
4Subject: [PATCH] Add gnome-doc-utils.make
5
6Since the sources are taken from git, the file is absent
7(and is installed by tools from gnome-doc-utils which
8are no longer provided).
9
10Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
11---
12 gnome-doc-utils.make | 706 +++++++++++++++++++++++++++++++++++++++++++++++++++
13 1 file changed, 706 insertions(+)
14 create mode 100644 gnome-doc-utils.make
15
16diff --git a/gnome-doc-utils.make b/gnome-doc-utils.make
17new file mode 100644
18index 0000000..b2e0fa1
19--- /dev/null
20+++ b/gnome-doc-utils.make
21@@ -0,0 +1,706 @@
22+# gnome-doc-utils.make - make magic for building documentation
23+# Copyright (C) 2004-2005 Shaun McCance <shaunm@gnome.org>
24+#
25+# This program is free software; you can redistribute it and/or modify
26+# it under the terms of the GNU General Public License as published by
27+# the Free Software Foundation; either version 2 of the License, or
28+# (at your option) any later version.
29+#
30+# This program is distributed in the hope that it will be useful,
31+# but WITHOUT ANY WARRANTY; without even the implied warranty of
32+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
33+# GNU General Public License for more details.
34+#
35+# You should have received a copy of the GNU General Public License
36+# along with this program; if not, write to the Free Software Foundation,
37+# Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
38+#
39+# As a special exception to the GNU General Public License, if you
40+# distribute this file as part of a program that contains a
41+# configuration script generated by Autoconf, you may include it under
42+# the same distribution terms that you use for the rest of that program.
43+
44+################################################################################
45+## @@ Generating Header Files
46+
47+## @ DOC_H_FILE
48+## The name of the header file to generate
49+DOC_H_FILE ?=
50+
51+## @ DOC_H_DOCS
52+## The input DocBook files for generating the header file
53+DOC_H_DOCS ?=
54+
55+$(DOC_H_FILE): $(DOC_H_DOCS);
56+ @rm -f $@.tmp; touch $@.tmp;
57+ echo 'const gchar* documentation_credits[] = {' >> $@.tmp
58+ list='$(DOC_H_DOCS)'; for doc in $$list; do \
59+ xmlpath="`echo $$doc | sed -e 's/^\(.*\/\).*/\1/' -e '/\//!s/.*//'`:$(srcdir)/`echo $$doc | sed -e 's/^\(.*\/\).*/\1/' -e '/\//!s/.*//'`"; \
60+ if ! test -f "$$doc"; then doc="$(srcdir)/$$doc"; fi; \
61+ xsltproc -nonet --path "$$xmlpath" $(_credits) $$doc; \
62+ done | sort | uniq \
63+ | awk 'BEGIN{s=""}{n=split($$0,w,"<");if(s!=""&&s!=substr(w[1],1,length(w[1])-1)){print s};if(n>1){print $$0;s=""}else{s=$$0}};END{if(s!=""){print s}}' \
64+ | sed -e 's/\\/\\\\/' -e 's/"/\\"/' -e 's/\(.*\)/\t"\1",/' >> $@.tmp
65+ echo ' NULL' >> $@.tmp
66+ echo '};' >> $@.tmp
67+ echo >> $@.tmp
68+ list='$(DOC_H_DOCS)'; for doc in $$list; do \
69+ xmlpath="`echo $$doc | sed -e 's/^\(.*\/\).*/\1/' -e '/\//!s/.*//'`:$(srcdir)/`echo $$doc | sed -e 's/^\(.*\/\).*/\1/' -e '/\//!s/.*//'`"; \
70+ if ! test -f "$$doc"; then doc="$(srcdir)/$$doc"; fi; \
71+ docid=`echo "$$doc" | sed -e 's/.*\/\([^/]*\)\.xml/\1/' \
72+ | sed -e 's/[^a-zA-Z_]/_/g' | tr 'a-z' 'A-Z'`; \
73+ echo $$xmlpath; \
74+ ids=`xsltproc -nonet --xinclude --path "$$xmlpath" $(_ids) $$doc`; \
75+ for id in $$ids; do \
76+ echo '#define HELP_'`echo $$docid`'_'`echo $$id \
77+ | sed -e 's/[^a-zA-Z_]/_/g' | tr 'a-z' 'A-Z'`' "'$$id'"' >> $@.tmp; \
78+ done; \
79+ echo >> $@.tmp; \
80+ done;
81+ cp $@.tmp $@ && rm -f $@.tmp
82+
83+dist-check-gdu:
84+if !HAVE_GNOME_DOC_UTILS
85+ @echo "*** GNOME Doc Utils must be installed in order to make dist"
86+ @false
87+endif
88+
89+.PHONY: dist-doc-header
90+dist-doc-header: $(DOC_H_FILE)
91+ @if test -f "$(DOC_H_FILE)"; then d=; else d="$(srcdir)/"; fi; \
92+ echo "$(INSTALL_DATA) $${d}$(DOC_H_FILE) $(distdir)/$(DOC_H_FILE)"; \
93+ $(INSTALL_DATA) "$${d}$(DOC_H_FILE)" "$(distdir)/$(DOC_H_FILE)";
94+
95+doc-dist-hook: dist-check-gdu $(if $(DOC_H_FILE),dist-doc-header)
96+
97+.PHONY: clean-doc-header
98+_clean_doc_header = $(if $(DOC_H_FILE),clean-doc-header)
99+clean-local: $(_clean_doc_header)
100+distclean-local: $(_clean_doc_header)
101+mostlyclean-local: $(_clean_doc_header)
102+maintainer-clean-local: $(_clean_doc_header)
103+clean-doc-header:
104+ rm -f $(DOC_H_FILE)
105+
106+all: $(DOC_H_FILE)
107+
108+
109+################################################################################
110+## @@ Generating Documentation Files
111+
112+## @ DOC_MODULE
113+## The name of the document being built
114+DOC_MODULE ?=
115+
116+## @ DOC_ID
117+## The unique identifier for a Mallard document
118+DOC_ID ?=
119+
120+## @ DOC_PAGES
121+## Page files in a Mallard document
122+DOC_PAGES ?=
123+
124+## @ DOC_ENTITIES
125+## Files included with a SYSTEM entity
126+DOC_ENTITIES ?=
127+
128+## @ DOC_INCLUDES
129+## Files included with XInclude
130+DOC_INCLUDES ?=
131+
132+## @ DOC_FIGURES
133+## Figures and other external data
134+DOC_FIGURES ?=
135+
136+## @ DOC_FORMATS
137+## The default formats to be built and installed
138+DOC_FORMATS ?= docbook
139+_DOC_REAL_FORMATS = $(if $(DOC_USER_FORMATS),$(DOC_USER_FORMATS),$(DOC_FORMATS))
140+
141+## @ DOC_LINGUAS
142+## The languages this document is translated into
143+DOC_LINGUAS ?=
144+_DOC_REAL_LINGUAS = $(if $(filter environment,$(origin LINGUAS)), \
145+ $(filter $(LINGUAS),$(DOC_LINGUAS)), \
146+ $(DOC_LINGUAS))
147+
148+_DOC_ABS_SRCDIR = @abs_srcdir@
149+
150+
151+################################################################################
152+## Variables for Bootstrapping
153+
154+_xml2po ?= `which xml2po`
155+_xml2po_mode = $(if $(DOC_ID),mallard,docbook)
156+
157+_db2html ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable db2html gnome-doc-utils`
158+_db2omf ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable db2omf gnome-doc-utils`
159+_chunks ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/chunks.xsl
160+_credits ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/credits.xsl
161+_ids ?= ${PKG_CONFIG_SYSROOT_DIR}$(shell $(PKG_CONFIG) --variable xmldir gnome-doc-utils)/gnome/xslt/docbook/utils/ids.xsl
162+
163+if ENABLE_SK
164+_ENABLE_SK = true
165+_skpkgdatadir ?= `scrollkeeper-config --pkgdatadir`
166+_sklocalstatedir ?= `scrollkeeper-config --pkglocalstatedir`
167+_skcontentslist ?= $(_skpkgdatadir)/Templates/C/scrollkeeper_cl.xml
168+endif
169+
170+
171+################################################################################
172+## Support for automake silent-rules
173+GDU_V_XML2PO=$(GDU__v_XML2PO_$(V))
174+GDU__v_XML2PO_=$(GDU__v_XML2PO_$(AM_DEFAULT_VERBOSITY))
175+GDU__v_XML2PO_0=@echo " XML2PO" $@;
176+
177+GDU_V_MSGFMT=$(GDU__v_MSGFMT_$(V))
178+GDU__v_MSGFMT_=$(GDU__v_MSGFMT_$(AM_DEFAULT_VERBOSITY))
179+GDU__v_MSGFMT_0=@echo " MSGFMT" $@;
180+
181+GDU_V_DB2OMF=$(GDU__v_DB2OMF_$(V))
182+GDU__v_DB2OMF_=$(GDU__v_DB2OMF_$(AM_DEFAULT_VERBOSITY))
183+GDU__v_DB2OMF_0=@echo " DB2OMF" $@;
184+
185+GDU_V_DB2HTM=$(GDU__v_DB2HTM_$(V))
186+GDU__v_DB2HTM_=$(GDU__v_DB2HTM_$(AM_DEFAULT_VERBOSITY))
187+GDU__v_DB2HTM_0=@echo " DB2HTM" $@;
188+
189+################################################################################
190+## @@ Rules for OMF Files
191+
192+db2omf_args = \
193+ --stringparam db2omf.basename $(DOC_MODULE) \
194+ --stringparam db2omf.format $(3) \
195+ --stringparam db2omf.dtd \
196+ $(shell xmllint --format $(2) | grep -h PUBLIC | head -n 1 \
197+ | sed -e 's/.*PUBLIC \(\"[^\"]*\"\).*/\1/') \
198+ --stringparam db2omf.lang $(notdir $(patsubst %/$(notdir $(2)),%,$(2))) \
199+ --stringparam db2omf.omf_dir "$(OMF_DIR)" \
200+ --stringparam db2omf.help_dir "$(HELP_DIR)" \
201+ --stringparam db2omf.omf_in "$(_DOC_OMF_IN)" \
202+ $(if $(_ENABLE_SK), \
203+ --stringparam db2omf.scrollkeeper_cl "$(_skcontentslist)") \
204+ $(_db2omf) $(2)
205+
206+## @ _DOC_OMF_IN
207+## The OMF input file
208+_DOC_OMF_IN = $(if $(DOC_MODULE),$(wildcard $(_DOC_ABS_SRCDIR)/$(DOC_MODULE).omf.in))
209+
210+## @ _DOC_OMF_DB
211+## The OMF files for DocBook output
212+_DOC_OMF_DB = $(if $(_DOC_OMF_IN), \
213+ $(foreach lc,C $(_DOC_REAL_LINGUAS),$(DOC_MODULE)-$(lc).omf))
214+
215+$(_DOC_OMF_DB) : $(_DOC_OMF_IN)
216+$(_DOC_OMF_DB) : $(DOC_MODULE)-%.omf : %/$(DOC_MODULE).xml
217+ @test "x$(_ENABLE_SK)" != "xtrue" -o -f "$(_skcontentslist)" || { \
218+ echo "The file '$(_skcontentslist)' does not exist." >&2; \
219+ echo "Please check your ScrollKeeper installation." >&2; \
220+ exit 1; }
221+ $(GDU_V_DB2OMF)xsltproc -nonet -o $@ $(call db2omf_args,$@,$<,'docbook') || { rm -f "$@"; exit 1; }
222+
223+## @ _DOC_OMF_HTML
224+## The OMF files for HTML output
225+_DOC_OMF_HTML = $(if $(_DOC_OMF_IN), \
226+ $(foreach lc,C $(_DOC_REAL_LINGUAS),$(DOC_MODULE)-html-$(lc).omf))
227+
228+$(_DOC_OMF_HTML) : $(_DOC_OMF_IN)
229+$(_DOC_OMF_HTML) : $(DOC_MODULE)-html-%.omf : %/$(DOC_MODULE).xml
230+if ENABLE_SK
231+ @test "x$(_ENABLE_SK)" != "xtrue" -o -f "$(_skcontentslist)" || { \
232+ echo "The file '$(_skcontentslist)' does not exist" >&2; \
233+ echo "Please check your ScrollKeeper installation." >&2; \
234+ exit 1; }
235+endif
236+ $(GDU_V_DB2OMF)xsltproc -nonet -o $@ $(call db2omf_args,$@,$<,'xhtml') || { rm -f "$@"; exit 1; }
237+
238+## @ _DOC_OMF_ALL
239+## All OMF output files to be built
240+# FIXME
241+_DOC_OMF_ALL = \
242+ $(if $(filter docbook,$(_DOC_REAL_FORMATS)),$(_DOC_OMF_DB)) \
243+ $(if $(filter html HTML,$(_DOC_REAL_FORMATS)),$(_DOC_OMF_HTML))
244+
245+.PHONY: omf
246+omf: $(_DOC_OMF_ALL)
247+
248+
249+################################################################################
250+## @@ C Locale Documents
251+
252+## @ _DOC_C_MODULE
253+## The top-level documentation file in the C locale
254+_DOC_C_MODULE = $(if $(DOC_MODULE),C/$(DOC_MODULE).xml)
255+
256+## @ _DOC_C_PAGES
257+## Page files in a Mallard document in the C locale
258+_DOC_C_PAGES = $(foreach page,$(DOC_PAGES),C/$(page))
259+
260+## @ _DOC_C_ENTITIES
261+## Files included with a SYSTEM entity in the C locale
262+_DOC_C_ENTITIES = $(foreach ent,$(DOC_ENTITIES),C/$(ent))
263+
264+## @ _DOC_C_XINCLUDES
265+## Files included with XInclude in the C locale
266+_DOC_C_INCLUDES = $(foreach inc,$(DOC_INCLUDES),C/$(inc))
267+
268+## @ _DOC_C_DOCS
269+## All documentation files in the C locale
270+_DOC_C_DOCS = \
271+ $(_DOC_C_ENTITIES) $(_DOC_C_INCLUDES) \
272+ $(_DOC_C_PAGES) $(_DOC_C_MODULE)
273+
274+## @ _DOC_C_DOCS_NOENT
275+## All documentation files in the C locale,
276+## except files included with a SYSTEM entity
277+_DOC_C_DOCS_NOENT = \
278+ $(_DOC_C_MODULE) $(_DOC_C_INCLUDES) \
279+ $(_DOC_C_PAGES)
280+
281+## @ _DOC_C_FIGURES
282+## All figures and other external data in the C locale
283+_DOC_C_FIGURES = $(if $(DOC_FIGURES), \
284+ $(foreach fig,$(DOC_FIGURES),C/$(fig)), \
285+ $(patsubst $(srcdir)/%,%,$(wildcard $(srcdir)/C/figures/*.png)))
286+
287+## @ _DOC_C_HTML
288+## All HTML documentation in the C locale
289+# FIXME: probably have to shell escape to determine the file names
290+_DOC_C_HTML = $(foreach f, \
291+ $(shell xsltproc -nonet --xinclude \
292+ --stringparam db.chunk.basename "$(DOC_MODULE)" \
293+ $(_chunks) "C/$(DOC_MODULE).xml"), \
294+ C/$(f).xhtml)
295+
296+###############################################################################
297+## @@ Other Locale Documentation
298+
299+## @ _DOC_POFILES
300+## The .po files used for translating the document
301+_DOC_POFILES = $(if $(DOC_MODULE)$(DOC_ID), \
302+ $(foreach lc,$(_DOC_REAL_LINGUAS),$(lc)/$(lc).po))
303+
304+.PHONY: po
305+po: $(_DOC_POFILES)
306+
307+## @ _DOC_MOFILES
308+## The .mo files used for translating the document
309+_DOC_MOFILES = $(patsubst %.po,%.mo,$(_DOC_POFILES))
310+
311+.PHONY: mo
312+mo: $(_DOC_MOFILES)
313+
314+## @ _DOC_LC_MODULES
315+## The top-level documentation files in all other locales
316+_DOC_LC_MODULES = $(if $(DOC_MODULE), \
317+ $(foreach lc,$(_DOC_REAL_LINGUAS),$(lc)/$(DOC_MODULE).xml))
318+
319+## @ _DOC_LC_PAGES
320+## Page files in a Mallard document in all other locales
321+_DOC_LC_PAGES = \
322+ $(foreach lc,$(_DOC_REAL_LINGUAS),$(foreach page,$(_DOC_C_PAGES), \
323+ $(lc)/$(notdir $(page)) ))
324+
325+## @ _DOC_LC_XINCLUDES
326+## Files included with XInclude in all other locales
327+_DOC_LC_INCLUDES = \
328+ $(foreach lc,$(_DOC_REAL_LINGUAS),$(foreach inc,$(_DOC_C_INCLUDES), \
329+ $(lc)/$(notdir $(inc)) ))
330+
331+## @ _DOC_LC_HTML
332+## All HTML documentation in all other locales
333+# FIXME: probably have to shell escape to determine the file names
334+_DOC_LC_HTML = \
335+ $(foreach lc,$(_DOC_REAL_LINGUAS),$(foreach doc,$(_DOC_C_HTML), \
336+ $(lc)/$(notdir $(doc)) ))
337+
338+## @ _DOC_LC_DOCS
339+## All documentation files in all other locales
340+_DOC_LC_DOCS = \
341+ $(_DOC_LC_MODULES) $(_DOC_LC_INCLUDES) $(_DOC_LC_PAGES) \
342+ $(if $(filter html HTML,$(_DOC_REAL_FORMATS)),$(_DOC_LC_HTML))
343+
344+## @ _DOC_LC_FIGURES
345+## All figures and other external data in all other locales
346+_DOC_LC_FIGURES = $(foreach lc,$(_DOC_REAL_LINGUAS), \
347+ $(patsubst C/%,$(lc)/%,$(_DOC_C_FIGURES)) )
348+
349+_DOC_SRC_FIGURES = \
350+ $(foreach fig,$(_DOC_C_FIGURES), $(foreach lc,C $(_DOC_REAL_LINGUAS), \
351+ $(wildcard $(srcdir)/$(lc)/$(patsubst C/%,%,$(fig))) ))
352+
353+$(_DOC_POFILES):
354+ @if ! test -d $(dir $@); then \
355+ echo "mkdir $(dir $@)"; \
356+ mkdir "$(dir $@)"; \
357+ fi
358+ @if test ! -f $@ -a -f $(srcdir)/$@; then \
359+ echo "cp $(srcdir)/$@ $@"; \
360+ cp "$(srcdir)/$@" "$@"; \
361+ fi;
362+ @docs=; \
363+ list='$(_DOC_C_DOCS_NOENT)'; for doc in $$list; do \
364+ docs="$$docs $(_DOC_ABS_SRCDIR)/$$doc"; \
365+ done; \
366+ if ! test -f $@; then \
367+ echo "(cd $(dir $@) && \
368+ $(_xml2po) -m $(_xml2po_mode) -e $$docs > $(notdir $@).tmp && \
369+ cp $(notdir $@).tmp $(notdir $@) && rm -f $(notdir $@).tmp)"; \
370+ (cd $(dir $@) && \
371+ $(_xml2po) -m $(_xml2po_mode) -e $$docs > $(notdir $@).tmp && \
372+ cp $(notdir $@).tmp $(notdir $@) && rm -f $(notdir $@).tmp); \
373+ else \
374+ echo "(cd $(dir $@) && \
375+ $(_xml2po) -m $(_xml2po_mode) -e -u $(notdir $@) $$docs)"; \
376+ (cd $(dir $@) && \
377+ $(_xml2po) -m $(_xml2po_mode) -e -u $(notdir $@) $$docs); \
378+ fi
379+
380+$(_DOC_MOFILES): %.mo: %.po
381+ $(AM_V_at)if ! test -d $(dir $@); then mkdir "$(dir $@)"; fi
382+ $(GDU_V_MSGFMT)msgfmt -o $@ $<
383+
384+# FIXME: fix the dependancy
385+# FIXME: hook xml2po up
386+$(_DOC_LC_DOCS) : $(_DOC_MOFILES)
387+$(_DOC_LC_DOCS) : $(_DOC_C_DOCS)
388+ $(AM_V_at)if ! test -d $(dir $@); then mkdir $(dir $@); fi
389+ $(GDU_V_XML2PO)if [ -f "C/$(notdir $@)" ]; then d="../"; else d="$(_DOC_ABS_SRCDIR)/"; fi; \
390+ mo="$(dir $@)$(patsubst %/$(notdir $@),%,$@).mo"; \
391+ if [ -f "$${mo}" ]; then mo="../$${mo}"; else mo="$(_DOC_ABS_SRCDIR)/$${mo}"; fi; \
392+ (cd $(dir $@) && \
393+ $(_xml2po) -m $(_xml2po_mode) -e -t "$${mo}" \
394+ "$${d}C/$(notdir $@)" > $(notdir $@).tmp && \
395+ cp $(notdir $@).tmp $(notdir $@) && rm -f $(notdir $@).tmp)
396+
397+## @ _DOC_POT
398+## A pot file
399+_DOC_POT = $(if $(DOC_MODULE),$(DOC_MODULE).pot,$(if $(DOC_ID),$(DOC_ID).pot))
400+.PHONY: pot
401+pot: $(_DOC_POT)
402+$(_DOC_POT): $(_DOC_C_DOCS_NOENT)
403+ $(GDU_V_XML2PO)$(_xml2po) -m $(_xml2po_mode) -e -o $@ $^
404+
405+
406+################################################################################
407+## @@ All Documentation
408+
409+## @ _DOC_HTML_ALL
410+## All HTML documentation, only if it's built
411+_DOC_HTML_ALL = $(if $(filter html HTML,$(_DOC_REAL_FORMATS)), \
412+ $(_DOC_C_HTML) $(_DOC_LC_HTML))
413+
414+_DOC_HTML_TOPS = $(foreach lc,C $(_DOC_REAL_LINGUAS),$(lc)/$(DOC_MODULE).xhtml)
415+
416+$(_DOC_HTML_TOPS): $(_DOC_C_DOCS) $(_DOC_LC_DOCS)
417+ $(GDU_V_DB2HTM)xsltproc -nonet -o $@ --xinclude --param db.chunk.chunk_top "false()" --stringparam db.chunk.basename "$(DOC_MODULE)" --stringparam db.chunk.extension ".xhtml" $(_db2html) $(patsubst %.xhtml,%.xml,$@)
418+
419+
420+################################################################################
421+## All
422+
423+all: \
424+ $(_DOC_C_DOCS) $(_DOC_LC_DOCS) \
425+ $(_DOC_OMF_ALL) $(_DOC_DSK_ALL) \
426+ $(_DOC_HTML_ALL) $(_DOC_POFILES)
427+
428+
429+################################################################################
430+## Clean
431+
432+.PHONY: clean-doc-omf clean-doc-dsk clean-doc-lc clean-doc-dir
433+
434+clean-doc-omf: ; rm -f $(_DOC_OMF_DB) $(_DOC_OMF_HTML)
435+clean-doc-dsk: ; rm -f $(_DOC_DSK_DB) $(_DOC_DSK_HTML)
436+clean-doc-lc:
437+ rm -f $(_DOC_LC_DOCS)
438+ rm -f $(_DOC_MOFILES)
439+ @list='$(_DOC_POFILES)'; for po in $$list; do \
440+ if ! test "$$po" -ef "$(srcdir)/$$po"; then \
441+ echo "rm -f $$po"; \
442+ rm -f "$$po"; \
443+ fi; \
444+ done
445+# .xml2.po.mo cleaning is obsolete as of 0.18.1 and could be removed in 0.20.x
446+ @for lc in C $(_DOC_REAL_LINGUAS); do \
447+ if test -f "$$lc/.xml2po.mo"; then \
448+ echo "rm -f $$lc/.xml2po.mo"; \
449+ rm -f "$$lc/.xml2po.mo"; \
450+ fi; \
451+ done
452+clean-doc-dir: clean-doc-lc
453+ @for lc in C $(_DOC_REAL_LINGUAS); do \
454+ for dir in `find $$lc -depth -type d`; do \
455+ if ! test $$dir -ef $(srcdir)/$$dir; then \
456+ echo "rmdir $$dir"; \
457+ rmdir "$$dir"; \
458+ fi; \
459+ done; \
460+ done
461+
462+_clean_omf = $(if $(_DOC_OMF_IN),clean-doc-omf)
463+_clean_dsk = $(if $(_DOC_DSK_IN),clean-doc-dsk)
464+_clean_lc = $(if $(_DOC_REAL_LINGUAS),clean-doc-lc)
465+_clean_dir = $(if $(DOC_MODULE)$(DOC_ID),clean-doc-dir)
466+
467+clean-local: \
468+ $(_clean_omf) $(_clean_dsk) \
469+ $(_clean_lc) $(_clean_dir)
470+distclean-local: \
471+ $(_clean_omf) $(_clean_dsk) \
472+ $(_clean_lc) $(_clean_dir)
473+mostlyclean-local: \
474+ $(_clean_omf) $(_clean_dsk) \
475+ $(_clean_lc) $(_clean_dir)
476+maintainer-clean-local: \
477+ $(_clean_omf) $(_clean_dsk) \
478+ $(_clean_lc) $(_clean_dir)
479+
480+
481+
482+################################################################################
483+## Dist
484+
485+.PHONY: dist-doc-docs dist-doc-pages dist-doc-figs dist-doc-omf dist-doc-dsk
486+doc-dist-hook: \
487+ $(if $(DOC_MODULE)$(DOC_ID),dist-doc-docs) \
488+ $(if $(_DOC_C_FIGURES),dist-doc-figs) \
489+ $(if $(_DOC_OMF_IN),dist-doc-omf)
490+# $(if $(_DOC_DSK_IN),dist-doc-dsk)
491+
492+dist-doc-docs: $(_DOC_C_DOCS) $(_DOC_LC_DOCS) $(_DOC_POFILES)
493+ @for lc in C $(_DOC_REAL_LINGUAS); do \
494+ echo " $(mkinstalldirs) $(distdir)/$$lc"; \
495+ $(mkinstalldirs) "$(distdir)/$$lc"; \
496+ done
497+ @list='$(_DOC_C_DOCS)'; \
498+ for doc in $$list; do \
499+ if test -f "$$doc"; then d=; else d="$(srcdir)/"; fi; \
500+ docdir=`echo $$doc | sed -e 's/^\(.*\/\).*/\1/' -e '/\//!s/.*//'`; \
501+ if ! test -d "$(distdir)/$$docdir"; then \
502+ echo "$(mkinstalldirs) $(distdir)/$$docdir"; \
503+ $(mkinstalldirs) "$(distdir)/$$docdir"; \
504+ fi; \
505+ echo "$(INSTALL_DATA) $$d$$doc $(distdir)/$$doc"; \
506+ $(INSTALL_DATA) "$$d$$doc" "$(distdir)/$$doc"; \
507+ done
508+ @list='$(_DOC_LC_DOCS)'; \
509+ for doc in $$list; do \
510+ if test -f "$$doc"; then d=; else d="$(srcdir)/"; fi; \
511+ docdir=`echo $$doc | sed -e 's/^\(.*\/\).*/\1/' -e '/\//!s/.*//'`; \
512+ if ! test -d "$(distdir)/$$docdir"; then \
513+ echo "$(mkinstalldirs) $(distdir)/$$docdir"; \
514+ $(mkinstalldirs) "$(distdir)/$$docdir"; \
515+ fi; \
516+ echo "$(INSTALL_DATA) $$d$$doc $(distdir)/$$doc"; \
517+ $(INSTALL_DATA) "$$d$$doc" "$(distdir)/$$doc"; \
518+ done
519+ @list='$(_DOC_POFILES)'; \
520+ for doc in $$list; do \
521+ if test -f "$$doc"; then d=; else d="$(srcdir)/"; fi; \
522+ docdir=`echo $$doc | sed -e 's/^\(.*\/\).*/\1/' -e '/\//!s/.*//'`; \
523+ if ! test -d "$(distdir)/$$docdir"; then \
524+ echo "$(mkinstalldirs) $(distdir)/$$docdir"; \
525+ $(mkinstalldirs) "$(distdir)/$$docdir"; \
526+ fi; \
527+ echo "$(INSTALL_DATA) $$d$$doc $(distdir)/$$doc"; \
528+ $(INSTALL_DATA) "$$d$$doc" "$(distdir)/$$doc"; \
529+ done
530+
531+dist-doc-figs: $(_DOC_SRC_FIGURES)
532+ @list='$(_DOC_C_FIGURES) $(_DOC_LC_FIGURES)'; \
533+ for fig in $$list; do \
534+ if test -f "$$fig"; then d=; else d="$(srcdir)/"; fi; \
535+ if test -f "$$d$$fig"; then \
536+ figdir=`echo $$fig | sed -e 's/^\(.*\/\).*/\1/' -e '/\//!s/.*//'`; \
537+ if ! test -d "$(distdir)/$$figdir"; then \
538+ echo "$(mkinstalldirs) $(distdir)/$$figdir"; \
539+ $(mkinstalldirs) "$(distdir)/$$figdir"; \
540+ fi; \
541+ echo "$(INSTALL_DATA) $$d$$fig $(distdir)/$$fig"; \
542+ $(INSTALL_DATA) "$$d$$fig" "$(distdir)/$$fig"; \
543+ fi; \
544+ done;
545+
546+dist-doc-omf:
547+ @if test -f "$(_DOC_OMF_IN)"; then d=; else d="$(srcdir)/"; fi; \
548+ echo "$(INSTALL_DATA) $$d$(_DOC_OMF_IN) $(distdir)/$(notdir $(_DOC_OMF_IN))"; \
549+ $(INSTALL_DATA) "$$d$(_DOC_OMF_IN)" "$(distdir)/$(notdir $(_DOC_OMF_IN))"
550+
551+dist-doc-dsk:
552+ @if test -f "$(_DOC_DSK_IN)"; then d=; else d="$(srcdir)/"; fi; \
553+ echo "$(INSTALL_DATA) $$d$(_DOC_DSK_IN) $(distdir)/$(notdir $(_DOC_DSK_IN))"; \
554+ $(INSTALL_DATA) "$$d$(_DOC_DSK_IN)" "$(distdir)/$(notdir $(_DOC_DSK_IN))"
555+
556+
557+
558+################################################################################
559+## Check
560+
561+.PHONY: check-doc-docs check-doc-omf
562+check: \
563+ $(if $(DOC_MODULE),check-doc-docs) \
564+ $(if $(DOC_ID),check-doc-pages) \
565+ $(if $(_DOC_OMF_IN),check-doc-omf)
566+
567+check-doc-docs: $(_DOC_C_DOCS) $(_DOC_LC_DOCS)
568+ @for lc in C $(_DOC_REAL_LINGUAS); do \
569+ if test -f "$$lc"; \
570+ then d=; \
571+ xmlpath="$$lc"; \
572+ else \
573+ d="$(srcdir)/"; \
574+ xmlpath="$$lc:$(srcdir)/$$lc"; \
575+ fi; \
576+ echo "xmllint --noout --noent --path $$xmlpath --xinclude --postvalid $$d$$lc/$(DOC_MODULE).xml"; \
577+ xmllint --noout --noent --path "$$xmlpath" --xinclude --postvalid "$$d$$lc/$(DOC_MODULE).xml"; \
578+ done
579+
580+check-doc-pages: $(_DOC_C_PAGES) $(_DOC_LC_PAGES)
581+ for lc in C $(_DOC_REAL_LINGUAS); do \
582+ if test -f "$$lc"; \
583+ then d=; \
584+ xmlpath="$$lc"; \
585+ else \
586+ d="$(srcdir)/"; \
587+ xmlpath="$$lc:$(srcdir)/$$lc"; \
588+ fi; \
589+ for page in $(DOC_PAGES); do \
590+ echo "xmllint --noout --noent --path $$xmlpath --xinclude $$d$$lc/$$page"; \
591+ xmllint --noout --noent --path "$$xmlpath" --xinclude "$$d$$lc/$$page"; \
592+ done; \
593+ done
594+
595+check-doc-omf: $(_DOC_OMF_ALL)
596+ @list='$(_DOC_OMF_ALL)'; for omf in $$list; do \
597+ echo "xmllint --noout --xinclude --dtdvalid 'http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/scrollkeeper-omf.dtd' $$omf"; \
598+ xmllint --noout --xinclude --dtdvalid 'http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/scrollkeeper-omf.dtd' $$omf; \
599+ done
600+
601+
602+
603+################################################################################
604+## Install
605+
606+.PHONY: install-doc-docs install-doc-html install-doc-figs install-doc-omf install-doc-dsk
607+
608+_doc_install_dir = $(if $(DOC_ID),$(DOC_ID),$(DOC_MODULE))
609+
610+install-data-local: \
611+ $(if $(DOC_MODULE)$(DOC_ID),install-doc-docs) \
612+ $(if $(_DOC_HTML_ALL),install-doc-html) \
613+ $(if $(_DOC_C_FIGURES),install-doc-figs) \
614+ $(if $(_DOC_OMF_IN),install-doc-omf)
615+# $(if $(_DOC_DSK_IN),install-doc-dsk)
616+
617+install-doc-docs:
618+ @for lc in C $(_DOC_REAL_LINGUAS); do \
619+ echo "$(mkinstalldirs) $(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$lc"; \
620+ $(mkinstalldirs) $(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$lc; \
621+ done
622+ @list='$(_DOC_C_DOCS)'; for doc in $$list; do \
623+ if test -f "$$doc"; then d=; else d="$(srcdir)/"; fi; \
624+ docdir="$$lc/"`echo $$doc | sed -e 's/^\(.*\/\).*/\1/' -e '/\//!s/.*//'`; \
625+ docdir="$(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$docdir"; \
626+ if ! test -d "$$docdir"; then \
627+ echo "$(mkinstalldirs) $$docdir"; \
628+ $(mkinstalldirs) "$$docdir"; \
629+ fi; \
630+ echo "$(INSTALL_DATA) $$d$$doc $(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$doc"; \
631+ $(INSTALL_DATA) $$d$$doc $(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$doc; \
632+ done
633+ @list='$(_DOC_LC_DOCS)'; for doc in $$list; do \
634+ if test -f "$$doc"; then d=; else d="$(srcdir)/"; fi; \
635+ docdir="$$lc/"`echo $$doc | sed -e 's/^\(.*\/\).*/\1/' -e '/\//!s/.*//'`; \
636+ docdir="$(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$docdir"; \
637+ if ! test -d "$$docdir"; then \
638+ echo "$(mkinstalldirs) $$docdir"; \
639+ $(mkinstalldirs) "$$docdir"; \
640+ fi; \
641+ echo "$(INSTALL_DATA) $$d$$doc $(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$doc"; \
642+ $(INSTALL_DATA) $$d$$doc $(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$doc; \
643+ done
644+
645+install-doc-figs:
646+ @list='$(patsubst C/%,%,$(_DOC_C_FIGURES))'; for fig in $$list; do \
647+ for lc in C $(_DOC_REAL_LINGUAS); do \
648+ figsymlink=false; \
649+ if test -f "$$lc/$$fig"; then \
650+ figfile="$$lc/$$fig"; \
651+ elif test -f "$(srcdir)/$$lc/$$fig"; then \
652+ figfile="$(srcdir)/$$lc/$$fig"; \
653+ else \
654+ figsymlink=true; \
655+ fi; \
656+ figdir="$$lc/"`echo $$fig | sed -e 's/^\(.*\/\).*/\1/' -e '/\//!s/.*//'`; \
657+ figdir="$(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$figdir"; \
658+ if ! test -d "$$figdir"; then \
659+ echo "$(mkinstalldirs) $$figdir"; \
660+ $(mkinstalldirs) "$$figdir"; \
661+ fi; \
662+ figbase=`echo $$fig | sed -e 's/^.*\///'`; \
663+ if $$figsymlink; then \
664+ echo "cd $$figdir && $(LN_S) -f ../../C/$$fig $$figbase"; \
665+ ( cd "$$figdir" && $(LN_S) -f "../../C/$$fig" "$$figbase" ); \
666+ else \
667+ echo "$(INSTALL_DATA) $$figfile $$figdir$$figbase"; \
668+ $(INSTALL_DATA) "$$figfile" "$$figdir$$figbase"; \
669+ fi; \
670+ done; \
671+ done
672+
673+install-doc-html:
674+ echo install-html
675+
676+install-doc-omf:
677+ $(mkinstalldirs) $(DESTDIR)$(OMF_DIR)/$(_doc_install_dir)
678+ @list='$(_DOC_OMF_ALL)'; for omf in $$list; do \
679+ echo "$(INSTALL_DATA) $$omf $(DESTDIR)$(OMF_DIR)/$(_doc_install_dir)/$$omf"; \
680+ $(INSTALL_DATA) $$omf $(DESTDIR)$(OMF_DIR)/$(_doc_install_dir)/$$omf; \
681+ done
682+ @if test "x$(_ENABLE_SK)" = "xtrue"; then \
683+ echo "scrollkeeper-update -p $(DESTDIR)$(_sklocalstatedir) -o $(DESTDIR)$(OMF_DIR)/$(_doc_install_dir)"; \
684+ scrollkeeper-update -p "$(DESTDIR)$(_sklocalstatedir)" -o "$(DESTDIR)$(OMF_DIR)/$(_doc_install_dir)"; \
685+ fi;
686+
687+install-doc-dsk:
688+ echo install-dsk
689+
690+
691+
692+################################################################################
693+## Uninstall
694+
695+.PHONY: uninstall-doc-docs uninstall-doc-html uninstall-doc-figs uninstall-doc-omf uninstall-doc-dsk
696+uninstall-local: \
697+ $(if $(DOC_MODULE)$(DOC_ID),uninstall-doc-docs) \
698+ $(if $(_DOC_HTML_ALL),uninstall-doc-html) \
699+ $(if $(_DOC_C_FIGURES),uninstall-doc-figs) \
700+ $(if $(_DOC_OMF_IN),uninstall-doc-omf)
701+# $(if $(_DOC_DSK_IN),uninstall-doc-dsk)
702+
703+uninstall-doc-docs:
704+ @list='$(_DOC_C_DOCS)'; for doc in $$list; do \
705+ echo " rm -f $(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$doc"; \
706+ rm -f "$(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$doc"; \
707+ done
708+ @list='$(_DOC_LC_DOCS)'; for doc in $$list; do \
709+ echo " rm -f $(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$doc"; \
710+ rm -f "$(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$doc"; \
711+ done
712+
713+uninstall-doc-figs:
714+ @list='$(_DOC_C_FIGURES) $(_DOC_LC_FIGURES)'; for fig in $$list; do \
715+ echo "rm -f $(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$fig"; \
716+ rm -f "$(DESTDIR)$(HELP_DIR)/$(_doc_install_dir)/$$fig"; \
717+ done;
718+
719+uninstall-doc-omf:
720+ @list='$(_DOC_OMF_ALL)'; for omf in $$list; do \
721+ if test "x$(_ENABLE_SK)" = "xtrue"; then \
722+ echo "scrollkeeper-uninstall -p $(_sklocalstatedir) $(DESTDIR)$(OMF_DIR)/$(_doc_install_dir)/$$omf"; \
723+ scrollkeeper-uninstall -p "$(_sklocalstatedir)" "$(DESTDIR)$(OMF_DIR)/$(_doc_install_dir)/$$omf"; \
724+ fi; \
725+ echo "rm -f $(DESTDIR)$(OMF_DIR)/$(_doc_install_dir)/$$omf"; \
726+ rm -f "$(DESTDIR)$(OMF_DIR)/$(_doc_install_dir)/$$omf"; \
727+ done
728--
7292.8.1
730
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
index 9be2ec10a..0f7cb59df 100644
--- a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
@@ -9,7 +9,7 @@ SECTION = "x11/gnome"
9 9
10PR = "r7" 10PR = "r7"
11 11
12DEPENDS = "gnome-doc-utils-native gconf glib-2.0 gnome-desktop gtk+ \ 12DEPENDS = "gnome-doc-utils gconf glib-2.0 gnome-desktop gtk+ \
13 pango libwnck gnome-menus cairo libgweather dbus dbus-glib \ 13 pango libwnck gnome-menus cairo libgweather dbus dbus-glib \
14 librsvg libcanberra" 14 librsvg libcanberra"
15RDEPENDS_${PN} = "python" 15RDEPENDS_${PN} = "python"
@@ -19,6 +19,7 @@ inherit gtk-doc gnome autotools-brokensep gettext pkgconfig gconf gobject-intros
19SRCREV = "8292bd2b8a36df7eed3c760899400790cde68590" 19SRCREV = "8292bd2b8a36df7eed3c760899400790cde68590"
20SRC_URI = "git://git.gnome.org/gnome-panel;branch=gnome-2-32 \ 20SRC_URI = "git://git.gnome.org/gnome-panel;branch=gnome-2-32 \
21 file://0001-Fix-build-with-gcc-5.patch \ 21 file://0001-Fix-build-with-gcc-5.patch \
22 file://0001-Add-gnome-doc-utils.make.patch \
22 " 23 "
23 24
24S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
@@ -29,7 +30,6 @@ PACKAGECONFIG ??= ""
29PACKAGECONFIG[networkmanager] = "--enable-network-manager,--disable-network-manager,networkmanager" 30PACKAGECONFIG[networkmanager] = "--enable-network-manager,--disable-network-manager,networkmanager"
30 31
31do_configure_prepend() { 32do_configure_prepend() {
32 gnome-doc-prepare --automake
33 sed -i -e s:help:: ${S}/Makefile.am 33 sed -i -e s:help:: ${S}/Makefile.am
34 sed -i -e s:^#!@PYTHON@:#!/usr/bin/python: ${S}/gnome-panel/gnome-panel-add.in 34 sed -i -e s:^#!@PYTHON@:#!/usr/bin/python: ${S}/gnome-panel/gnome-panel-add.in
35} 35}