summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-21 11:12:51 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-21 12:55:35 +0200
commitd3a738c4375dba1c89c64a88ade5262d38a9cf5e (patch)
treeb5811ee7084c023948a5f345ed49b2419f4bddb6 /meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
parentecdd1c6f0ffec1e67b97d05b00bf680a0b3330f1 (diff)
downloadmeta-openembedded-d3a738c4375dba1c89c64a88ade5262d38a9cf5e.tar.gz
gnome-panel: update to 2.32.x from the git release branch
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
new file mode 100644
index 000000000..738b51a8b
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "GNOME panel"
2LICENSE = "GPLv2 && LGPLv2 && GFDLv1.1"
3
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://COPYING-DOCS;md5=c9211dab3ae61e580f48432020784324 \
6 file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8SECTION = "x11/gnome"
9
10PR = "r4"
11
12DEPENDS = "gnome-doc-utils-native gconf glib-2.0 gnome-desktop gtk+ pango libwnck gnome-menus cairo libgweather dbus-glib librsvg libcanberra"
13
14inherit gtk-doc gnome pkgconfig
15
16SRCREV = "6a364b6a4a9beed3da9ca6f5b0dac81eb99dea2a"
17SRC_URI = "git://git.gnome.org/gnome-panel;branch=gnome-2-32"
18
19S = "${WORKDIR}/git"
20
21EXTRA_OECONF = "--disable-scrollkeeper --disable-eds --enable-bonobo=no --with-in-process-applets=none"
22
23do_configure_prepend() {
24 gnome-doc-prepare --automake
25 sed -i -e s:help:: ${S}/Makefile.am
26}
27
28pkg_postinst_append () {
29 gconftool-2 --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults \
30 --direct --load /etc/gconf/schemas/panel-default-setup.entries
31}
32
33PACKAGES =+ "libpanel-applet"
34FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
35
36FILES_${PN} =+ "${datadir}/gnome* \
37 ${datadir}/dbus-1 \
38 ${datadir}/icons \
39 ${datadir}/PolicyKit \
40 ${libdir}/bonobo \
41 "
42
43