diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2022-04-13 00:26:37 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-04-13 19:21:41 -0700 |
commit | a89b57aa45b08c1b90b9d46b0ff97fea6b65a7be (patch) | |
tree | 44bdfab6cf1e6cd432f5f7c6bd35f1c5ff4c207e /meta-gnome/recipes-gnome/gnome-bluetooth | |
parent | 6f5d694d9c328a9d8e0bd927d569714cd75597b7 (diff) | |
download | meta-openembedded-a89b57aa45b08c1b90b9d46b0ff97fea6b65a7be.tar.gz |
gnome-bluetooth: rename recipes to avoid suffix in future
We have two gnome-bluetooths:
* 3.34.5: This will deprecate so add suffix and name it gnome-bluetooth3
* 42.0: This is the future of gnome-bluetooth so name it as such
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-bluetooth')
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3/0001-build-Fix-build-for-newer-versions-of-meson.patch (renamed from meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-build-Fix-build-for-newer-versions-of-meson.patch) | 0 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3_3.34.5.bb (renamed from meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.34.5.bb) | 10 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.0.bb (renamed from meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth4_42.0.bb) | 7 |
3 files changed, 10 insertions, 7 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-build-Fix-build-for-newer-versions-of-meson.patch b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3/0001-build-Fix-build-for-newer-versions-of-meson.patch index 16c87b6a6..16c87b6a6 100644 --- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-build-Fix-build-for-newer-versions-of-meson.patch +++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3/0001-build-Fix-build-for-newer-versions-of-meson.patch | |||
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.34.5.bb b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3_3.34.5.bb index 7b74c76f9..e2a885b1f 100644 --- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.34.5.bb +++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3_3.34.5.bb | |||
@@ -8,6 +8,9 @@ SECTION = "x11/gnome" | |||
8 | 8 | ||
9 | DEPENDS = "udev gtk+3 libnotify libcanberra bluez5" | 9 | DEPENDS = "udev gtk+3 libnotify libcanberra bluez5" |
10 | 10 | ||
11 | GNOMEBN = "gnome-bluetooth" | ||
12 | S = "${WORKDIR}/${GNOMEBN}-${PV}" | ||
13 | |||
11 | GNOMEBASEBUILDCLASS = "meson" | 14 | GNOMEBASEBUILDCLASS = "meson" |
12 | GTKDOC_MESON_OPTION = "gtk_doc" | 15 | GTKDOC_MESON_OPTION = "gtk_doc" |
13 | 16 | ||
@@ -22,13 +25,16 @@ SRC_URI += " file://0001-build-Fix-build-for-newer-versions-of-meson.patch" | |||
22 | SRC_URI[archive.md5sum] = "d83faa54abaf64bb40b5313bc233e74e" | 25 | SRC_URI[archive.md5sum] = "d83faa54abaf64bb40b5313bc233e74e" |
23 | SRC_URI[archive.sha256sum] = "6c949e52c8becc2054daacd604901f66ce5cf709a5fa91c4bb7cacc939b53ea9" | 26 | SRC_URI[archive.sha256sum] = "6c949e52c8becc2054daacd604901f66ce5cf709a5fa91c4bb7cacc939b53ea9" |
24 | 27 | ||
25 | # avoid clashes with gnome-bluetooth4 | 28 | # avoid clashes with gnome-bluetooth |
26 | do_install:append() { | 29 | do_install:append() { |
27 | # just bluetooth-sendto / bluetooth-sendto.desktop only | 30 | # just bluetooth-sendto / bluetooth-sendto.desktop only |
28 | rm -rf ${D}${bindir} | 31 | rm -rf ${D}${bindir} |
29 | rm -rf ${D}${datadir}/applications | 32 | rm -rf ${D}${datadir}/applications |
30 | } | 33 | } |
34 | |||
35 | FILES:${PN} += "${datadir}/gnome-bluetooth" | ||
36 | |||
31 | # offer alternate bluetooth-sendto | 37 | # offer alternate bluetooth-sendto |
32 | RRECOMMENS:${PN} += "gnome-bluetooth4" | 38 | RRECOMMENS:${PN} += "gnome-bluetooth" |
33 | 39 | ||
34 | RDEPENDS:${PN} += "bluez5" | 40 | RDEPENDS:${PN} += "bluez5" |
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth4_42.0.bb b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.0.bb index 3fe2c35ef..a9b7bdec0 100644 --- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth4_42.0.bb +++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.0.bb | |||
@@ -18,9 +18,6 @@ DEPENDS = " \ | |||
18 | libadwaita \ | 18 | libadwaita \ |
19 | " | 19 | " |
20 | 20 | ||
21 | GNOMEBN = "gnome-bluetooth" | ||
22 | S = "${WORKDIR}/${GNOMEBN}-${PV}" | ||
23 | |||
24 | GNOMEBASEBUILDCLASS = "meson" | 21 | GNOMEBASEBUILDCLASS = "meson" |
25 | GTKDOC_MESON_OPTION = "gtk_doc" | 22 | GTKDOC_MESON_OPTION = "gtk_doc" |
26 | GTKIC_VERSION = "4" | 23 | GTKIC_VERSION = "4" |
@@ -31,6 +28,6 @@ REQUIRED_DISTRO_FEATURES = "x11" | |||
31 | 28 | ||
32 | SRC_URI[archive.sha256sum] = "3d1e2720673bc9a242619dc5d231fd6e776c18a49da29f43cdc433055adb0170" | 29 | SRC_URI[archive.sha256sum] = "3d1e2720673bc9a242619dc5d231fd6e776c18a49da29f43cdc433055adb0170" |
33 | 30 | ||
34 | RDEPENDS:${PN} += "bluez5" | ||
35 | |||
36 | FILES:${PN} += "${datadir}/gnome-bluetooth-3.0" | 31 | FILES:${PN} += "${datadir}/gnome-bluetooth-3.0" |
32 | |||
33 | RDEPENDS:${PN} += "bluez5" | ||