diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-05-15 15:45:17 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-19 09:37:34 +0200 |
commit | 9c657f0e6975a283fcc8f3b748c006882fab961a (patch) | |
tree | fdb08fbf7d465e4f21989c30f974c10186886383 /meta-gnome/recipes-gnome/gnome-bluetooth | |
parent | 708ceaee5e0b5619fb66bf8c934fb5d5e938e308 (diff) | |
download | meta-openembedded-9c657f0e6975a283fcc8f3b748c006882fab961a.tar.gz |
gnome-bluetooth: Fix build erorrs found with gcc 4.8
Fix errors like below
| bluetooth-input.c:193:4: error: format '%d' expects argument of type
'int', but argument 5 has type 'XID' [-Werror=format=]
| g_message ("has mouse: %s (id = %d)", device_info[i].name,
device_info[i].id);
| ^
| bluetooth-input.c:198:4: error: format '%d' expects argument of type
'int', but argument 5 has type 'XID' [-Werror=format=]
| g_message ("has keyboard: %s (id = %d)", device_info[i].name,
device_info[i].id);
| ^
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-bluetooth')
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-bluetooth-input-Fix-compile-errors.patch | 37 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb | 2 |
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-bluetooth-input-Fix-compile-errors.patch b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-bluetooth-input-Fix-compile-errors.patch new file mode 100644 index 000000000..0b0cf8b6e --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-bluetooth-input-Fix-compile-errors.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From e3c789d6dca9a8a99b60b86e28d8119c55253c13 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 15 May 2013 08:37:03 -0700 | ||
4 | Subject: [PATCH] bluetooth-input: Fix compile errors | ||
5 | |||
6 | XID is unsigned long type so %d will error out with -Wformat | ||
7 | where format warnings are being treated at errors | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | |||
11 | Upstream-Status: Unknown | ||
12 | --- | ||
13 | wizard/bluetooth-input.c | 4 ++-- | ||
14 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/wizard/bluetooth-input.c b/wizard/bluetooth-input.c | ||
17 | index b3fbdaf..d17e67c 100644 | ||
18 | --- a/wizard/bluetooth-input.c | ||
19 | +++ b/wizard/bluetooth-input.c | ||
20 | @@ -190,12 +190,12 @@ bluetooth_input_check_for_devices (BluetoothInput *input) | ||
21 | if (bluetooth_input_device_get_type (&device_info[i], &is_mouse, &is_keyboard) == FALSE) | ||
22 | continue; | ||
23 | if (is_mouse != FALSE) { | ||
24 | - g_message ("has mouse: %s (id = %d)", device_info[i].name, device_info[i].id); | ||
25 | + g_message ("has mouse: %s (id = %lu)", device_info[i].name, device_info[i].id); | ||
26 | has_mouse = TRUE; | ||
27 | //break; | ||
28 | } | ||
29 | if (is_keyboard != FALSE) { | ||
30 | - g_message ("has keyboard: %s (id = %d)", device_info[i].name, device_info[i].id); | ||
31 | + g_message ("has keyboard: %s (id = %lu)", device_info[i].name, device_info[i].id); | ||
32 | has_keyboard = TRUE; | ||
33 | //break; | ||
34 | } | ||
35 | -- | ||
36 | 1.7.9.5 | ||
37 | |||
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb index a2037cff0..00ac3f872 100644 --- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb +++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb | |||
@@ -11,6 +11,8 @@ DEPENDS = "obexd gnome-doc-utils-native gnome-doc-utils gconf gtk+ dbus-glib lib | |||
11 | 11 | ||
12 | inherit gnome | 12 | inherit gnome |
13 | 13 | ||
14 | SRC_URI += "file://0001-bluetooth-input-Fix-compile-errors.patch \ | ||
15 | " | ||
14 | SRC_URI[archive.md5sum] = "f129686fe46c4c98eb70a0cc85d59cae" | 16 | SRC_URI[archive.md5sum] = "f129686fe46c4c98eb70a0cc85d59cae" |
15 | SRC_URI[archive.sha256sum] = "57b1f06c96a1b85e1c19ff919d708cc38e95edae658881ed99968c325839a973" | 17 | SRC_URI[archive.sha256sum] = "57b1f06c96a1b85e1c19ff919d708cc38e95edae658881ed99968c325839a973" |
16 | 18 | ||