summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-bluetooth
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-02-12 11:07:53 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-19 10:09:59 +0100
commiteaa248e369b5445e41e895e6894d6e2a47c917a2 (patch)
tree6e889faab113da9fa72c2399bce438c93876e35b /meta-gnome/recipes-gnome/gnome-bluetooth
parentd2d6fa93dda0f2a1ac6334b2e7f22bbe092881e4 (diff)
downloadmeta-openembedded-eaa248e369b5445e41e895e6894d6e2a47c917a2.tar.gz
gnome-bluetooth: fix build by using a valid dbus interface + unblacklist
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-bluetooth')
-rw-r--r--meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0002-bluetooth-client-use-valid-interface-names.patch122
-rw-r--r--meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb8
2 files changed, 126 insertions, 4 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0002-bluetooth-client-use-valid-interface-names.patch b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0002-bluetooth-client-use-valid-interface-names.patch
new file mode 100644
index 000000000..99049a0ca
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0002-bluetooth-client-use-valid-interface-names.patch
@@ -0,0 +1,122 @@
1From 1555f85b222db0d536efe277d31b57b2a8b938f4 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Thu, 12 Feb 2015 01:19:41 +0100
4Subject: [PATCH] bluetooth-client: use valid interface names
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Inappropriate[version unmaintained upstream]
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 lib/bluetooth-client.c | 12 ++++++------
14 lib/bluetooth-client.xml | 6 +++---
15 lib/test-agent.c | 2 +-
16 3 files changed, 10 insertions(+), 10 deletions(-)
17
18diff --git a/lib/bluetooth-client.c b/lib/bluetooth-client.c
19index d62d56d..02e194c 100644
20--- a/lib/bluetooth-client.c
21+++ b/lib/bluetooth-client.c
22@@ -721,7 +721,7 @@ static void add_device(DBusGProxy *adapter, GtkTreeIter *parent,
23 BLUEZ_DEVICE_INTERFACE, path);
24
25 if (device != NULL)
26- device_get_properties(device, &hash, NULL);
27+ org_bluez_device_get_properties(device, &hash, NULL);
28 } else
29 device = NULL;
30
31@@ -945,7 +945,7 @@ static void adapter_added(DBusGProxy *manager,
32 adapter = dbus_g_proxy_new_from_proxy(manager,
33 BLUEZ_ADAPTER_INTERFACE, path);
34
35- adapter_get_properties(adapter, &hash, NULL);
36+ org_bluez_adapter_get_properties(adapter, &hash, NULL);
37 if (hash != NULL) {
38 value = g_hash_table_lookup(hash, "Address");
39 address = value ? g_value_get_string(value) : NULL;
40@@ -1178,7 +1178,7 @@ static void bluetooth_client_init(BluetoothClient *client)
41 dbus_g_proxy_connect_signal(priv->manager, "DefaultAdapterChanged",
42 G_CALLBACK(default_adapter_changed), client, NULL);
43
44- manager_list_adapters(priv->manager, &array, NULL);
45+ org_bluez_manager_list_adapters(priv->manager, &array, NULL);
46 if (array != NULL) {
47 int i;
48
49@@ -1189,7 +1189,7 @@ static void bluetooth_client_init(BluetoothClient *client)
50 }
51 }
52
53- manager_default_adapter(priv->manager, &default_path, NULL);
54+ org_bluez_manager_default_adapter(priv->manager, &default_path, NULL);
55 if (default_path != NULL) {
56 default_adapter_changed(priv->manager, default_path, client);
57 g_free(default_path);
58@@ -1541,7 +1541,7 @@ gboolean bluetooth_client_start_discovery(BluetoothClient *client)
59 if (adapter == NULL)
60 return FALSE;
61
62- adapter_start_discovery(adapter, NULL);
63+ org_bluez_adapter_start_discovery(adapter, NULL);
64
65 g_object_unref(adapter);
66
67@@ -1568,7 +1568,7 @@ gboolean bluetooth_client_stop_discovery(BluetoothClient *client)
68 if (adapter == NULL)
69 return FALSE;
70
71- adapter_stop_discovery(adapter, NULL);
72+ org_bluez_adapter_stop_discovery(adapter, NULL);
73
74 g_object_unref(adapter);
75
76diff --git a/lib/bluetooth-client.xml b/lib/bluetooth-client.xml
77index 2326277..38c7fb0 100644
78--- a/lib/bluetooth-client.xml
79+++ b/lib/bluetooth-client.xml
80@@ -1,7 +1,7 @@
81 <?xml version="1.0" encoding="UTF-8" ?>
82
83 <node name="/">
84- <interface name="manager">
85+ <interface name="org.bluez.manager">
86 <method name="DefaultAdapter">
87 <arg type="o" direction="out"/>
88 </method>
89@@ -16,7 +16,7 @@
90 </method>
91 </interface>
92
93- <interface name="adapter">
94+ <interface name="org.bluez.adapter">
95 <method name="GetProperties">
96 <arg type="a{sv}" direction="out"/>
97 </method>
98@@ -44,7 +44,7 @@
99 </method>
100 </interface>
101
102- <interface name="device">
103+ <interface name="org.bluez.device">
104 <method name="GetProperties">
105 <arg type="a{sv}" direction="out"/>
106 </method>
107diff --git a/lib/test-agent.c b/lib/test-agent.c
108index 8d60da6..83464eb 100644
109--- a/lib/test-agent.c
110+++ b/lib/test-agent.c
111@@ -40,7 +40,7 @@ static gboolean agent_pincode(DBusGMethodInvocation *context,
112 GValue *value;
113 const gchar *address, *name;
114
115- device_get_properties(device, &hash, NULL);
116+ org_bluez_device_get_properties(device, &hash, NULL);
117
118 if (hash != NULL) {
119 value = g_hash_table_lookup(hash, "Address");
120--
1211.9.3
122
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb
index b9b73551d..8711b8af0 100644
--- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb
@@ -6,15 +6,15 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
6 6
7PR = "r1" 7PR = "r1"
8 8
9PNBLACKLIST[gnome-bluetooth] ?= "dbus-binding-tool fails with: Unable to load gnome-bluetooth-2.32.0/lib/bluetooth-client.xml": "manager" is not a valid D-Bus interface name"
10
11SECTION = "x11/gnome" 9SECTION = "x11/gnome"
12DEPENDS = "obexd gnome-doc-utils-native gnome-doc-utils gconf gtk+ dbus-glib libunique libnotify bluez4 gnome-keyring virtual/libx11 libxi intltool-native" 10DEPENDS = "obexd gnome-doc-utils-native gnome-doc-utils gconf gtk+ dbus-glib libunique libnotify bluez4 gnome-keyring virtual/libx11 libxi intltool-native"
13 11
14inherit gnomebase gtk-icon-cache 12inherit gnomebase gtk-icon-cache
15 13
16SRC_URI += "file://0001-bluetooth-input-Fix-compile-errors.patch \ 14SRC_URI += " \
17 " 15 file://0001-bluetooth-input-Fix-compile-errors.patch \
16 file://0002-bluetooth-client-use-valid-interface-names.patch \
17"
18SRC_URI[archive.md5sum] = "f129686fe46c4c98eb70a0cc85d59cae" 18SRC_URI[archive.md5sum] = "f129686fe46c4c98eb70a0cc85d59cae"
19SRC_URI[archive.sha256sum] = "57b1f06c96a1b85e1c19ff919d708cc38e95edae658881ed99968c325839a973" 19SRC_URI[archive.sha256sum] = "57b1f06c96a1b85e1c19ff919d708cc38e95edae658881ed99968c325839a973"
20 20