diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2021-05-10 20:23:59 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-05-11 08:27:27 -0700 |
commit | 313b98f73c0e0281f86aafe658903a8d7d9daaa1 (patch) | |
tree | 9b7a715d42894933452731e0f2ef3b7fa6cd424c /meta-gnome/recipes-gnome/evolution-data-server | |
parent | 259e6d305adfa3adcd34e36b855e01c824b5d588 (diff) | |
download | meta-openembedded-313b98f73c0e0281f86aafe658903a8d7d9daaa1.tar.gz |
evolution-data-server: Backport upstream patch to fix configure on latest CMake
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/evolution-data-server')
2 files changed, 68 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb index 7f267b497..e2d7f502b 100644 --- a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb +++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb | |||
@@ -16,6 +16,7 @@ SRC_URI += " \ | |||
16 | file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \ | 16 | file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \ |
17 | file://0004-call-native-helpers.patch \ | 17 | file://0004-call-native-helpers.patch \ |
18 | file://iconv-detect.h \ | 18 | file://iconv-detect.h \ |
19 | file://0005-PrintableOptions.cmake-Correct-variable-name-compari.patch \ | ||
19 | " | 20 | " |
20 | 21 | ||
21 | LKSTRFTIME = "HAVE_LKSTRFTIME=ON" | 22 | LKSTRFTIME = "HAVE_LKSTRFTIME=ON" |
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0005-PrintableOptions.cmake-Correct-variable-name-compari.patch b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0005-PrintableOptions.cmake-Correct-variable-name-compari.patch new file mode 100644 index 000000000..d84b41d00 --- /dev/null +++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0005-PrintableOptions.cmake-Correct-variable-name-compari.patch | |||
@@ -0,0 +1,67 @@ | |||
1 | From c95a70bfeae25ba11fbe50fe759a6cdb29388e44 Mon Sep 17 00:00:00 2001 | ||
2 | From: Milan Crha <mcrha@redhat.com> | ||
3 | Date: Wed, 14 Apr 2021 16:58:08 +0200 | ||
4 | Subject: [PATCH] PrintableOptions.cmake: Correct variable name comparison | ||
5 | |||
6 | CMake 3.20.1 errors out with: | ||
7 | |||
8 | CMake Error at cmake/modules/PrintableOptions.cmake:38 (message): | ||
9 | variable name cannot be empty | ||
10 | Call Stack (most recent call first): | ||
11 | CMakeLists.txt:152 (add_printable_variable) | ||
12 | |||
13 | Change how the parameter value is compared, to fix it. | ||
14 | |||
15 | Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/c95a70bfeae25ba11fbe50fe759a6cdb29388e44] | ||
16 | --- | ||
17 | cmake/modules/PrintableOptions.cmake | 16 ++++++++-------- | ||
18 | 1 file changed, 8 insertions(+), 8 deletions(-) | ||
19 | |||
20 | diff --git a/cmake/modules/PrintableOptions.cmake b/cmake/modules/PrintableOptions.cmake | ||
21 | index a79419a..c74531a 100644 | ||
22 | --- a/cmake/modules/PrintableOptions.cmake | ||
23 | +++ b/cmake/modules/PrintableOptions.cmake | ||
24 | @@ -19,32 +19,32 @@ | ||
25 | # prints all the build options previously added with the above functions | ||
26 | |||
27 | macro(add_printable_variable_bare _name) | ||
28 | - if(_name STREQUAL "") | ||
29 | + if("${_name}" STREQUAL "") | ||
30 | message(FATAL_ERROR "variable name cannot be empty") | ||
31 | - endif(_name STREQUAL "") | ||
32 | + endif("${_name}" STREQUAL "") | ||
33 | list(APPEND _printable_options ${_name}) | ||
34 | endmacro() | ||
35 | |||
36 | macro(add_printable_option _name _description _default_value) | ||
37 | - if(_name STREQUAL "") | ||
38 | + if("${_name}" STREQUAL "") | ||
39 | message(FATAL_ERROR "option name cannot be empty") | ||
40 | - endif(_name STREQUAL "") | ||
41 | + endif("${_name}" STREQUAL "") | ||
42 | option(${_name} ${_description} ${_default_value}) | ||
43 | add_printable_variable_bare(${_name}) | ||
44 | endmacro() | ||
45 | |||
46 | macro(add_printable_variable _name _description _default_value) | ||
47 | - if(_name STREQUAL "") | ||
48 | + if("${_name}" STREQUAL "") | ||
49 | message(FATAL_ERROR "variable name cannot be empty") | ||
50 | - endif(_name STREQUAL "") | ||
51 | + endif("${_name}" STREQUAL "") | ||
52 | set(${_name} ${_default_value} CACHE STRING ${_description}) | ||
53 | add_printable_variable_bare(${_name}) | ||
54 | endmacro() | ||
55 | |||
56 | macro(add_printable_variable_path _name _description _default_value) | ||
57 | - if(_name STREQUAL "") | ||
58 | + if("${_name}" STREQUAL "") | ||
59 | message(FATAL_ERROR "path variable name cannot be empty") | ||
60 | - endif(_name STREQUAL "") | ||
61 | + endif("${_name}" STREQUAL "") | ||
62 | set(${_name} ${_default_value} CACHE PATH ${_description}) | ||
63 | add_printable_variable_bare(${_name}) | ||
64 | endmacro() | ||
65 | -- | ||
66 | 2.30.2 | ||
67 | |||