diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-05-05 23:17:59 -0700 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-05-17 08:19:22 -0700 |
commit | 6cb102d0efc2955af39e249bacbf8c7c2d099684 (patch) | |
tree | 05bb8f9e5d7237a6397c03ab549c4f4281e58c5a /meta-gnome/recipes-gnome/eds | |
parent | e59a9738c24ccaeac91740d1f67c607d4ee2a217 (diff) | |
download | meta-openembedded-6cb102d0efc2955af39e249bacbf8c7c2d099684.tar.gz |
evolution-data-server: Update to 3.26.6 and fix build with icu 61
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/eds')
-rw-r--r-- | meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Use-recommended-way-to-handle-the-icu-namespace.patch | 46 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.6.bb (renamed from meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.3.bb) | 17 |
2 files changed, 55 insertions, 8 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Use-recommended-way-to-handle-the-icu-namespace.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Use-recommended-way-to-handle-the-icu-namespace.patch new file mode 100644 index 000000000..d3b0ac673 --- /dev/null +++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Use-recommended-way-to-handle-the-icu-namespace.patch | |||
@@ -0,0 +1,46 @@ | |||
1 | From 698a0e104dcbe4b630df848fd4af7c59f76cdc37 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 5 May 2018 17:46:52 -0700 | ||
4 | Subject: [PATCH] Use recommended way to handle the icu namespace | ||
5 | |||
6 | Fixes build with icu >= 61 | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | src/libedataserver/e-alphabet-index-private.cpp | 2 ++ | ||
13 | src/libedataserver/e-transliterator-private.cpp | 2 ++ | ||
14 | 2 files changed, 4 insertions(+) | ||
15 | |||
16 | diff --git a/src/libedataserver/e-alphabet-index-private.cpp b/src/libedataserver/e-alphabet-index-private.cpp | ||
17 | index d3e44f4..ddffd99 100644 | ||
18 | --- a/src/libedataserver/e-alphabet-index-private.cpp | ||
19 | +++ b/src/libedataserver/e-alphabet-index-private.cpp | ||
20 | @@ -33,9 +33,11 @@ | ||
21 | |||
22 | /* ICU headers */ | ||
23 | #include <unicode/alphaindex.h> | ||
24 | +#include <unicode/ustring.h> | ||
25 | |||
26 | using icu::AlphabeticIndex; | ||
27 | using icu::Locale; | ||
28 | +using U_ICU_NAMESPACE::UnicodeString; | ||
29 | |||
30 | struct _EAlphabetIndex { | ||
31 | AlphabeticIndex *priv; | ||
32 | diff --git a/src/libedataserver/e-transliterator-private.cpp b/src/libedataserver/e-transliterator-private.cpp | ||
33 | index bb15593..573446f 100644 | ||
34 | --- a/src/libedataserver/e-transliterator-private.cpp | ||
35 | +++ b/src/libedataserver/e-transliterator-private.cpp | ||
36 | @@ -33,8 +33,10 @@ | ||
37 | |||
38 | /* ICU headers */ | ||
39 | #include <unicode/translit.h> | ||
40 | +#include <unicode/ustring.h> | ||
41 | |||
42 | using icu::Transliterator; | ||
43 | +using U_ICU_NAMESPACE::UnicodeString; | ||
44 | |||
45 | struct _ETransliterator { | ||
46 | Transliterator *priv; | ||
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.3.bb b/meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.6.bb index 2303b8f18..db5dca95b 100644 --- a/meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.3.bb +++ b/meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.6.bb | |||
@@ -18,14 +18,15 @@ inherit distro_features_check gnomebase cmake gtk-doc gettext gobject-introspect | |||
18 | 18 | ||
19 | REQUIRED_DISTRO_FEATURES = "x11" | 19 | REQUIRED_DISTRO_FEATURES = "x11" |
20 | 20 | ||
21 | SRC_URI += " \ | 21 | SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \ |
22 | file://0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch \ | 22 | file://0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch \ |
23 | file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \ | 23 | file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \ |
24 | file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \ | 24 | file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \ |
25 | file://iconv-detect.h \ | 25 | file://iconv-detect.h \ |
26 | " | 26 | file://0004-Use-recommended-way-to-handle-the-icu-namespace.patch \ |
27 | SRC_URI[archive.md5sum] = "568a21a4df4e0ec985c849b38fc66908" | 27 | " |
28 | SRC_URI[archive.sha256sum] = "63b1ae5f76be818862f455bf841b5ebb1ec3e1f4df6d3a16dc2be348b7e0a1c5" | 28 | SRC_URI[archive.md5sum] = "ae7bbf543b2c3ff79af27e0edea5d472" |
29 | SRC_URI[archive.sha256sum] = "e43aa1847ddc02965f560261ef88d18fb8704eddaa55555bf96b884a33e510ec" | ||
29 | 30 | ||
30 | LKSTRFTIME = "HAVE_LKSTRFTIME=ON" | 31 | LKSTRFTIME = "HAVE_LKSTRFTIME=ON" |
31 | LKSTRFTIME_libc-musl = "HAVE_LKSTRFTIME=OFF" | 32 | LKSTRFTIME_libc-musl = "HAVE_LKSTRFTIME=OFF" |