summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/devilspie
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-gnome/recipes-gnome/devilspie
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/devilspie')
-rw-r--r--meta-gnome/recipes-gnome/devilspie/devilspie2_0.24.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta-gnome/recipes-gnome/devilspie/devilspie2_0.24.bb b/meta-gnome/recipes-gnome/devilspie/devilspie2_0.24.bb
index 05311fd54..9e6ba9042 100644
--- a/meta-gnome/recipes-gnome/devilspie/devilspie2_0.24.bb
+++ b/meta-gnome/recipes-gnome/devilspie/devilspie2_0.24.bb
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=00aefaa50aad75c21367df66102d542c \
7DEPENDS = "gtk+ glib-2.0 libwnck lua5.1 virtual/libx11" 7DEPENDS = "gtk+ glib-2.0 libwnck lua5.1 virtual/libx11"
8 8
9SRC_URI = " \ 9SRC_URI = " \
10 http://www.gusnan.se/devilspie2/download/devilspie2_${PV}-src.tar.gz \ 10 http://www.gusnan.se/devilspie2/download/devilspie2_${PV}-src.tar.gz \
11 file://default.lua \ 11 file://default.lua \
12 file://devilspie2.desktop \ 12 file://devilspie2.desktop \
13" 13"
14SRC_URI[md5sum] = "90b354662659e2922bd051fdde3b0971" 14SRC_URI[md5sum] = "90b354662659e2922bd051fdde3b0971"
15SRC_URI[sha256sum] = "9c94fa13ed8c0bf6914fdda513e21a4bd527821b97a53d8004168a8d465a646a" 15SRC_URI[sha256sum] = "9c94fa13ed8c0bf6914fdda513e21a4bd527821b97a53d8004168a8d465a646a"
@@ -17,14 +17,14 @@ SRC_URI[sha256sum] = "9c94fa13ed8c0bf6914fdda513e21a4bd527821b97a53d8004168a8d46
17inherit pkgconfig 17inherit pkgconfig
18 18
19do_compile() { 19do_compile() {
20 export GTK2=1 20 export GTK2=1
21 oe_runmake CC="${CC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS=" -ldl -lm ${LDFLAGS}" 21 oe_runmake CC="${CC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS=" -ldl -lm ${LDFLAGS}"
22} 22}
23 23
24do_install() { 24do_install() {
25 oe_runmake DESTDIR="${D}" PREFIX="${prefix}" install 25 oe_runmake DESTDIR="${D}" PREFIX="${prefix}" install
26 install -d ${D}/${sysconfdir}/devilspie2 26 install -d ${D}/${sysconfdir}/devilspie2
27 install -m 644 ${WORKDIR}/default.lua ${D}/${sysconfdir}/devilspie2 27 install -m 644 ${WORKDIR}/default.lua ${D}/${sysconfdir}/devilspie2
28 install -d ${D}/${sysconfdir}/xdg/autostart 28 install -d ${D}/${sysconfdir}/xdg/autostart
29 install -m 644 ${WORKDIR}/devilspie2.desktop ${D}/${sysconfdir}/xdg/autostart 29 install -m 644 ${WORKDIR}/devilspie2.desktop ${D}/${sysconfdir}/xdg/autostart
30} 30}