diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-04-21 20:09:00 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-04-21 20:09:13 +0200 |
commit | dcb014c8fab65e9dd15c97904395ac46d8451419 (patch) | |
tree | 49d8bf85782328007ab5d902fd9eae41d71c028b /meta-gnome/recipes-gnome/abiword | |
parent | 111a652bb6631045720bab2947fd798f95bac176 (diff) | |
download | meta-openembedded-dcb014c8fab65e9dd15c97904395ac46d8451419.tar.gz |
abiword*: import from oe-core rev 0a6f77f549c095692045825f4b5c4c5a2edff73c
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/abiword')
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword-2.5.inc | 63 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword-embedded_2.5.2.bb | 12 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword.inc | 63 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword_2.5.2.bb | 5 |
4 files changed, 143 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword-2.5.inc b/meta-gnome/recipes-gnome/abiword/abiword-2.5.inc new file mode 100644 index 000000000..e3f6a9d2b --- /dev/null +++ b/meta-gnome/recipes-gnome/abiword/abiword-2.5.inc | |||
@@ -0,0 +1,63 @@ | |||
1 | DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word" | ||
2 | HOMEPAGE = "http://www.abiword.org" | ||
3 | SECTION = "x11/office" | ||
4 | LICENSE = "GPLv2" | ||
5 | DEPENDS = "perl-native wv libgsf libglade libfribidi jpeg libpng libxml2" | ||
6 | RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \ | ||
7 | glibc-gconv-iso8859-15 glibc-gconv-iso8859-1" | ||
8 | |||
9 | SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz" | ||
10 | |||
11 | #want 2.x from 2.x.y for the installation directory | ||
12 | SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | ||
13 | |||
14 | FILES_${PN} += " \ | ||
15 | ${datadir}/icons/* \ | ||
16 | ${datadir}/abiword-${SHRT_VER}/glade \ | ||
17 | ${datadir}/abiword-${SHRT_VER}/scripts \ | ||
18 | ${datadir}/abiword-${SHRT_VER}/system.profile-en \ | ||
19 | ${datadir}/abiword-${SHRT_VER}/system.profile-en_GB \ | ||
20 | # ${datadir}/abiword-${SHRT_VER}/templates/A4.awt \ | ||
21 | # ${datadir}/abiword-${SHRT_VER}/templates/US-Letter.awt \ | ||
22 | ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \ | ||
23 | ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \ | ||
24 | ${datadir}/abiword-${SHRT_VER}/templates/Employee-Directory.awt \ | ||
25 | ${datadir}/abiword-${SHRT_VER}/templates/Business-Report.awt \ | ||
26 | ${datadir}/abiword-${SHRT_VER}/templates/Fax-Coversheet.awt \ | ||
27 | ${datadir}/abiword-${SHRT_VER}/templates/Resume.awt \ | ||
28 | ${datadir}/abiword-${SHRT_VER}/templates/Two-Columns.awt \ | ||
29 | ${datadir}/abiword-${SHRT_VER}/templates/Memo.awt \ | ||
30 | ${datadir}/abiword-${SHRT_VER}/templates/Press-Release.awt " | ||
31 | |||
32 | inherit autotools pkgconfig | ||
33 | |||
34 | PARALLEL_MAKE = "" | ||
35 | |||
36 | EXTRA_OECONF = " --disable-pspell \ | ||
37 | --disable-spellcheck \ | ||
38 | --disable-printing \ | ||
39 | --disable-exports \ | ||
40 | --with-sys-wv" | ||
41 | |||
42 | # AbiWord configure.ac does not play nicely with autoreconf | ||
43 | # so use the autogen.sh script that comes with AbiWord | ||
44 | # | ||
45 | do_configure() { | ||
46 | cd ${S} | ||
47 | export NOCONFIGURE="no"; ./autogen.sh | ||
48 | oe_runconf | ||
49 | } | ||
50 | |||
51 | |||
52 | do_install_append() { | ||
53 | install -d ${D}${datadir}/pixmaps/ | ||
54 | mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/ | ||
55 | } | ||
56 | |||
57 | PACKAGES += " abiword-clipart abiword-icons abiword-strings abiword-systemprofiles abiword-templates " | ||
58 | |||
59 | FILES_abiword-clipart += "${datadir}/abiword-${SHRT_VER}/clipart" | ||
60 | FILES_abiword-icons += "${datadir}/abiword-${SHRT_VER}/icons" | ||
61 | FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/AbiWord/strings" | ||
62 | FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/AbiWord/system.profile*" | ||
63 | FILES_abiword-templates += "${datadir}/abiword-${SHRT_VER}/templates" | ||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword-embedded_2.5.2.bb b/meta-gnome/recipes-gnome/abiword/abiword-embedded_2.5.2.bb new file mode 100644 index 000000000..7ee0f866a --- /dev/null +++ b/meta-gnome/recipes-gnome/abiword/abiword-embedded_2.5.2.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | require abiword-2.5.inc | ||
2 | |||
3 | PR = "r1" | ||
4 | |||
5 | EXTRA_OECONF += "--enable-embedded" | ||
6 | |||
7 | S = "${WORKDIR}/abiword-${PV}" | ||
8 | |||
9 | RCONFLICTS = "abiword" | ||
10 | RPROVIDES += "abiword" | ||
11 | |||
12 | |||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword.inc b/meta-gnome/recipes-gnome/abiword/abiword.inc new file mode 100644 index 000000000..5d7e3ce60 --- /dev/null +++ b/meta-gnome/recipes-gnome/abiword/abiword.inc | |||
@@ -0,0 +1,63 @@ | |||
1 | DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word" | ||
2 | SECTION = "gnome/office" | ||
3 | HOMEPAGE = "http://www.abiword.org"" | ||
4 | LICENSE = "GPLv2" | ||
5 | |||
6 | DEPENDS = "libgsf libglade libfribidi libxml2 wv" | ||
7 | RRECOMMENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \ | ||
8 | glibc-gconv-iso8859-15 glibc-gconv-iso8859-1" | ||
9 | |||
10 | # Share this file between recipes that use cvs and that pull tarballs | ||
11 | # (one day change this to differentiate automatically based on PV and set the | ||
12 | # SRC_URI and S var directly) | ||
13 | RELURI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz" | ||
14 | RELSRC = "${WORKDIR}/abiword-${PV}/abi" | ||
15 | |||
16 | CVSURI = "cvs://anoncvs:anoncvs@anoncvs.abisource.com/cvsroot;module=abi" | ||
17 | CVSSRC = "${WORKDIR}/abi" | ||
18 | |||
19 | #want 2.x from 2.x.y for the installation directory | ||
20 | SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | ||
21 | |||
22 | FILES_${PN} += " \ | ||
23 | ${datadir}/icons/* \ | ||
24 | ${datadir}/mime-info \ | ||
25 | ${datadir}/abiword-${SHRT_VER}/glade \ | ||
26 | ${datadir}/abiword-${SHRT_VER}/system.profile-en \ | ||
27 | ${datadir}/abiword-${SHRT_VER}/system.profile-en-GB \ | ||
28 | # ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \ | ||
29 | # ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \ | ||
30 | " | ||
31 | |||
32 | inherit autotools pkgconfig | ||
33 | |||
34 | PARALLEL_MAKE = "" | ||
35 | |||
36 | # This is a minimalistic AbiWord build | ||
37 | # | ||
38 | # if you are planning to build plugins, make sure to comment out the | ||
39 | # --disable-exports options | ||
40 | |||
41 | EXTRA_OECONF = " --enable-embedded=poky \ | ||
42 | --disable-printing \ | ||
43 | --with-sys-wv \ | ||
44 | --disable-exports \ | ||
45 | --disable-spellcheck" | ||
46 | |||
47 | # TODO -- refactor this, so that instead of two strings and profiles | ||
48 | # packages we have lots of locale packages, each with a set of strings and | ||
49 | # a profile | ||
50 | # | ||
51 | PACKAGES += " abiword-strings abiword-systemprofiles" | ||
52 | |||
53 | FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings" | ||
54 | FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*" | ||
55 | |||
56 | # AbiWord configure.ac does not play nicely with autoreconf | ||
57 | # so use the autogen.sh script that comes with AbiWord | ||
58 | # | ||
59 | do_configure() { | ||
60 | cd ${S} | ||
61 | export NOCONFIGURE="no"; ./autogen.sh | ||
62 | oe_runconf | ||
63 | } | ||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.5.2.bb b/meta-gnome/recipes-gnome/abiword/abiword_2.5.2.bb new file mode 100644 index 000000000..c10d761b0 --- /dev/null +++ b/meta-gnome/recipes-gnome/abiword/abiword_2.5.2.bb | |||
@@ -0,0 +1,5 @@ | |||
1 | require abiword-2.5.inc | ||
2 | |||
3 | PR = "r2" | ||
4 | |||
5 | RCONFLICTS_${PN} = "abiword-embedded" | ||