diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 13:49:59 +0000 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 14:32:06 +0000 |
commit | 3a30c562385cb3d9cd1b3043f6fe677a22024018 (patch) | |
tree | 66dc67f338ba316c25ca672950ef334e9e357386 /meta-gnome/recipes-gnome/abiword | |
parent | d66c9a8b625f7b19f7b17e728dc82413399c2e19 (diff) | |
download | meta-openembedded-3a30c562385cb3d9cd1b3043f6fe677a22024018.tar.gz |
Replace bb.data.* with d.*
Used sed expression given here:
http://lists.linuxtogo.org/pipermail/openembedded-core/2011-November/012373.html
Plus an additional expression for .expand. Full expression is:
sed \
-e 's:bb.data.\(setVar([^,]*,[^,]*\), \([^ )]*\) *):\2.\1):g' \
-e 's:bb.data.\(setVarFlag([^,]*,[^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(expand([^,]*\), \([^ )]*\) *):\2.\1):g' \
-i `grep -ril bb.data *`
Some minor correction in systemd.bbclass was needed for some expressions
that didn't quite match the regex in the desired way; additionally a few
instances were manually changed.
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/abiword')
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword.inc | 2 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb | 16 |
2 files changed, 9 insertions, 9 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword.inc b/meta-gnome/recipes-gnome/abiword/abiword.inc index b1b0f6701..8fbcd3bb2 100644 --- a/meta-gnome/recipes-gnome/abiword/abiword.inc +++ b/meta-gnome/recipes-gnome/abiword/abiword.inc | |||
@@ -17,7 +17,7 @@ CVSURI = "cvs://anoncvs:anoncvs@anoncvs.abisource.com/cvsroot;module=abi" | |||
17 | CVSSRC = "${WORKDIR}/abi" | 17 | CVSSRC = "${WORKDIR}/abi" |
18 | 18 | ||
19 | #want 2.x from 2.x.y for the installation directory | 19 | #want 2.x from 2.x.y for the installation directory |
20 | SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | 20 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" |
21 | 21 | ||
22 | FILES_${PN} += " \ | 22 | FILES_${PN} += " \ |
23 | ${datadir}/icons/* \ | 23 | ${datadir}/icons/* \ |
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb index 60b970bab..c4bf3448d 100644 --- a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb +++ b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb | |||
@@ -21,7 +21,7 @@ SRC_URI[md5sum] = "f883b0a7f26229a9c66fd6a1a94381aa" | |||
21 | SRC_URI[sha256sum] = "d99089a63a6cfc1a6a4a026be9278028d47d224088d24b1853acb67e95683a15" | 21 | SRC_URI[sha256sum] = "d99089a63a6cfc1a6a4a026be9278028d47d224088d24b1853acb67e95683a15" |
22 | 22 | ||
23 | #want 2.x from 2.x.y for the installation directory | 23 | #want 2.x from 2.x.y for the installation directory |
24 | SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | 24 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" |
25 | 25 | ||
26 | PR = "r7" | 26 | PR = "r7" |
27 | 27 | ||
@@ -102,21 +102,21 @@ FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates" | |||
102 | PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*" | 102 | PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*" |
103 | 103 | ||
104 | python populate_packages_prepend () { | 104 | python populate_packages_prepend () { |
105 | abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d) | 105 | abiword_libdir = d.expand('${libdir}/abiword-2.8/plugins') |
106 | do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='') | 106 | do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='') |
107 | 107 | ||
108 | metapkg = "abiword-meta" | 108 | metapkg = "abiword-meta" |
109 | bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d) | 109 | d.setVar('ALLOW_EMPTY_' + metapkg, "1") |
110 | bb.data.setVar('FILES_' + metapkg, "", d) | 110 | d.setVar('FILES_' + metapkg, "") |
111 | blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ] | 111 | blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ] |
112 | metapkg_rdepends = [] | 112 | metapkg_rdepends = [] |
113 | packages = bb.data.getVar('PACKAGES', d, 1).split() | 113 | packages = d.getVar('PACKAGES', 1).split() |
114 | for pkg in packages[1:]: | 114 | for pkg in packages[1:]: |
115 | if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"): | 115 | if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"): |
116 | print "Modifying ", pkg | 116 | print "Modifying ", pkg |
117 | metapkg_rdepends.append(pkg) | 117 | metapkg_rdepends.append(pkg) |
118 | bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d) | 118 | d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends)) |
119 | bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d) | 119 | d.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package') |
120 | packages.append(metapkg) | 120 | packages.append(metapkg) |
121 | bb.data.setVar('PACKAGES', ' '.join(packages), d) | 121 | d.setVar('PACKAGES', ' '.join(packages)) |
122 | } | 122 | } |