diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2020-02-09 16:10:49 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-09 22:31:31 -0800 |
commit | d55b2dca5f8116eb3e2e230994ba0a0abcf36b3a (patch) | |
tree | 480d212d144b648f5884bac01d9277fef69bdaca /meta-gnome/recipes-gimp | |
parent | c23165fe1704d2bee66f4503355fe56071eb7f88 (diff) | |
download | meta-openembedded-d55b2dca5f8116eb3e2e230994ba0a0abcf36b3a.tar.gz |
gegl: upgrade 0.3.18 -> 0.4.20
* gegl is GPLv3 now
* gegl moved to meson build
* move to meta-gnome: latest gimp requires gexiv2 and nothing but gimp depends
on gegl
* add more PACKAGECONFIGs and change defaults slightly: sdl->sdl2 / add gexiv2
by default because gimp requires it anyway
* extend to native: latest gimp requires gegl for manipulation of pngs during
build
* get sources from location gimp's homepage suggests
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gimp')
-rw-r--r-- | meta-gnome/recipes-gimp/gegl/gegl/0001-meson.build-Give-note-if-sdl2-was-found.patch | 32 | ||||
-rw-r--r-- | meta-gnome/recipes-gimp/gegl/gegl_0.4.20.bb | 61 |
2 files changed, 93 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gimp/gegl/gegl/0001-meson.build-Give-note-if-sdl2-was-found.patch b/meta-gnome/recipes-gimp/gegl/gegl/0001-meson.build-Give-note-if-sdl2-was-found.patch new file mode 100644 index 000000000..6a49f1d7c --- /dev/null +++ b/meta-gnome/recipes-gimp/gegl/gegl/0001-meson.build-Give-note-if-sdl2-was-found.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 6bed199a73a7af39344cf8e799b665011553600c Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> | ||
3 | Date: Sat, 8 Feb 2020 14:29:52 +0100 | ||
4 | Subject: [PATCH] meson.build: Give note if sdl2 was found | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Configure output confused me a bit | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> | ||
14 | --- | ||
15 | meson.build | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/meson.build b/meson.build | ||
19 | index 9d5b484..296b5f3 100644 | ||
20 | --- a/meson.build | ||
21 | +++ b/meson.build | ||
22 | @@ -374,6 +374,7 @@ message('\n'.join(['', | ||
23 | ' OpenEXR: @0@'.format(openexr.found()), | ||
24 | ' rsvg: @0@'.format(librsvg.found()), | ||
25 | ' SDL: @0@'.format(sdl1.found()), | ||
26 | +' SDL2: @0@'.format(sdl2.found()), | ||
27 | ' libraw: @0@'.format(libraw.found()), | ||
28 | ' Jasper: @0@'.format(jasper.found()), | ||
29 | ' av libs: @0@'.format(avlibs_found), | ||
30 | -- | ||
31 | 2.21.0 | ||
32 | |||
diff --git a/meta-gnome/recipes-gimp/gegl/gegl_0.4.20.bb b/meta-gnome/recipes-gimp/gegl/gegl_0.4.20.bb new file mode 100644 index 000000000..5e7a1bb84 --- /dev/null +++ b/meta-gnome/recipes-gimp/gegl/gegl_0.4.20.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework" | ||
2 | LICENSE = "GPLv3" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=f1a8bfcbc85304df454b65d378b299c7" | ||
4 | |||
5 | DEPENDS = " \ | ||
6 | intltool-native \ | ||
7 | babl \ | ||
8 | glib-2.0 \ | ||
9 | pango \ | ||
10 | cairo \ | ||
11 | expat \ | ||
12 | zlib \ | ||
13 | \ | ||
14 | json-glib \ | ||
15 | " | ||
16 | |||
17 | GNOMEBASEBUILDCLASS = "meson" | ||
18 | |||
19 | inherit features_check gnomebase vala gobject-introspection | ||
20 | |||
21 | REQUIRED_DISTRO_FEATURES = "x11" | ||
22 | |||
23 | SHPV = "${@gnome_verdir("${PV}")}" | ||
24 | |||
25 | SRC_URI = " \ | ||
26 | https://download.gimp.org/pub/${BPN}/${SHPV}/${BP}.tar.xz \ | ||
27 | file://0001-meson.build-Give-note-if-sdl2-was-found.patch \ | ||
28 | " | ||
29 | SRC_URI[md5sum] = "37433eb00f8a4b0d1ae9e975aaedfa26" | ||
30 | SRC_URI[sha256sum] = "23bd8bb42b20de7c2a8c314eeb5301dc20141feda20a4b1ed455020b69b73dff" | ||
31 | |||
32 | PACKAGECONFIG ??= "gexiv2 jpeg libpng librsvg sdl2" | ||
33 | PACKAGECONFIG_class-native = "libpng librsvg" | ||
34 | |||
35 | PACKAGECONFIG[jasper] = "-Djasper=enabled,-Djasper=disabled,jasper" | ||
36 | PACKAGECONFIG[gexiv2] = "-Dgexiv2=enabled,-Dgexiv2=disabled,gexiv2" | ||
37 | PACKAGECONFIG[graphviz] = "-Dgraphviz=enabled,-Dgraphviz=disabled,graphviz" | ||
38 | PACKAGECONFIG[jpeg] = "-Dlibjpeg=enabled,-Dlibjpeg=disabled,jpeg" | ||
39 | PACKAGECONFIG[lcms] = "-Dlcms=enabled,-Dlcms=disabled,lcms" | ||
40 | PACKAGECONFIG[libav] = "-Dlibav=enabled,-Dlibav=disabled,libav" | ||
41 | PACKAGECONFIG[libpng] = "-Dlibpng=enabled,-Dlibpng=disabled,libpng" | ||
42 | PACKAGECONFIG[librsvg] = "-Dlibrsvg=enabled,-Dlibrsvg=disabled,librsvg" | ||
43 | PACKAGECONFIG[sdl] = "-Dsdl1=enabled,-Dsdl1=disabled,virtual/libsdl" | ||
44 | PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,virtual/libsdl2" | ||
45 | PACKAGECONFIG[tiff] = "-Dlibtiff=enabled,-Dlibtiff=disabled,tiff" | ||
46 | PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,webp" | ||
47 | |||
48 | # There are a couple of non-symlink .so files installed into libdir, which need to go into main package | ||
49 | FILES_${PN} += " \ | ||
50 | ${libdir}/*.so \ | ||
51 | ${libdir}/gegl-${SHPV}/*.json \ | ||
52 | ${libdir}/gegl-${SHPV}/*.so \ | ||
53 | " | ||
54 | FILES_SOLIBSDEV = "${libdir}/libgegl-${SHPV}${SOLIBSDEV}" | ||
55 | |||
56 | # Fails to build with thumb-1 (qemuarm) | ||
57 | # gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process': | ||
58 | # gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275 | ||
59 | ARM_INSTRUCTION_SET = "arm" | ||
60 | |||
61 | BBCLASSEXTEND = "native" | ||