summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gimp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-24 22:45:11 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-25 08:56:32 -0700
commitd3bfe80601963cf8c41d67e0eba299b37beec9a5 (patch)
treefeea7da61c42777fbec7cc38e2abbdb9c11f9269 /meta-gnome/recipes-gimp
parent75adab58e3d979cce2a549ac2c2277a31b30253d (diff)
downloadmeta-openembedded-d3bfe80601963cf8c41d67e0eba299b37beec9a5.tar.gz
gimp: Fix buildpaths in binaries and scripts
Fixes WARNING: gimp-2.10.34-r0 do_package_qa: QA Issue: File /usr/libexec/gimp-debug-tool-2.0 in package gimp contains reference to TMPDIR File /usr/bin/gimp-console-2.10 in package gimp contains reference to TMPDIR File /usr/bin/gimptool-2.0 in package gimp contains reference to TMPDIR File /usr/bin/gimp-2.10 in package gimp contains reference to TMPDIR [buildpaths] Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gimp')
-rw-r--r--meta-gnome/recipes-gimp/gimp/gimp/0001-configure-Keep-first-line-of-compiler-version-string.patch30
-rw-r--r--meta-gnome/recipes-gimp/gimp/gimp/0001-libtool-Do-not-add-build-time-library-paths-to-LD_LI.patch34
-rw-r--r--meta-gnome/recipes-gimp/gimp/gimp_2.10.34.bb4
3 files changed, 67 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gimp/gimp/gimp/0001-configure-Keep-first-line-of-compiler-version-string.patch b/meta-gnome/recipes-gimp/gimp/gimp/0001-configure-Keep-first-line-of-compiler-version-string.patch
new file mode 100644
index 000000000..618b4cc7a
--- /dev/null
+++ b/meta-gnome/recipes-gimp/gimp/gimp/0001-configure-Keep-first-line-of-compiler-version-string.patch
@@ -0,0 +1,30 @@
1From 5711ccfab40e304ced7f5be39a4083e3fcecff91 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 24 May 2023 22:22:41 -0700
4Subject: [PATCH] configure: Keep first line of compiler version string
5
6Full output of cc -v may contain additional information which could
7contain build path information, which is unnessasary
8
9Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/gimp/-/merge_requests/926]
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 configure.ac | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/configure.ac b/configure.ac
16index c25415d..68707a0 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -599,7 +599,7 @@ fi
20 for CC_VERSION_OPT in $CC_VERSION_OPTS; do
21 # We run $CC, and escape and format its output, in a single step,
22 # since some shells expand escape sequences in "echo" arguments.
23- CC_VERSION="`$CC $CC_VERSION_OPT 2>&1 | sed -e 's/\\\\/\\\\\\\\\\\\\\\\/g;s/^/\\\\t/;s/$/\\\\n/' | tr -d '\n'`"
24+ CC_VERSION="`$CC $CC_VERSION_OPT 2>&1 | head -1 | sed -e 's/\\\\/\\\\\\\\\\\\\\\\/g;s/^/\\\\t/;s/$/\\\\n/' | tr -d '\n'`"
25 if test $? -eq 0; then
26 break
27 fi
28--
292.40.1
30
diff --git a/meta-gnome/recipes-gimp/gimp/gimp/0001-libtool-Do-not-add-build-time-library-paths-to-LD_LI.patch b/meta-gnome/recipes-gimp/gimp/gimp/0001-libtool-Do-not-add-build-time-library-paths-to-LD_LI.patch
new file mode 100644
index 000000000..cec005528
--- /dev/null
+++ b/meta-gnome/recipes-gimp/gimp/gimp/0001-libtool-Do-not-add-build-time-library-paths-to-LD_LI.patch
@@ -0,0 +1,34 @@
1From c720df90dfe3a3e92e34bfb36a04cc792064a501 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 24 May 2023 22:39:02 -0700
4Subject: [PATCH] libtool: Do not add build time library paths to
5 LD_LIBRARY_PATH
6
7This does not serve much purpose on cross builds as it will add build
8time paths which are only useful when trying to run these tools from
9build area but when they are cross built this is not possible to run
10them like this.
11
12Upstream-Status: Inappropriate [Cross-compile specific]
13
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 ltmain.sh | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/ltmain.sh b/ltmain.sh
20index 134902c..068d74a 100644
21--- a/ltmain.sh
22+++ b/ltmain.sh
23@@ -5748,7 +5748,7 @@ func_exec_program ()
24 if test yes = "$shlibpath_overrides_runpath" && test -n "$shlibpath_var" && test -n "$temp_rpath"; then
25 $ECHO "\
26 # Add our own library path to $shlibpath_var
27- $shlibpath_var=\"$temp_rpath\$$shlibpath_var\"
28+ $shlibpath_var=\"$shlibpath_var\"
29
30 # Some systems cannot cope with colon-terminated $shlibpath_var
31 # The second colon is a workaround for a bug in BeOS R4 sed
32--
332.40.1
34
diff --git a/meta-gnome/recipes-gimp/gimp/gimp_2.10.34.bb b/meta-gnome/recipes-gimp/gimp/gimp_2.10.34.bb
index 76825d96c..734303680 100644
--- a/meta-gnome/recipes-gimp/gimp/gimp_2.10.34.bb
+++ b/meta-gnome/recipes-gimp/gimp/gimp_2.10.34.bb
@@ -43,7 +43,9 @@ REQUIRED_DISTRO_FEATURES = "x11"
43 43
44SHPV = "${@gnome_verdir("${PV}")}" 44SHPV = "${@gnome_verdir("${PV}")}"
45 45
46SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2" 46SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2 \
47 file://0001-configure-Keep-first-line-of-compiler-version-string.patch \
48 file://0001-libtool-Do-not-add-build-time-library-paths-to-LD_LI.patch"
47SRC_URI[sha256sum] = "84004642d351b398a4293cd7fd3592044a944f05bb52850ee6068f247c657aa3" 49SRC_URI[sha256sum] = "84004642d351b398a4293cd7fd3592044a944f05bb52850ee6068f247c657aa3"
48 50
49EXTRA_OECONF = "--disable-python \ 51EXTRA_OECONF = "--disable-python \