summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-10-14 03:06:17 +0200
committerKhem Raj <raj.khem@gmail.com>2020-10-13 22:33:05 -0700
commit780b1ccb6d457a3cfd9d5f508ff914e228a8fa55 (patch)
tree6e7bc81388f2e46cff6016730ba92dfa5be71347 /meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb
parenta1f938bf9c8261ceecdc81de5285beab65f470cd (diff)
downloadmeta-openembedded-780b1ccb6d457a3cfd9d5f508ff914e228a8fa55.tar.gz
gimp: upgrade 2.10.20 -> 2.10.22
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb')
-rw-r--r--meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb b/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb
new file mode 100644
index 000000000..aec1ebf7b
--- /dev/null
+++ b/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb
@@ -0,0 +1,63 @@
1SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
6
7DEPENDS = " \
8 gdk-pixbuf-native \
9 intltool-native \
10 libxslt-native \
11 gegl-native \
12 dbus-glib \
13 gtk+ \
14 babl \
15 gegl \
16 libmypaint \
17 mypaint-brushes-1.0 \
18 gexiv2 \
19 jpeg \
20 libpng \
21 libexif \
22 tiff \
23 lcms \
24 poppler \
25 poppler-data \
26 jasper \
27 bzip2 \
28 libgudev \
29 libmng \
30 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)} \
31"
32DEPENDS_append_libc-musl = " libexecinfo"
33
34inherit features_check gnomebase gtk-icon-cache gtk-doc mime-xdg
35
36REQUIRED_DISTRO_FEATURES = "x11"
37
38SHPV = "${@gnome_verdir("${PV}")}"
39
40SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2"
41SRC_URI[sha256sum] = "2db84b57f3778d80b3466d7c21a21d22e315c7b062de2883cbaaeda9a0f618bb"
42
43EXTRA_OECONF = "--disable-python \
44 --without-webkit \
45 --without-wmf"
46
47EXTRA_OECONF_append_libc-musl_mipsarch = " --disable-vector-icons"
48EXTRA_OECONF_append_toolchain-clang_arm = " --disable-vector-icons"
49
50do_configure_append() {
51 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
52 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
53}
54
55do_compile_prepend() {
56 # Let native babl/gegl find their plugins
57 export BABL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'babl-*'`
58 export GEGL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'gegl-*'`
59}
60
61FILES_${PN} += "${datadir}/metainfo"
62
63RDEPENDS_${PN} += "mypaint-brushes-1.0"