diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-01-08 21:33:34 -0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-01-10 12:18:10 +0100 |
commit | 642d3ce4e09a62e854bedb64faa07fdc456e1266 (patch) | |
tree | 1bf4b7adbec112f1fa76e4092c3388966e8f3690 /meta-gnome/recipes-connectivity | |
parent | 83ee268bcf0adf967b2e4762ea5a15eb19cebe34 (diff) | |
download | meta-openembedded-642d3ce4e09a62e854bedb64faa07fdc456e1266.tar.gz |
obexd: Include unistd.h to get ssize_t definition
This error is exposed with eglibc 2.17
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-connectivity')
-rw-r--r-- | meta-gnome/recipes-connectivity/obex/obexd/ssize_t_definition.patch | 32 | ||||
-rw-r--r-- | meta-gnome/recipes-connectivity/obex/obexd_0.44.bb | 6 |
2 files changed, 36 insertions, 2 deletions
diff --git a/meta-gnome/recipes-connectivity/obex/obexd/ssize_t_definition.patch b/meta-gnome/recipes-connectivity/obex/obexd/ssize_t_definition.patch new file mode 100644 index 000000000..2009dcd22 --- /dev/null +++ b/meta-gnome/recipes-connectivity/obex/obexd/ssize_t_definition.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | include unistd.h to get ssize_t definitions | ||
2 | |||
3 | Fixes errors like | ||
4 | |||
5 | | In file included from plugins/mas.c:36:0: | ||
6 | | ./src/obex.h:39:1: error: unknown type name 'ssize_t' | ||
7 | | ./src/obex.h:49:1: error: unknown type name 'ssize_t' | ||
8 | | ./src/obex.h:50:1: error: unknown type name 'ssize_t' | ||
9 | | In file included from plugins/mas.c:38:0: | ||
10 | | ./src/mimetype.h:36:2: error: expected specifier-qualifier-list before 'ssize_t' | ||
11 | | In file included from plugins/mas.c:39:0: | ||
12 | | plugins/filesystem.h:24:1: error: unknown type name 'ssize_t' | ||
13 | | plugins/mas.c:550:1: error: unknown type name 'ssize_t' | ||
14 | | plugins/mas.c:557:1: error: unknown type name 'ssize_t' | ||
15 | | plugins/mas.c: In function 'any_read': | ||
16 | | plugins/mas.c:560:2: error: unknown type name 'ssize_t' | ||
17 | |||
18 | Upstream-Status: Pending | ||
19 | |||
20 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
21 | Index: obexd-0.44/plugins/mas.c | ||
22 | =================================================================== | ||
23 | --- obexd-0.44.orig/plugins/mas.c 2012-01-11 14:53:53.000000000 -0800 | ||
24 | +++ obexd-0.44/plugins/mas.c 2013-01-08 12:51:12.681882174 -0800 | ||
25 | @@ -29,6 +29,7 @@ | ||
26 | #include <glib.h> | ||
27 | #include <fcntl.h> | ||
28 | #include <inttypes.h> | ||
29 | +#include <unistd.h> | ||
30 | |||
31 | #include "obexd.h" | ||
32 | #include "plugin.h" | ||
diff --git a/meta-gnome/recipes-connectivity/obex/obexd_0.44.bb b/meta-gnome/recipes-connectivity/obex/obexd_0.44.bb index 77d7f1ef8..384ce0575 100644 --- a/meta-gnome/recipes-connectivity/obex/obexd_0.44.bb +++ b/meta-gnome/recipes-connectivity/obex/obexd_0.44.bb | |||
@@ -4,9 +4,11 @@ DEPENDS = "openobex glib-2.0 dbus bluez4 libical" | |||
4 | LICENSE = "GPLv2" | 4 | LICENSE = "GPLv2" |
5 | LIC_FILES_CHKSUM = "files://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" | 5 | LIC_FILES_CHKSUM = "files://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" |
6 | 6 | ||
7 | PR = "r1" | 7 | PR = "r2" |
8 | 8 | ||
9 | SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/obexd-${PV}.tar.gz" | 9 | SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/obexd-${PV}.tar.gz \ |
10 | file://ssize_t_definition.patch \ | ||
11 | " | ||
10 | SRC_URI[md5sum] = "3fb9cb9d7ab119753253ff784235a364" | 12 | SRC_URI[md5sum] = "3fb9cb9d7ab119753253ff784235a364" |
11 | SRC_URI[sha256sum] = "104fc50eb8bf41d690d31588c3a4829a75dc7738b1c76cf260171d8f525da758" | 13 | SRC_URI[sha256sum] = "104fc50eb8bf41d690d31588c3a4829a75dc7738b1c76cf260171d8f525da758" |
12 | 14 | ||