summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-09-10 23:49:19 +0200
committerKhem Raj <raj.khem@gmail.com>2019-09-10 18:35:34 -0700
commitb5767f592890950a3c0914ac34c21f4b0e97e616 (patch)
tree7cee2157592907423c989c2d146d8270767c3265 /meta-filesystems
parent28a99855f57b53bb7dc6d5a9c1f51bc9360de1cd (diff)
downloadmeta-openembedded-b5767f592890950a3c0914ac34c21f4b0e97e616.tar.gz
fuse3: add libfuse3 recipe
Add recipe for libfuse version 3 series. Follow the scheme other distributions use and create a new recipe with 3 in its name. To avoid conflict with the fuse (2) recipe this recipe does not provide init scripts/configuration files which automatically load the fuse kernel driver. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse3_3.6.2.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-support/fuse/fuse3_3.6.2.bb b/meta-filesystems/recipes-support/fuse/fuse3_3.6.2.bb
new file mode 100644
index 000000000..e65eb08e2
--- /dev/null
+++ b/meta-filesystems/recipes-support/fuse/fuse3_3.6.2.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
2DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
3 programs to export a virtual filesystem to the Linux kernel. FUSE \
4 also aims to provide a secure method for non privileged users to \
5 create and mount their own filesystem implementations. \
6 "
7HOMEPAGE = "https://github.com/libfuse/libfuse"
8SECTION = "libs"
9LICENSE = "GPLv2 & LGPLv2"
10LIC_FILES_CHKSUM = "file://GPL2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
11 file://LGPL2.txt;md5=4fbd65380cdd255951079008b364516c \
12 file://LICENSE;md5=a55c12a2d7d742ecb41ca9ae0a6ddc66"
13
14SRC_URI = "https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.xz \
15"
16SRC_URI[md5sum] = "1798945aa69434286723b9999a141c7a"
17SRC_URI[sha256sum] = "f45869427575e1e59ab743a67deb57addbf2cb8f9ce431199dbd40ddab71f281"
18
19S = "${WORKDIR}/fuse-${PV}"
20
21UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases"
22UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>3(\.\d+)+).tar.xz"
23
24inherit meson pkgconfig
25
26DEPENDS = "udev"
27
28PACKAGES =+ "fuse3-utils"
29
30RPROVIDES_${PN}-dbg += "fuse3-utils-dbg"
31
32RRECOMMENDS_${PN}_class-target = "kernel-module-fuse fuse3-utils"
33
34FILES_${PN} += "${libdir}/libfuse3.so.*"
35FILES_${PN}-dev += "${libdir}/libfuse3*.la"
36
37EXTRA_OEMESON += " \
38 -Dexamples=false \
39"
40
41# Forbid auto-renaming to libfuse3-utils
42FILES_fuse3-utils = "${bindir} ${base_sbindir}"
43DEBIAN_NOAUTONAME_fuse3-utils = "1"
44DEBIAN_NOAUTONAME_${PN}-dbg = "1"
45
46do_install_append() {
47 rm -rf ${D}${base_prefix}/dev
48}