summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-09-25 17:35:36 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-25 09:48:19 -0700
commit69f234b65ea3cf80967360ec65c96881326bdc67 (patch)
tree3bfd2d2ada77b16d928a8f83011223ec892a01ac /meta-filesystems
parenta715d081cc25c3bf64f296258caf125d83a186e6 (diff)
downloadmeta-openembedded-69f234b65ea3cf80967360ec65c96881326bdc67.tar.gz
fuse: Fix installed-vs-shipped for nativesdk
There are two problems: * The /dev is installed to '${D}/dev', not '${D}${base_prefix}' * The /etc is installed ${D}, but should be ${D}${sysconfdir} It works for target is because target's base_prefix is NULL, but it isn't work for native or nativesdk. Fixed: $ bitbake nativesdk-fuse ERROR: nativesdk-fuse-2.9.9-r0 do_package: QA Issue: nativesdk-fuse: Files/directories were installed but not shipped in any package: /dev /etc /etc/init.d /etc/udev /etc/init.d/fuse /etc/udev/rules.d /etc/udev/rules.d/99-fuse.rules Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse_2.9.9.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-support/fuse/fuse_2.9.9.bb b/meta-filesystems/recipes-support/fuse/fuse_2.9.9.bb
index c83e7f6d3..95e870691 100644
--- a/meta-filesystems/recipes-support/fuse/fuse_2.9.9.bb
+++ b/meta-filesystems/recipes-support/fuse/fuse_2.9.9.bb
@@ -54,7 +54,7 @@ do_configure_prepend() {
54} 54}
55 55
56do_install_append() { 56do_install_append() {
57 rm -rf ${D}${base_prefix}/dev 57 rm -rf ${D}/dev
58 58
59 # systemd class remove the sysv_initddir only if systemd_system_unitdir 59 # systemd class remove the sysv_initddir only if systemd_system_unitdir
60 # contains anything, but it's not needed if sysvinit is not in DISTRO_FEATURES 60 # contains anything, but it's not needed if sysvinit is not in DISTRO_FEATURES
@@ -69,4 +69,10 @@ do_install_append() {
69 fi 69 fi
70} 70}
71 71
72do_install_append_class-nativesdk() {
73 install -d ${D}${sysconfdir}
74 mv ${D}/etc/* ${D}${sysconfdir}/
75 rmdir ${D}/etc
76}
77
72BBCLASSEXTEND = "native nativesdk" 78BBCLASSEXTEND = "native nativesdk"