summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-08-03 15:44:59 -0400
committerKhem Raj <raj.khem@gmail.com>2019-08-03 17:05:01 -0700
commit58805f41a2786a1f25559d74c7c9fa596d5613d9 (patch)
tree76c6f85309a0eda568eda76f12648373aa7369bd /meta-filesystems
parent45e884888ff61c9bf3c8fe96dce70c97bd119303 (diff)
downloadmeta-openembedded-58805f41a2786a1f25559d74c7c9fa596d5613d9.tar.gz
ufs-tool: add tool to access UFS (Universal Flash Storage) devices
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb b/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb
new file mode 100644
index 000000000..e074b5197
--- /dev/null
+++ b/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Tool to access UFS (Universal Flash Storage) devices"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
5PV = "1.3+git${SRCPV}"
6
7BRANCH ?= "dev"
8
9SRCREV = "8b00e33003b57d7071943f63863fcf8cc48d5be9"
10
11SRC_URI = "git://github.com/westerndigitalcorporation/ufs-tool.git;protocol=git;branch=${BRANCH}"
12
13S = "${WORKDIR}/git"
14
15EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}""
16
17do_install() {
18 install -d ${D}${bindir}/
19 install -c -m 755 ${S}/ufs-tool ${D}${bindir}/
20}