diff options
author | Pengyu Ma <pengyu.ma@windriver.com> | 2013-08-21 11:14:50 +0800 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2014-01-20 15:20:44 +0000 |
commit | 221c46116dc8a8ac5f9773a685f8273596754e74 (patch) | |
tree | 18773358738fc3ec0872923bdfd7cfbc7e2ff1fa /meta-filesystems | |
parent | 9402e8cc964a3d75456af616497d376ebcc8e299 (diff) | |
download | meta-openembedded-221c46116dc8a8ac5f9773a685f8273596754e74.tar.gz |
yaffs2: Adds git version recipe (initial recipe)
Added CONFIG in CFLAGS to resolve missing definition error.
Signed-off-by: Pengyu Ma <pengyu.ma@windriver.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r-- | meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb b/meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb new file mode 100644 index 000000000..2b7452b1f --- /dev/null +++ b/meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | SUMMARY = "Yet Another Flash File System" | ||
2 | |||
3 | DESCRIPTION = "Tools for managing 'yaffs2' file systems." | ||
4 | |||
5 | SECTION = "base" | ||
6 | HOMEPAGE = "http://www.yaffs.net" | ||
7 | LICENSE = "GPLv2" | ||
8 | |||
9 | PR = "r0" | ||
10 | PV = "0.0+git${SRCPV}" | ||
11 | |||
12 | DEPENDS = "mtd-utils" | ||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | # Source is the HEAD of master branch at the time of writing this recipe | ||
16 | SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master \ | ||
17 | " | ||
18 | SRCREV = "bc76682d93955cfb33051beb503ad9f8a5450578" | ||
19 | |||
20 | LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=12;endline=14;md5=5f5464f9b3e981ca574e65b00e438561" | ||
21 | |||
22 | CFLAGS_append = " -I.. -DCONFIG_YAFFS_UTIL -DCONFIG_YAFFS_DEFINES_TYPES" | ||
23 | |||
24 | do_compile() { | ||
25 | cd utils && oe_runmake | ||
26 | } | ||
27 | |||
28 | INSTALL_FILES = "mkyaffsimage \ | ||
29 | mkyaffs2image \ | ||
30 | " | ||
31 | do_install() { | ||
32 | install -d ${D}${sbindir}/ | ||
33 | for i in ${INSTALL_FILES}; do | ||
34 | install -m 0755 utils/$i ${D}${sbindir}/ | ||
35 | done | ||
36 | } | ||
37 | |||
38 | BBCLASSEXTEND = "native" | ||