diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2024-03-08 01:31:58 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-03-08 10:07:30 -0800 |
commit | 7f50e80c19df2796dfff2e09a9a68153557409f0 (patch) | |
tree | 1aa96ec930532d1b14cfd794b14ad8626f52a181 /meta-filesystems | |
parent | 1bafebf636f959892de6aebcd7cc790c78d54575 (diff) | |
download | meta-openembedded-7f50e80c19df2796dfff2e09a9a68153557409f0.tar.gz |
xfsprogs: 6.5.0 -> 6.6.0
Rebased 0005-Replace-off64_t-stat64-with-off_t-stat.patch for 6.6.0.
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r-- | meta-filesystems/recipes-utils/xfsprogs/files/0005-Replace-off64_t-stat64-with-off_t-stat.patch | 40 | ||||
-rw-r--r-- | meta-filesystems/recipes-utils/xfsprogs/xfsprogs_6.6.0.bb (renamed from meta-filesystems/recipes-utils/xfsprogs/xfsprogs_6.5.0.bb) | 2 |
2 files changed, 21 insertions, 21 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/files/0005-Replace-off64_t-stat64-with-off_t-stat.patch b/meta-filesystems/recipes-utils/xfsprogs/files/0005-Replace-off64_t-stat64-with-off_t-stat.patch index 731c001e1..940d63c01 100644 --- a/meta-filesystems/recipes-utils/xfsprogs/files/0005-Replace-off64_t-stat64-with-off_t-stat.patch +++ b/meta-filesystems/recipes-utils/xfsprogs/files/0005-Replace-off64_t-stat64-with-off_t-stat.patch | |||
@@ -42,18 +42,18 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
42 | 26 files changed, 74 insertions(+), 74 deletions(-) | 42 | 26 files changed, 74 insertions(+), 74 deletions(-) |
43 | 43 | ||
44 | diff --git a/copy/xfs_copy.c b/copy/xfs_copy.c | 44 | diff --git a/copy/xfs_copy.c b/copy/xfs_copy.c |
45 | index 79f6594..854fd7f 100644 | 45 | index 0420649..98a578a 100644 |
46 | --- a/copy/xfs_copy.c | 46 | --- a/copy/xfs_copy.c |
47 | +++ b/copy/xfs_copy.c | 47 | +++ b/copy/xfs_copy.c |
48 | @@ -888,7 +888,7 @@ main(int argc, char **argv) | 48 | @@ -881,7 +881,7 @@ main(int argc, char **argv) |
49 | } | 49 | } |
50 | } else { | 50 | } else { |
51 | char *lb[XFS_MAX_SECTORSIZE] = { NULL }; | 51 | char *lb = memalign(wbuf_align, XFS_MAX_SECTORSIZE); |
52 | - off64_t off; | 52 | - off64_t off; |
53 | + off_t off; | 53 | + off_t off; |
54 | ssize_t len; | ||
54 | 55 | ||
55 | /* ensure device files are sufficiently large */ | 56 | /* ensure device files are sufficiently large */ |
56 | |||
57 | diff --git a/fsr/xfs_fsr.c b/fsr/xfs_fsr.c | 57 | diff --git a/fsr/xfs_fsr.c b/fsr/xfs_fsr.c |
58 | index ba02506..12fffbd 100644 | 58 | index ba02506..12fffbd 100644 |
59 | --- a/fsr/xfs_fsr.c | 59 | --- a/fsr/xfs_fsr.c |
@@ -68,7 +68,7 @@ index ba02506..12fffbd 100644 | |||
68 | int ct, wc, wc_b4; | 68 | int ct, wc, wc_b4; |
69 | char ffname[SMBUFSZ]; | 69 | char ffname[SMBUFSZ]; |
70 | diff --git a/io/bmap.c b/io/bmap.c | 70 | diff --git a/io/bmap.c b/io/bmap.c |
71 | index 27383ca..0b14bb7 100644 | 71 | index 722a389..6182e1c 100644 |
72 | --- a/io/bmap.c | 72 | --- a/io/bmap.c |
73 | +++ b/io/bmap.c | 73 | +++ b/io/bmap.c |
74 | @@ -257,7 +257,7 @@ bmap_f( | 74 | @@ -257,7 +257,7 @@ bmap_f( |
@@ -186,7 +186,7 @@ index 7db5184..bf11963 100644 | |||
186 | swidth = (fsgeo->swidth * fsgeo->blocksize); | 186 | swidth = (fsgeo->swidth * fsgeo->blocksize); |
187 | 187 | ||
188 | diff --git a/io/io.h b/io/io.h | 188 | diff --git a/io/io.h b/io/io.h |
189 | index 64b7a66..5f42301 100644 | 189 | index fe474fa..68e5e48 100644 |
190 | --- a/io/io.h | 190 | --- a/io/io.h |
191 | +++ b/io/io.h | 191 | +++ b/io/io.h |
192 | @@ -53,7 +53,7 @@ extern int stat_f(int argc, char **argv); | 192 | @@ -53,7 +53,7 @@ extern int stat_f(int argc, char **argv); |
@@ -603,7 +603,7 @@ index 1d04919..a74b613 100644 | |||
603 | 603 | ||
604 | init_cvtnum(&blocksize, §size); | 604 | init_cvtnum(&blocksize, §size); |
605 | diff --git a/libxfs/rdwr.c b/libxfs/rdwr.c | 605 | diff --git a/libxfs/rdwr.c b/libxfs/rdwr.c |
606 | index d5aad3e..0faa05b 100644 | 606 | index 0e33211..153007d 100644 |
607 | --- a/libxfs/rdwr.c | 607 | --- a/libxfs/rdwr.c |
608 | +++ b/libxfs/rdwr.c | 608 | +++ b/libxfs/rdwr.c |
609 | @@ -576,7 +576,7 @@ libxfs_balloc( | 609 | @@ -576,7 +576,7 @@ libxfs_balloc( |
@@ -615,8 +615,8 @@ index d5aad3e..0faa05b 100644 | |||
615 | { | 615 | { |
616 | int sts; | 616 | int sts; |
617 | 617 | ||
618 | @@ -639,7 +639,7 @@ libxfs_readbufr_map(struct xfs_buftarg *btp, struct xfs_buf *bp, int flags) | 618 | @@ -638,7 +638,7 @@ libxfs_readbufr_map(struct xfs_buftarg *btp, struct xfs_buf *bp, int flags) |
619 | fd = libxfs_device_to_fd(btp->bt_bdev); | 619 | |
620 | buf = bp->b_addr; | 620 | buf = bp->b_addr; |
621 | for (i = 0; i < bp->b_nmaps; i++) { | 621 | for (i = 0; i < bp->b_nmaps; i++) { |
622 | - off64_t offset = LIBXFS_BBTOOFF64(bp->b_maps[i].bm_bn); | 622 | - off64_t offset = LIBXFS_BBTOOFF64(bp->b_maps[i].bm_bn); |
@@ -624,7 +624,7 @@ index d5aad3e..0faa05b 100644 | |||
624 | int len = BBTOB(bp->b_maps[i].bm_len); | 624 | int len = BBTOB(bp->b_maps[i].bm_len); |
625 | 625 | ||
626 | error = __read_buf(fd, buf, len, offset, flags); | 626 | error = __read_buf(fd, buf, len, offset, flags); |
627 | @@ -798,7 +798,7 @@ err: | 627 | @@ -797,7 +797,7 @@ err: |
628 | } | 628 | } |
629 | 629 | ||
630 | static int | 630 | static int |
@@ -633,7 +633,7 @@ index d5aad3e..0faa05b 100644 | |||
633 | { | 633 | { |
634 | int sts; | 634 | int sts; |
635 | 635 | ||
636 | @@ -864,7 +864,7 @@ libxfs_bwrite( | 636 | @@ -863,7 +863,7 @@ libxfs_bwrite( |
637 | void *buf = bp->b_addr; | 637 | void *buf = bp->b_addr; |
638 | 638 | ||
639 | for (i = 0; i < bp->b_nmaps; i++) { | 639 | for (i = 0; i < bp->b_nmaps; i++) { |
@@ -643,20 +643,20 @@ index d5aad3e..0faa05b 100644 | |||
643 | 643 | ||
644 | bp->b_error = __write_buf(fd, buf, len, offset, | 644 | bp->b_error = __write_buf(fd, buf, len, offset, |
645 | diff --git a/mdrestore/xfs_mdrestore.c b/mdrestore/xfs_mdrestore.c | 645 | diff --git a/mdrestore/xfs_mdrestore.c b/mdrestore/xfs_mdrestore.c |
646 | index 7c1a66c..bb54e38 100644 | 646 | index 8e3998d..334bdd2 100644 |
647 | --- a/mdrestore/xfs_mdrestore.c | 647 | --- a/mdrestore/xfs_mdrestore.c |
648 | +++ b/mdrestore/xfs_mdrestore.c | 648 | +++ b/mdrestore/xfs_mdrestore.c |
649 | @@ -116,7 +116,7 @@ perform_restore( | 649 | @@ -160,7 +160,7 @@ verify_device_size( |
650 | } else { | ||
650 | /* ensure device is sufficiently large enough */ | 651 | /* ensure device is sufficiently large enough */ |
651 | 652 | char lb[XFS_MAX_SECTORSIZE] = { 0 }; | |
652 | char *lb[XFS_MAX_SECTORSIZE] = { NULL }; | ||
653 | - off64_t off; | 653 | - off64_t off; |
654 | + off_t off; | 654 | + off_t off; |
655 | 655 | ||
656 | off = sb.sb_dblocks * sb.sb_blocksize - sizeof(lb); | 656 | off = nr_blocks * blocksize - sizeof(lb); |
657 | if (pwrite(dst_fd, lb, sizeof(lb), off) < 0) | 657 | if (pwrite(dev_fd, lb, sizeof(lb), off) < 0) |
658 | diff --git a/repair/prefetch.c b/repair/prefetch.c | 658 | diff --git a/repair/prefetch.c b/repair/prefetch.c |
659 | index 017750e..35b5013 100644 | 659 | index 78c1e39..b0dd197 100644 |
660 | --- a/repair/prefetch.c | 660 | --- a/repair/prefetch.c |
661 | +++ b/repair/prefetch.c | 661 | +++ b/repair/prefetch.c |
662 | @@ -475,7 +475,7 @@ pf_batch_read( | 662 | @@ -475,7 +475,7 @@ pf_batch_read( |
@@ -669,7 +669,7 @@ index 017750e..35b5013 100644 | |||
669 | int i; | 669 | int i; |
670 | int inode_bufs; | 670 | int inode_bufs; |
671 | diff --git a/scrub/spacemap.c b/scrub/spacemap.c | 671 | diff --git a/scrub/spacemap.c b/scrub/spacemap.c |
672 | index 03440d3..00bee17 100644 | 672 | index b6fd411..9cefe07 100644 |
673 | --- a/scrub/spacemap.c | 673 | --- a/scrub/spacemap.c |
674 | +++ b/scrub/spacemap.c | 674 | +++ b/scrub/spacemap.c |
675 | @@ -97,11 +97,11 @@ scan_ag_rmaps( | 675 | @@ -97,11 +97,11 @@ scan_ag_rmaps( |
@@ -688,7 +688,7 @@ index 03440d3..00bee17 100644 | |||
688 | memset(keys, 0, sizeof(struct fsmap) * 2); | 688 | memset(keys, 0, sizeof(struct fsmap) * 2); |
689 | keys->fmr_device = ctx->fsinfo.fs_datadev; | 689 | keys->fmr_device = ctx->fsinfo.fs_datadev; |
690 | diff --git a/spaceman/freesp.c b/spaceman/freesp.c | 690 | diff --git a/spaceman/freesp.c b/spaceman/freesp.c |
691 | index 423568a..df878ce 100644 | 691 | index 70dcdb5..f5177cb 100644 |
692 | --- a/spaceman/freesp.c | 692 | --- a/spaceman/freesp.c |
693 | +++ b/spaceman/freesp.c | 693 | +++ b/spaceman/freesp.c |
694 | @@ -62,7 +62,7 @@ static void | 694 | @@ -62,7 +62,7 @@ static void |
diff --git a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_6.5.0.bb b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_6.6.0.bb index fd2797982..07c5e97db 100644 --- a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_6.5.0.bb +++ b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_6.6.0.bb | |||
@@ -13,7 +13,7 @@ SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \ | |||
13 | file://0004-configure-Use-AC_SYS_LARGERFILE-autoconf-macro.patch \ | 13 | file://0004-configure-Use-AC_SYS_LARGERFILE-autoconf-macro.patch \ |
14 | file://0005-Replace-off64_t-stat64-with-off_t-stat.patch \ | 14 | file://0005-Replace-off64_t-stat64-with-off_t-stat.patch \ |
15 | " | 15 | " |
16 | SRC_URI[sha256sum] = "8db81712b32756b97d89dd9a681ac5e325bbb75e585382cd4863fab7f9d021c6" | 16 | SRC_URI[sha256sum] = "50ca2f4676df8fab4cb4c3ef3dd512d5551e6844d40a65a31d5b8e03593d22df" |
17 | inherit autotools-brokensep pkgconfig | 17 | inherit autotools-brokensep pkgconfig |
18 | 18 | ||
19 | PACKAGES =+ "${PN}-fsck ${PN}-mkfs ${PN}-repair libhandle" | 19 | PACKAGES =+ "${PN}-fsck ${PN}-mkfs ${PN}-repair libhandle" |