diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-03-12 10:53:23 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-03-12 15:55:07 -0800 |
commit | 656fb86a5581a0ba57a8677309edc0524020e926 (patch) | |
tree | e47001d25140567a8f96a7933e19bd0207d57ce3 /meta-filesystems | |
parent | 724b134c848610961735a4d82db96a6244480838 (diff) | |
download | meta-openembedded-656fb86a5581a0ba57a8677309edc0524020e926.tar.gz |
ufs-utils: Upgrade to 1.9
Fix build with ppc64 while here
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r-- | meta-filesystems/recipes-utils/ufs-utils/ufs-utils/0001-Replace-u_intXX_t-with-kernel-typedefs.patch | 54 | ||||
-rw-r--r-- | meta-filesystems/recipes-utils/ufs-utils/ufs-utils/0001-Use-asm-type.h-for-kernel-types.patch | 65 | ||||
-rw-r--r-- | meta-filesystems/recipes-utils/ufs-utils/ufs-utils_1.9.bb (renamed from meta-filesystems/recipes-utils/ufs-utils/ufs-utils_git.bb) | 6 |
3 files changed, 67 insertions, 58 deletions
diff --git a/meta-filesystems/recipes-utils/ufs-utils/ufs-utils/0001-Replace-u_intXX_t-with-kernel-typedefs.patch b/meta-filesystems/recipes-utils/ufs-utils/ufs-utils/0001-Replace-u_intXX_t-with-kernel-typedefs.patch deleted file mode 100644 index e69a3cf1ff..0000000000 --- a/meta-filesystems/recipes-utils/ufs-utils/ufs-utils/0001-Replace-u_intXX_t-with-kernel-typedefs.patch +++ /dev/null | |||
@@ -1,54 +0,0 @@ | |||
1 | From 6cf6f5b9c39dfd0d46f2069c3baeab92ae980367 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 15 Dec 2019 00:58:13 -0800 | ||
4 | Subject: [PATCH] Replace u_intXX_t with kernel typedefs | ||
5 | |||
6 | u_intXX_t requires including sys/types.h which might not work in kernel | ||
7 | code, if this header is used in a kernel module | ||
8 | |||
9 | Fixes | ||
10 | | In file included from ufs.c:16: | ||
11 | | In file included from ./ufs.h:9: | ||
12 | | ./scsi_bsg_util.h:131:2: error: unknown type name 'u_int16_t'; did you mean 'uint16_t'? | ||
13 | | u_int16_t result; | ||
14 | | ^~~~~~~~~ | ||
15 | |||
16 | Upstream-Status: Submitted [https://github.com/westerndigitalcorporation/ufs-utils/pull/23] | ||
17 | |||
18 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
19 | --- | ||
20 | scsi_bsg_util.h | 18 +++++++++--------- | ||
21 | 1 file changed, 9 insertions(+), 9 deletions(-) | ||
22 | |||
23 | diff --git a/scsi_bsg_util.h b/scsi_bsg_util.h | ||
24 | index 3f8a482..497c3ae 100644 | ||
25 | --- a/scsi_bsg_util.h | ||
26 | +++ b/scsi_bsg_util.h | ||
27 | @@ -121,15 +121,15 @@ struct ufs_bsg_reply { | ||
28 | #endif /* SCSI_BSG_UFS_H.*/ | ||
29 | |||
30 | struct rpmb_frame { | ||
31 | - u_int8_t stuff[196]; | ||
32 | - u_int8_t key_mac[32]; | ||
33 | - u_int8_t data[256]; | ||
34 | - u_int8_t nonce[16]; | ||
35 | - u_int32_t write_counter; | ||
36 | - u_int16_t addr; | ||
37 | - u_int16_t block_count; | ||
38 | - u_int16_t result; | ||
39 | - u_int16_t req_resp; | ||
40 | + __u8 stuff[196]; | ||
41 | + __u8 key_mac[32]; | ||
42 | + __u8 data[256]; | ||
43 | + __u8 nonce[16]; | ||
44 | + __u32 write_counter; | ||
45 | + __u16 addr; | ||
46 | + __u16 block_count; | ||
47 | + __u16 result; | ||
48 | + __u16 req_resp; | ||
49 | }; | ||
50 | |||
51 | #define BSG_REPLY_SZ (sizeof(struct ufs_bsg_reply)) | ||
52 | -- | ||
53 | 2.24.1 | ||
54 | |||
diff --git a/meta-filesystems/recipes-utils/ufs-utils/ufs-utils/0001-Use-asm-type.h-for-kernel-types.patch b/meta-filesystems/recipes-utils/ufs-utils/ufs-utils/0001-Use-asm-type.h-for-kernel-types.patch new file mode 100644 index 0000000000..08cf870169 --- /dev/null +++ b/meta-filesystems/recipes-utils/ufs-utils/ufs-utils/0001-Use-asm-type.h-for-kernel-types.patch | |||
@@ -0,0 +1,65 @@ | |||
1 | From 517f841ccac59b0579e706dd768d6c7b1a7e7552 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 12 Mar 2021 10:37:21 -0800 | ||
4 | Subject: [PATCH] Use asm/type.h for kernel types | ||
5 | |||
6 | This ensures that right headers for types is included otherwise it can | ||
7 | conflict for some platforms e.g. ppc64 where it includes the underlying | ||
8 | files conditionally | ||
9 | |||
10 | asm/types.h is | ||
11 | |||
12 | if !defined(__SANE_USERSPACE_TYPES__) && defined(__powerpc64__) && !defined(__KERNEL__) | ||
13 | include <asm-generic/int-l64.h> | ||
14 | else | ||
15 | include <asm-generic/int-ll64.h> | ||
16 | endif | ||
17 | |||
18 | Upstream-Status: Submitted [https://github.com/westerndigitalcorporation/ufs-utils/pull/29] | ||
19 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
20 | --- | ||
21 | ufs.h | 1 - | ||
22 | ufs_cmds.h | 2 +- | ||
23 | ufs_ffu.c | 1 - | ||
24 | 3 files changed, 1 insertion(+), 3 deletions(-) | ||
25 | |||
26 | diff --git a/ufs.h b/ufs.h | ||
27 | index dc51367..0321c54 100644 | ||
28 | --- a/ufs.h | ||
29 | +++ b/ufs.h | ||
30 | @@ -4,7 +4,6 @@ | ||
31 | |||
32 | #ifndef UFS_H_ | ||
33 | #define UFS_H_ | ||
34 | -#include <asm-generic/int-ll64.h> | ||
35 | #include "ioctl.h" | ||
36 | #include "scsi_bsg_util.h" | ||
37 | |||
38 | diff --git a/ufs_cmds.h b/ufs_cmds.h | ||
39 | index 1e7e24d..5c5b045 100644 | ||
40 | --- a/ufs_cmds.h | ||
41 | +++ b/ufs_cmds.h | ||
42 | @@ -5,7 +5,7 @@ | ||
43 | #define UFS_CMNDS_H_ | ||
44 | |||
45 | #include "options.h" | ||
46 | -#include <asm-generic/int-ll64.h> | ||
47 | +#include <asm/types.h> | ||
48 | |||
49 | |||
50 | enum field_width { | ||
51 | diff --git a/ufs_ffu.c b/ufs_ffu.c | ||
52 | index 2bcec44..99b479c 100644 | ||
53 | --- a/ufs_ffu.c | ||
54 | +++ b/ufs_ffu.c | ||
55 | @@ -12,7 +12,6 @@ | ||
56 | #include <unistd.h> | ||
57 | #include <stdint.h> | ||
58 | #include <errno.h> | ||
59 | -#include <asm-generic/int-ll64.h> | ||
60 | |||
61 | #include "ufs.h" | ||
62 | #include "ufs_cmds.h" | ||
63 | -- | ||
64 | 2.30.2 | ||
65 | |||
diff --git a/meta-filesystems/recipes-utils/ufs-utils/ufs-utils_git.bb b/meta-filesystems/recipes-utils/ufs-utils/ufs-utils_1.9.bb index 23583650b8..e23c764a03 100644 --- a/meta-filesystems/recipes-utils/ufs-utils/ufs-utils_git.bb +++ b/meta-filesystems/recipes-utils/ufs-utils/ufs-utils_1.9.bb | |||
@@ -2,14 +2,12 @@ SUMMARY = "Tool to access UFS (Universal Flash Storage) devices" | |||
2 | LICENSE = "GPLv2" | 2 | LICENSE = "GPLv2" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
4 | 4 | ||
5 | PV = "1.6+git${SRCPV}" | ||
6 | |||
7 | BRANCH ?= "dev" | 5 | BRANCH ?= "dev" |
8 | 6 | ||
9 | SRCREV = "a3cf93b66f4606a46354cf884d24aa966661f848" | 7 | SRCREV = "517c0b01e47d4441cc45be351509fb4c96843d5a" |
10 | 8 | ||
11 | SRC_URI = "git://github.com/westerndigitalcorporation/ufs-utils.git;protocol=git;branch=${BRANCH} \ | 9 | SRC_URI = "git://github.com/westerndigitalcorporation/ufs-utils.git;protocol=git;branch=${BRANCH} \ |
12 | file://0001-Replace-u_intXX_t-with-kernel-typedefs.patch \ | 10 | file://0001-Use-asm-type.h-for-kernel-types.patch \ |
13 | " | 11 | " |
14 | 12 | ||
15 | UPSTREAM_CHECK_COMMITS = "1" | 13 | UPSTREAM_CHECK_COMMITS = "1" |