diff options
author | Athanasios Oikonomou <athoik@gmail.com> | 2017-10-22 01:16:32 +0300 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-11-15 16:30:50 -0800 |
commit | 62f1d7cfc39718a0a7aebccc9b4df67d4430b53a (patch) | |
tree | a615c4a28adc76433944401de610ceae07e4c863 /meta-filesystems | |
parent | 3594d16a15120626739a34541a3631303e6b766e (diff) | |
download | meta-openembedded-62f1d7cfc39718a0a7aebccc9b4df67d4430b53a.tar.gz |
smbnetfs: update update 0.5.3a -> 0.6.0
It seems that updating smbnetfs to latest revision fixes build issues.
Also remove the blacklist allowing the plugin to build again.
Patches reworked to apply on 0.6.0.
Additionally handle missing libexecinfo (DEPENDS and LDFLAGS)
when building with musl else we are getting the following error:
| ../../git/src/common.c:7:10: fatal error: execinfo.h: No such file or directory
| #include <execinfo.h>
Signed-off-by: Athanasios Oikonomou <athoik@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-filesystems')
3 files changed, 9 insertions, 8 deletions
diff --git a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/Using-PKG_CHECK_MODULES-to-found-headers-and-libraries.patch b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/Using-PKG_CHECK_MODULES-to-found-headers-and-libraries.patch index f05f09f61..371ab8982 100644 --- a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/Using-PKG_CHECK_MODULES-to-found-headers-and-libraries.patch +++ b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/Using-PKG_CHECK_MODULES-to-found-headers-and-libraries.patch | |||
@@ -10,10 +10,10 @@ Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> | |||
10 | src/Makefile.am | 3 +++ | 10 | src/Makefile.am | 3 +++ |
11 | 2 files changed, 8 insertions(+) | 11 | 2 files changed, 8 insertions(+) |
12 | 12 | ||
13 | diff --git a/configure.in b/configure.in | 13 | diff --git a/configure.ac b/configure.ac |
14 | index ce21aef..ecd7119 100644 | 14 | index ce21aef..ecd7119 100644 |
15 | --- a/configure.in | 15 | --- a/configure.ac |
16 | +++ b/configure.in | 16 | +++ b/configure.ac |
17 | @@ -125,6 +125,11 @@ AC_CHECK_LIB(smbclient, smbc_setOptionUserData, | 17 | @@ -125,6 +125,11 @@ AC_CHECK_LIB(smbclient, smbc_setOptionUserData, |
18 | )] | 18 | )] |
19 | ) | 19 | ) |
diff --git a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/configure.patch b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/configure.patch index c80fed187..152507cf3 100644 --- a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/configure.patch +++ b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/configure.patch | |||
@@ -1,9 +1,9 @@ | |||
1 | Index: git/configure.in | 1 | Index: git/configure.in |
2 | =================================================================== | 2 | =================================================================== |
3 | --- git.orig/configure.in 2014-06-18 16:06:16.040721349 +0000 | 3 | --- git.orig/configure.ac 2014-06-18 16:06:16.040721349 +0000 |
4 | +++ git/configure.in 2014-07-18 07:49:17.085552256 +0000 | 4 | +++ git/configure.ac 2014-07-18 07:49:17.085552256 +0000 |
5 | @@ -1,5 +1,5 @@ | 5 | @@ -1,5 +1,5 @@ |
6 | AC_INIT([SMBNetFS],[0.5.3а]) | 6 | AC_INIT([SMBNetFS],[0.6.0]) |
7 | -AM_INIT_AUTOMAKE | 7 | -AM_INIT_AUTOMAKE |
8 | +AM_INIT_AUTOMAKE([foreign]) | 8 | +AM_INIT_AUTOMAKE([foreign]) |
9 | AC_CONFIG_HEADERS([src/config.h]) | 9 | AC_CONFIG_HEADERS([src/config.h]) |
diff --git a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb index 6995ad3f5..0fcfd6ae7 100644 --- a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb +++ b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb | |||
@@ -9,12 +9,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" | |||
9 | HOMEPAGE ="http://sourceforge.net/projects/smbnetfs" | 9 | HOMEPAGE ="http://sourceforge.net/projects/smbnetfs" |
10 | 10 | ||
11 | DEPENDS = "fuse samba" | 11 | DEPENDS = "fuse samba" |
12 | DEPENDS_append_libc-musl = " libexecinfo" | ||
12 | 13 | ||
13 | inherit autotools gitpkgv pkgconfig | 14 | inherit autotools gitpkgv pkgconfig |
14 | 15 | ||
15 | PKGV = "${GITPKGVTAG}" | 16 | PKGV = "${GITPKGVTAG}" |
16 | 17 | ||
17 | SRCREV = "ace1c519d45fe488b9b7e6cc77a2bcadb6c83464" | 18 | SRCREV = "21c63ed60202e5540613d4c822a57a0b81764499" |
18 | 19 | ||
19 | SRC_URI = "git://smbnetfs.git.sourceforge.net/gitroot/smbnetfs/smbnetfs;branch=master \ | 20 | SRC_URI = "git://smbnetfs.git.sourceforge.net/gitroot/smbnetfs/smbnetfs;branch=master \ |
20 | file://configure.patch \ | 21 | file://configure.patch \ |
@@ -25,4 +26,4 @@ PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring=yes,--with-gnome-keyring=no | |||
25 | 26 | ||
26 | S = "${WORKDIR}/git" | 27 | S = "${WORKDIR}/git" |
27 | 28 | ||
28 | PNBLACKLIST[smbnetfs] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/132827/ - the recipe will be removed on 2017-09-01 unless the issue is fixed" | 29 | LDFLAGS_append_libc-musl = " -lexecinfo" |