diff options
author | Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com> | 2022-05-23 19:44:30 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-05-24 08:39:45 -0700 |
commit | 176eb22ba3e1bc8a3aa6874882730c5d04607bc4 (patch) | |
tree | 6e8b97cddabd08787df210d3e8ebd188684219ca /meta-filesystems | |
parent | 962e3a3c13255e5232e7156e5802bc7f40c7921d (diff) | |
download | meta-openembedded-176eb22ba3e1bc8a3aa6874882730c5d04607bc4.tar.gz |
overlayfs-progs: add new recipe
overlayfs-progs contains fsck.overlay, which is used to check and optionally
repair underlying directories of overlay-filesystem.
Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r-- | meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch | 30 | ||||
-rw-r--r-- | meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb | 32 |
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch b/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch new file mode 100644 index 000000000..d9f285d94 --- /dev/null +++ b/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 8eeaee82dcfdf47f16ad880e416b722827f41bdb Mon Sep 17 00:00:00 2001 | ||
2 | From: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com> | ||
3 | Date: Mon, 23 May 2022 19:37:32 +0200 | ||
4 | Subject: [PATCH] Makefile: proper location of LDFLAGS | ||
5 | |||
6 | Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com> | ||
7 | --- | ||
8 | Makefile | 4 ++-- | ||
9 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
10 | |||
11 | diff --git a/Makefile b/Makefile | ||
12 | index e3c5207..14b155e 100644 | ||
13 | --- a/Makefile | ||
14 | +++ b/Makefile | ||
15 | @@ -1,5 +1,5 @@ | ||
16 | CFLAGS = -Wall -g | ||
17 | -LFLAGS = -lm | ||
18 | +LDFLAGS = -lm | ||
19 | CC = gcc | ||
20 | |||
21 | all: overlay | ||
22 | @@ -7,7 +7,7 @@ all: overlay | ||
23 | objects = fsck.o common.o lib.o check.o mount.o path.o overlayfs.o | ||
24 | |||
25 | overlay: $(objects) | ||
26 | - $(CC) $(LFLAGS) $(objects) -o fsck.overlay | ||
27 | + $(CC) $(objects) -o fsck.overlay $(LDFLAGS) | ||
28 | |||
29 | .c.o: | ||
30 | $(CC) $(CFLAGS) -c $< | ||
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb b/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb new file mode 100644 index 000000000..9d58b9a63 --- /dev/null +++ b/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "File system check utility for OverlayFS" | ||
2 | HOMEPAGE = "https://github.com/hisilicon/overlayfs-progs" | ||
3 | LICENSE = "PD" | ||
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851" | ||
5 | |||
6 | SRC_URI = "\ | ||
7 | git://github.com/hisilicon/overlayfs-progs.git;protocol=https;branch=master \ | ||
8 | file://0001-Makefile-proper-location-of-LDFLAGS.patch \ | ||
9 | " | ||
10 | |||
11 | PV = "1.0+git${SRCPV}" | ||
12 | SRCREV = "e10ef686570d9c7eff42f52461593a5c15da56bd" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | B = "${S}" | ||
16 | |||
17 | # Required to have the fts.h header for musl | ||
18 | DEPENDS:append:libc-musl = " fts" | ||
19 | # Fix the missing fts libs when using musl | ||
20 | EXTRA_OEMAKE:append:libc-musl = " LDFLAGS='-lfts'" | ||
21 | |||
22 | EXTRA_OEMAKE += "'CC=${CC} -O2' " | ||
23 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
24 | |||
25 | do_compile () { | ||
26 | oe_runmake | ||
27 | } | ||
28 | |||
29 | do_install () { | ||
30 | install -d ${D}${bindir} | ||
31 | install -m 0755 ${B}/fsck.overlay ${D}${bindir} | ||
32 | } | ||