summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-11-06 23:06:39 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-22 13:38:14 +0100
commitc3dad0ba49c6f82519d5846be3eb12e65cae395c (patch)
treecffe918145d58e0e219d72cbf4d01dc2e08d2d42 /meta-filesystems
parent7f8915a6ecdd5c4b03c7e5b5f1fa903f89c2d560 (diff)
downloadmeta-openembedded-c3dad0ba49c6f82519d5846be3eb12e65cae395c.tar.gz
Revert "physfs: move to sources found at github/supertux"
This reverts commit 3bbec2b7921c83e13b64e808ef34122a608933f0. The commit was intended to make supertux in meta-games happy. Now I found out that: * other packets e.g meta-retro d1x-rebirth segfault with supertux version of physfs * supertux can be configured to use it's own physfs as static library To avoid package version counting backwards PE = 1 was added. The patch required for supertux was already applied in meta-games. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-support/physfs/files/0001-fix-build-with-gcc-6.patch52
-rw-r--r--meta-filesystems/recipes-support/physfs/physfs_2.0.3.bb13
-rw-r--r--meta-filesystems/recipes-support/physfs/physfs_git.bb15
3 files changed, 13 insertions, 67 deletions
diff --git a/meta-filesystems/recipes-support/physfs/files/0001-fix-build-with-gcc-6.patch b/meta-filesystems/recipes-support/physfs/files/0001-fix-build-with-gcc-6.patch
deleted file mode 100644
index 805c4a1f0..000000000
--- a/meta-filesystems/recipes-support/physfs/files/0001-fix-build-with-gcc-6.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1From 06fe4c205094e0b65d3e5d1244f52089ed5bdafb Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Sun, 25 Sep 2016 23:50:22 +0200
4Subject: [PATCH] fix build with gcc-6
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Pending
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 src/archiver_zip.c | 1 -
14 src/physfs_miniz.h | 3 +++
15 2 files changed, 3 insertions(+), 1 deletion(-)
16
17diff --git a/src/archiver_zip.c b/src/archiver_zip.c
18index 5c4996d..3b436db 100644
19--- a/src/archiver_zip.c
20+++ b/src/archiver_zip.c
21@@ -845,7 +845,6 @@ static ZIPentry *zip_hash_ancestors(ZIPinfo *info, char *name)
22 if (sep)
23 {
24 const size_t namelen = (sep - name) + 1;
25- ZIPentry *parent;
26
27 *sep = '\0'; /* chop off last piece. */
28 retval = zip_find_entry(info, name);
29diff --git a/src/physfs_miniz.h b/src/physfs_miniz.h
30index 619cb71..fd877c0 100644
31--- a/src/physfs_miniz.h
32+++ b/src/physfs_miniz.h
33@@ -194,6 +194,8 @@ struct tinfl_decompressor_tag
34 code_len = TINFL_FAST_LOOKUP_BITS; do { temp = (pHuff)->m_tree[~temp + ((bit_buf >> code_len++) & 1)]; } while (temp < 0); \
35 } sym = temp; bit_buf >>= code_len; num_bits -= code_len; } MZ_MACRO_END
36
37+#pragma GCC diagnostic push
38+#pragma GCC diagnostic ignored "-Wmisleading-indentation"
39 static tinfl_status tinfl_decompress(tinfl_decompressor *r, const mz_uint8 *pIn_buf_next, size_t *pIn_buf_size, mz_uint8 *pOut_buf_start, mz_uint8 *pOut_buf_next, size_t *pOut_buf_size, const mz_uint32 decomp_flags)
40 {
41 static const int s_length_base[31] = { 3,4,5,6,7,8,9,10,11,13, 15,17,19,23,27,31,35,43,51,59, 67,83,99,115,131,163,195,227,258,0,0 };
42@@ -465,6 +467,7 @@ common_exit:
43 }
44 return status;
45 }
46+#pragma GCC diagnostic pop
47
48 /* Flush values. For typical usage you only need MZ_NO_FLUSH and MZ_FINISH. The other stuff is for advanced use. */
49 enum { MZ_NO_FLUSH = 0, MZ_PARTIAL_FLUSH = 1, MZ_SYNC_FLUSH = 2, MZ_FULL_FLUSH = 3, MZ_FINISH = 4, MZ_BLOCK = 5 };
50--
512.5.5
52
diff --git a/meta-filesystems/recipes-support/physfs/physfs_2.0.3.bb b/meta-filesystems/recipes-support/physfs/physfs_2.0.3.bb
new file mode 100644
index 000000000..dc2c10649
--- /dev/null
+++ b/meta-filesystems/recipes-support/physfs/physfs_2.0.3.bb
@@ -0,0 +1,13 @@
1SUMMARY = "PhysicsFS is a library to provide abstract access to various archives"
2HOMEAPAGE = "http://icculus.org/physfs"
3LICENSE = "Zlib"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5d94e3eaaa10b00ca803ba35a3e87cde"
5DEPENDS = "readline zlib"
6
7inherit cmake
8
9PE = "1"
10
11SRC_URI = "http://icculus.org/${BPN}/downloads/${BP}.tar.bz2"
12SRC_URI[md5sum] = "c2c727a8a8deb623b521b52d0080f613"
13SRC_URI[sha256sum] = "ca862097c0fb451f2cacd286194d071289342c107b6fe69079c079883ff66b69"
diff --git a/meta-filesystems/recipes-support/physfs/physfs_git.bb b/meta-filesystems/recipes-support/physfs/physfs_git.bb
deleted file mode 100644
index a50715ce0..000000000
--- a/meta-filesystems/recipes-support/physfs/physfs_git.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1SUMMARY = "PhysicsFS is a library to provide abstract access to various archives"
2HOMEAPAGE = "http://icculus.org/physfs"
3LICENSE = "Zlib"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4424d2cfb8a288df2843c4467b5d719a"
5DEPENDS = "readline zlib"
6
7inherit cmake
8
9SRC_URI = " \
10 git://github.com/SuperTux/physfs.git \
11 file://0001-fix-build-with-gcc-6.patch \
12"
13SRCREV = "f3b45a94d0b7c0a85469b1e60fefd8383b6719ba"
14S = "${WORKDIR}/git"
15PV = "2.0.3+git${SRCPV}"